Bug 209092 - rcnetworr restart crashes nm-kde4 [SortedActivatableList::handleAdd, ActivatableList::addActivatableInternal, WirelessNetworkInterfaceActivatableProvider::handleAdd]
Summary: rcnetworr restart crashes nm-kde4 [SortedActivatableList::handleAdd, Activata...
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
: 212162 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-10-01 12:58 UTC by Alin M Elena
Modified: 2009-11-14 04:12 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alin M Elena 2009-10-01 12:58:10 UTC
Application: knetworkmanager (v0.9)
KDE Version: 4.3.69 (KDE 4.3.69 (KDE 4.4 >= 20090923)) "release 2"
Qt Version: 4.5.2
Operating System: Linux 2.6.31-10-desktop x86_64
Distribution: "openSUSE 11.2 Milestone 8 (x86_64)"

What I was doing when the application crashed:
rcnetworr restart crashes nm-kde4

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#5  0x00007f2d9926475a in Knm::Activatable::deviceUni() const () from /usr/lib64/libknminternals.so.4
#6  0x00007f2d9902cfbb in ?? () from /usr/lib64/libknmservice.so.4
#7  0x00007f2d9902d0b3 in ?? () from /usr/lib64/libknmservice.so.4
#8  0x00007f2d9902d30e in ?? () from /usr/lib64/libknmservice.so.4
#9  0x00007f2d9902d53d in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib64/libknmservice.so.4
#10 0x00007f2d9901e6fb in ActivatableList::addActivatableInternal(Knm::Activatable*) () from /usr/lib64/libknmservice.so.4
#11 0x00007f2d99022862 in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib64/libknmservice.so.4
#12 0x00007f2d99020210 in NetworkInterfaceActivatableProvider::init() () from /usr/lib64/libknmservice.so.4
#13 0x00007f2d9901ee68 in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib64/libknmservice.so.4
#14 0x00007f2d99019abd in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libknmservice.so.4
#15 0x00007f2d97aad91c in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
#16 0x00007f2d98b9e7b5 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x7fff80565830, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.3.69svn1027298/build/libs/solid/control/networkmanager.moc:101
#17 0x00007f2d98b9f18c in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x790510, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff80565fa0)
    at /usr/src/debug/kdebase-workspace-4.3.69svn1027298/build/libs/solid/control/networkmanager_p.moc:75
#18 0x00007f2d97aad91c in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
#19 0x00007f2d8b500db5 in NMNetworkManager::networkInterfaceAdded (this=0x7fff80565830, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.3.69svn1027298/build/solid/networkmanager-0.7/manager.moc:128
#20 0x00007f2d8b5014da in NMNetworkManager::deviceAdded (this=0x6ae9a0, objpath=...) at /usr/src/debug/kdebase-workspace-4.3.69svn1027298/solid/networkmanager-0.7/manager.cpp:199
#21 0x00007f2d8b502419 in NMNetworkManager::qt_metacall (this=0x6ae9a0, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff80566180)
    at /usr/src/debug/kdebase-workspace-4.3.69svn1027298/build/solid/networkmanager-0.7/manager.moc:105
#22 0x00007f2d97aad91c in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
#23 0x00007f2d8b50d762 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x7fff80565830, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.3.69svn1027298/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:149
#24 0x00007f2d8b50db8d in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x7e0630, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff805665e0)
    at /usr/src/debug/kdebase-workspace-4.3.69svn1027298/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:96
#25 0x00007f2d97dafe48 in ?? () from /usr/lib64/libQtDBus.so.4
#26 0x00007f2d97db743f in ?? () from /usr/lib64/libQtDBus.so.4
#27 0x00007f2d97aa7c39 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#28 0x00007f2d9819630c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#29 0x00007f2d9819d5de in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#30 0x00007f2d99690e76 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#31 0x00007f2d97a9876c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#32 0x00007f2d97a9934a in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#33 0x00007f2d97ac1073 in ?? () from /usr/lib64/libQtCore.so.4
#34 0x00007f2d93c91e6e in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#35 0x00007f2d93c95838 in ?? () from /usr/lib64/libglib-2.0.so.0
#36 0x00007f2d93c95960 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#37 0x00007f2d97ac0ce6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#38 0x00007f2d982292fe in ?? () from /usr/lib64/libQtGui.so.4
#39 0x00007f2d97a97072 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#40 0x00007f2d97a97444 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#41 0x00007f2d97a995f9 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#42 0x000000000040d0af in main (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/networkmanager/monolithic/main.cpp:45

Reported using DrKonqi
Comment 1 Dario Andres 2009-10-02 00:24:49 UTC
- What is your networkmanager package version ?

If you can reproduce the crash at will (or you experience this regularly), can you install the networkmanager debug package and post a complete backtrace here?

I wonder if this could be related to the backtrace in bug 202690. 
Thanks
Comment 2 Alin M Elena 2009-10-02 00:32:09 UTC
funny thing is that I have the debuginfo installed maybe I need others too. as the crash appears on 4.3.69 I won't worry to much about. I added it just for Will to have a track of them.

Alin
Comment 3 Dario Andres 2009-10-28 13:25:51 UTC
I wonder if this could be the same as bug 210878 (seems to have a better backtrace). Thanks
Comment 4 Dario Andres 2009-10-28 13:26:00 UTC
*** Bug 212162 has been marked as a duplicate of this bug. ***
Comment 5 Dario Andres 2009-11-14 04:12:06 UTC

*** This bug has been marked as a duplicate of bug 210878 ***