Bug 213666 - add refresh directory content button (shortut) to files tab
Summary: add refresh directory content button (shortut) to files tab
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: File Browser (show other bugs)
Version: 2.1.1
Platform: openSUSE RPMs Unspecified
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 283837 302238 320208 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-11-08 12:16 UTC by loigu
Modified: 2013-05-24 09:49 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.8


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description loigu 2009-11-08 12:16:50 UTC
Version:           2.1.1 (using KDE 4.3.1)
Installed from:    openSUSE RPMs

When using files tab, there is no 'refresh' button, so when directory content changes, there is need for going out of the folder and then back to refresh content.

This is very annoying for me, since I use nfs-mounted music library, so very often when starting amarok, the directory is empty (but amarok opens it) and after mount I must go out and back to view the content. F5 won't work either :/

thanks
Comment 1 cordawyn 2011-11-19 11:51:03 UTC
+1 for the feature. I have files on a local HDD (not NFS or anything), but occasionally, the file list is not refreshed. I could not reliably reproduce this bug and the only workaround for me is restarting Amarok (2.4.3). Until this bug is somehow hunted down, a "refresh" button would be helpful.
Comment 2 Triton Circonflexe 2012-03-01 18:00:30 UTC
Same problem on my side with NFS and local HDD.
Even when getting out of the directory and getting back in (using or not "previous" and "next" buttons.

OS : Gentoo/Linux x86_64 kernel 3.2.1-r2
Amarok 2.4.3-r1 with kdelibs 4.7.4
Comment 3 Myriam Schweingruber 2012-06-22 17:52:00 UTC
*** Bug 283837 has been marked as a duplicate of this bug. ***
Comment 4 Matěj Laitl 2012-12-15 10:01:27 UTC
*** Bug 302238 has been marked as a duplicate of this bug. ***
Comment 5 Abhinandan 2013-05-18 11:26:35 UTC
patch: https://git.reviewboard.kde.org/r/110498/
Comment 6 Mark Kretschmann 2013-05-24 09:35:36 UTC
*** Bug 320208 has been marked as a duplicate of this bug. ***
Comment 7 Mark Kretschmann 2013-05-24 09:49:12 UTC
Git commit 67920bdeb4342a483543a0f8dbabaaa06af17e2c by Mark Kretschmann, on behalf of Abhinandan Ramaprasath.
Committed on 24/05/2013 at 11:37.
Pushed by markey into branch 'master'.

Add refresh button to FileBrowser

A tiny patch that adds a refresh button to the file browser and maps "F5" key to refresh.
FIXED-IN: 2.8

M  +1    -0    ChangeLog
M  +11   -0    src/browsers/filebrowser/FileBrowser.cpp
M  +4    -0    src/browsers/filebrowser/FileBrowser.h
M  +1    -0    src/browsers/filebrowser/FileBrowser_p.h
M  +3    -0    src/browsers/filebrowser/FileView.cpp
M  +1    -0    src/browsers/filebrowser/FileView.h

http://commits.kde.org/amarok/67920bdeb4342a483543a0f8dbabaaa06af17e2c