Bug 213231 - Dolphin crashed after unmount of usb-device via plasma-widget
Summary: Dolphin crashed after unmount of usb-device via plasma-widget
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-05 12:37 UTC by Jonathan.Brons
Modified: 2009-11-05 15:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan.Brons 2009-11-05 12:37:59 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
- 2 dolphin windows open.
- copied large file (600mb) to usb-stick.
- immediately after file-copy complete i 'safely removed'/unmounted the usb-stick via the default plasma-widget in the taskbar.
=> dolphin crashes.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#5  QUrl (this=0x7fff68484fd0, other=...) at io/qurl.cpp:3936
#6  0x00007f45ace70fc9 in KUrl (this=0x7fff68484fd0, _u=...) at ../../kdecore/io/kurl.cpp:468
#7  0x00007f45aed19ec0 in KFileItem::url (this=<value optimized out>) at ../../kio/kio/kfileitem.cpp:1271
#8  0x00007f45aed0a6e4 in KDirModel::indexForItem (this=0x1189820, item=...) at ../../kio/kio/kdirmodel.cpp:919
#9  0x00007f45ae9ae920 in KFilePreviewGenerator::Private::orderItems (this=0x1198610, items=...) at ../../kfile/kfilepreviewgenerator.cpp:1023
#10 0x00007f45ae9b2622 in KFilePreviewGenerator::Private::updateIcons (this=0x1198610, items=...) at ../../kfile/kfilepreviewgenerator.cpp:508
#11 0x00007f45ae9b287f in KFilePreviewGenerator::Private::delayedIconUpdate (this=0x1198610) at ../../kfile/kfilepreviewgenerator.cpp:1088
#12 0x00007f45ae9b38f5 in KFilePreviewGenerator::qt_metacall (this=0x1198410, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff684852b0) at ./kfilepreviewgenerator.moc:95
#13 0x00007f45abc80ddc in QMetaObject::activate (sender=0x11985e0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x36f) at kernel/qobject.cpp:3113
#14 0x00007f45abc7ad83 in QObject::event (this=0x11985e0, e=0x10) at kernel/qobject.cpp:1075
#15 0x00007f45ac0feefc in QApplicationPrivate::notify_helper (this=0x956220, receiver=0x11985e0, e=0x7fff684858b0) at kernel/qapplication.cpp:4056
#16 0x00007f45ac1061ce in QApplication::notify (this=0x7fff68485c00, receiver=0x11985e0, e=0x7fff684858b0) at kernel/qapplication.cpp:4021
#17 0x00007f45ad433ab6 in KApplication::notify (this=0x7fff68485c00, receiver=0x11985e0, event=0x7fff684858b0) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x00007f45abc6bc2c in QCoreApplication::notifyInternal (this=0x7fff68485c00, receiver=0x11985e0, event=0x7fff684858b0) at kernel/qcoreapplication.cpp:610
#19 0x00007f45abc96862 in QCoreApplication::sendEvent (this=0x953a30) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QTimerInfoList::activateTimers (this=0x953a30) at kernel/qeventdispatcher_unix.cpp:572
#21 0x00007f45abc9425d in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
#22 0x00007f45a7789bbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007f45a778d588 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007f45a778d6b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007f45abc941a6 in QEventDispatcherGlib::processEvents (this=0x926d20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#26 0x00007f45ac1934be in QGuiEventDispatcherGlib::processEvents (this=0x7fff68484fd0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#27 0x00007f45abc6a532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007f45abc6a904 in QEventLoop::exec (this=0x7fff68485b50, flags=) at kernel/qeventloop.cpp:201
#29 0x00007f45abc6cab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0x0000000000439555 in _start ()

This bug may be a duplicate of or related to bug 213166

Reported using DrKonqi
Comment 1 Dario Andres 2009-11-05 15:14:56 UTC
Merging with bug 211525. Thanks

*** This bug has been marked as a duplicate of bug 211525 ***