Bug 212982 - kio_smb starts asking password for non-passworded share
Summary: kio_smb starts asking password for non-passworded share
Status: RESOLVED DUPLICATE of bug 209431
Alias: None
Product: kio
Classification: Unclassified
Component: smb (show other bugs)
Version: 4.3
Platform: unspecified Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-03 22:00 UTC by anton
Modified: 2017-10-28 15:34 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description anton 2009-11-03 22:00:37 UTC
Version:            (using KDE 4.3.2)
OS:                Linux
Installed from:    Unlisted Binary Package

Did try both with KDE4.3.1 and KDE4.3.2

Simple network with 2 computers - windows xp home, alt linux 5 with KDE4. Windows XP shares public directory inside workgroup opened for everybody.

Dolphin/Konqueror can see this directory perfectly, come inside shared subdirectories, see files and open them, but:

1. Come into shared directory (there should be one or more file in OpenOffice format)
2. Click on the document so it opens in OpenOffice - document opens ok - close the document
3. Click on the document 2nd time so it opens in OpenOffice - document opens ok - close the document
4. Click on the document the 3rd time - document does not open - instead I receive dialog suggesting to enter login/password for the share (and it does not accept logins/passwords for any account existing on windows machine); further clicking on the document shows error dialog "access denied to smb://xxx"

that's the problem

further diagnose:
1. open konsole
2. enter command ps -A | grep kio_smb - it would show 4 precesses - the 1st one corresponds to shred dir shown in dolphin, 3 others - to oo.org documents,
opened in OpenOffice (though they were closed long ago).
3. Kill 3 last processes one by one (keep the 1st one with dolphin)
4. Return to Dolphin and repeat all steps above - files would start open again, but only 2 times in a row - 3rd time brings password dialog again
5. (optionaly) one may kill only 2 last kio_smb processes instead of 3 (so 1 kio_smb for dolphin and 1 kio_smb for closed open office would be left) - so the document file would open only 1 time - the 2nd attempt would show password dialog, so 4 kio_smp processes seems to be magic number.

Manual mounting with cifsmount command gives no bugs.
Comment 1 Nate Graham 2017-10-28 15:34:35 UTC

*** This bug has been marked as a duplicate of bug 209431 ***