Bug 210762 - kate crashes without obvious cause
Summary: kate crashes without obvious cause
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-16 09:21 UTC by Hulahup
Modified: 2009-10-17 22:10 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hulahup 2009-10-16 09:21:23 UTC
Application that crashed: kate
Version of the application: 3.3.1
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.21.7-5.fc8xen x86_64
Distribution: "Fedora release 11 (Leonidas)"

 -- Backtrace:
Application: Kate (kate), signal: Segmentation fault
[KCrash Handler]
#5  KateSmartCursor::setPositionInternal (this=0x1082480, pos=@0x7fff6aa53c70, internal=true) at /usr/src/debug/kdelibs-4.3.1/kate/smart/katesmartcursor.cpp:186
#6  0x00002aaab270dd7f in KateSmartCursor::translate (this=0x1082480, edit=@0x122c180) at /usr/src/debug/kdelibs-4.3.1/kate/smart/katesmartcursor.cpp:305
#7  0x00002aaab271300c in KateSmartGroup::translateChanged (this=0x11e3e30, edit=@0x122c180) at /usr/src/debug/kdelibs-4.3.1/kate/smart/katesmartmanager.cpp:464
#8  0x00002aaab27166db in KateSmartManager::slotTextChanged (this=0x907600, edit=0x122c180) at /usr/src/debug/kdelibs-4.3.1/kate/smart/katesmartmanager.cpp:368
#9  0x00002aaab2716a44 in KateSmartManager::qt_metacall (this=0x907600, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff6aa53f10)
    at /usr/src/debug/kdelibs-4.3.1/x86_64-redhat-linux-gnu/kate/katesmartmanager.moc:74
#10 0x000000346ed547dc in QMetaObject::activate (sender=0x915b80, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x3463769e88) at kernel/qobject.cpp:3113
#11 0x00002aaab26e873f in KateEditHistory::editDone (this=0x7fff6aa53c70, _t1=0x122c180) at /usr/src/debug/kdelibs-4.3.1/x86_64-redhat-linux-gnu/kate/kateedit.moc:78
#12 0x00002aaab26d49a6 in KateDocument::editWrapLine (this=0x902020, line=106, col=2, newLine=<value optimized out>, newLineAdded=<value optimized out>)
    at /usr/src/debug/kdelibs-4.3.1/kate/document/katedocument.cpp:1281
#13 0x00002aaab26d64a9 in KateDocument::newLine (this=0x902020, v=0x962ab0) at /usr/src/debug/kdelibs-4.3.1/kate/document/katedocument.cpp:3877
#14 0x00002aaab275a8c1 in KateViewInternal::doReturn (this=0xbc4ed0) at /usr/src/debug/kdelibs-4.3.1/kate/view/kateviewinternal.cpp:808
#15 0x00002aaab275af84 in KateViewInternal::keyPressEvent (this=0xbc4ed0, e=0x7fff6aa54840) at /usr/src/debug/kdelibs-4.3.1/kate/view/kateviewinternal.cpp:2381
#16 0x00002aaab275a2fc in KateViewInternal::eventFilter (this=0xbc4ed0, obj=0xbc4ed0, e=0x7fff6aa54840) at /usr/src/debug/kdelibs-4.3.1/kate/view/kateviewinternal.cpp:2250
#17 0x000000346ed3e8e7 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0xbc4ed0, event=0x7fff6aa54840) at kernel/qcoreapplication.cpp:726
#18 0x000000347218f66c in QApplicationPrivate::notify_helper (this=0x625d00, receiver=0xbc4ed0, e=0x7fff6aa54840) at kernel/qapplication.cpp:4052
#19 0x0000003472197413 in QApplication::notify (this=<value optimized out>, receiver=0xbc4ed0, e=0x7fff6aa54840) at kernel/qapplication.cpp:3662
#20 0x0000003473611b56 in KApplication::notify (this=0x7fff6aa56a50, receiver=0xbc4ed0, event=0x7fff6aa54840) at /usr/src/debug/kdelibs-4.3.1/kdeui/kernel/kapplication.cpp:302
#21 0x000000346ed3f59c in QCoreApplication::notifyInternal (this=0x7fff6aa56a50, receiver=0xbc4ed0, event=0x7fff6aa54840) at kernel/qcoreapplication.cpp:610
#22 0x000000347221e8ba in QKeyMapper::sendKeyEvent (keyWidget=0xbc4ed0, grab=<value optimized out>, type=QEvent::KeyPress, code=16777220, modifiers=<value optimized out>, text=@0x7fff6aa54a60, 
    autorepeat=false, count=1, nativeScanCode=36, nativeVirtualKey=65293, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1861
#23 0x0000003472220e50 in QKeyMapperPrivate::translateKeyEvent (this=0x65bbc0, keyWidget=0xbc4ed0, event=<value optimized out>, grab=113) at kernel/qkeymapper_x11.cpp:1831
#24 0x00000034721fa4e4 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff6aa56620) at kernel/qapplication_x11.cpp:3438
#25 0x00000034722227dc in x11EventSourceDispatch (s=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#26 0x0000003464c3790e in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#27 0x0000003464c3b0e8 in ?? () from /lib64/libglib-2.0.so.0
#28 0x0000003464c3b20a in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#29 0x000000346ed67936 in QEventDispatcherGlib::processEvents (this=0x609190, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#30 0x0000003472221f8e in QGuiEventDispatcherGlib::processEvents (this=0x7fff6aa53c70, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#31 0x000000346ed3ded2 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 36}) at kernel/qeventloop.cpp:149
#32 0x000000346ed3e2a4 in QEventLoop::exec (this=0x7fff6aa56950, flags={i = 0}) at kernel/qeventloop.cpp:201
#33 0x000000346ed40439 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#34 0x0000003462a04aed in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdesdk-4.3.1/kate/app/katemain.cpp:257
#35 0x000000346341ea2d in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff6aa57c68) at libc-start.c:220
#36 0x00000000004006c9 in _start ()
Warning: the current language does not match this frame.

This bug may be a duplicate of or related to bug 209215

Reported using DrKonqi
Comment 1 Dario Andres 2009-10-17 22:10:35 UTC
Merging with bug 200450 (same backtrace) Thanks

*** This bug has been marked as a duplicate of bug 200450 ***