Bug 211778 - Dolphin don't update dir content
Summary: Dolphin don't update dir content
Status: RESOLVED DUPLICATE of bug 207361
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-25 14:47 UTC by Alexey Chernov
Modified: 2009-10-26 10:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Chernov 2009-10-25 14:47:48 UTC
Version:            (using KDE 4.3.2)
Compiler:          GCC 4.3.2 Target: x86_64-unknown-linux-gnu Configured with:  ../gcc-4.3.2/configure --prefix=/usr --libexecdir=/usr/lib --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu --enable-languages=c,c++,fortran,objc,treelang --disable-multilib --enable-c99 --enable-long-long Thread model: posix
OS:                Linux
Installed from:    Compiled From Sources

Dolphin don't see updates of directory if it's changed from another program or in console. The most reproducible way concerns Firefox built-in downloader. Here're the steps to reproduce:
1. Open directory where Firefox downloads files to in Dolphin. Keep it opened.
2. Start some download in Firefox using its built-in downloader. Wait for download to finish.
3. Switch to Dolphin window and mention that there's no such a file that was downloaded.
4. Press F5 and notice the file appeared.

DNotify and INotify (both legacy kernel and userspace) are (*) in kernel. Kernel version 2.6.31.2.
Comment 1 Frank Reininghaus 2009-10-25 15:47:21 UTC
Thanks for the report! This looks related to bug 211472, bug 211295. Which file system do you use?
Comment 2 Alexey Chernov 2009-10-25 15:52:57 UTC
I've noticed it for ext3, but didn't test on others..
Comment 3 Dario Andres 2009-10-25 22:57:52 UTC
This could also be related to bug 207361 which seems to affect Kernel 2.6.31+ 
@Frank: what do you think ?
Thanks
Comment 4 Alexey Chernov 2009-10-25 23:04:10 UTC
Yeah, Dario, you seems to be right, I've noticed that after upgrade to 2.6.31 but thought it's just coincidence because I also upgraded to 4.3.1 at almost the same time. I've read through the bug 207361, there were mentioned nVidia drivers, but I can confirm it for radeonhd so I don't think it's related to video drivers.
Comment 5 Dario Andres 2009-10-25 23:07:17 UTC
I also think it is unrelated to video drivers.
Merging. Thanks

*** This bug has been marked as a duplicate of bug 207361 ***
Comment 6 Frank Reininghaus 2009-10-26 10:06:49 UTC
@Darío: It's just amazing how well you know the issues in bugs.kde.org :-)