Bug 211295 - Konqueror 4-File view does not refresh often enough
Summary: Konqueror 4-File view does not refresh often enough
Status: RESOLVED DUPLICATE of bug 210284
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-21 05:00 UTC by Andrew Udvare
Modified: 2010-02-02 10:30 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Udvare 2009-10-21 05:00:43 UTC
Version:            (using KDE 4.3.2)
Compiler:          GCC 4.3.2 
OS:                Linux
Installed from:    Gentoo Packages

The file view in Konqueror is far too out of sync with moves, copies, and other operations that are done externally (such as a terminal or another file manager). I often have to refresh Konqueror. The interval that Konqueror refreshes itself is much too large. Perhaps this interval should be customisable? I find myself hitting the Refresh button a lot in Konqueror just to see what was just downloaded from Firefox.
Comment 1 Frank Reininghaus 2009-10-21 09:33:56 UTC
Thanks for the report. There is actually no "refresh interval" - Konqueror (or more precisely, the Dolphin view shown inside it) is supposed to be informed about any changes to files and then refreshed automatically.

If I create a file using a terminal or via a Firefox download, it gets shown immediately in Konqueror (used the Details view, but that should not matter), so I can't confirm.
Comment 2 Tommi Tervo 2009-10-21 10:53:01 UTC
Do you have fam or gamin installed?
Comment 3 Andrew Udvare 2009-10-21 17:51:15 UTC
I think this may be a problem with ntfs-3g, and maybe other file systems like vfat. The other issue is that in the directory tree EVERY folder on an ntfs-3g partition has a + expansion button even if no directories are inside that level directory.

I can confirm that this problem does not occur with ext3. Only my ntfs-3g partition does this where I have to refresh a lot and the aforementioned problem above.
Comment 4 Frank Reininghaus 2009-10-21 18:59:29 UTC
(In reply to comment #3)
> The other issue is that in the directory tree EVERY folder on an ntfs-3g
> partition has a + expansion button even if no directories are inside that level
> directory.

This is not NTFS-specific, see bug 171021.
Comment 5 FiNeX 2009-11-29 23:18:39 UTC
could this be a dup of bug #210284 ?
Comment 6 FiNeX 2009-12-05 17:25:02 UTC

*** This bug has been marked as a duplicate of bug 210284 ***
Comment 7 Ahmad Samir 2010-02-02 10:30:18 UTC
Both bugs are duplicates of bug #207361, which is closed as fixed in 4.3.5.