Bug 210179 - Splash screen hides KWallet dialog
Summary: Splash screen hides KWallet dialog
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.3-GIT
Platform: NetBSD pkgsrc NetBSD
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 210927 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-10-11 12:41 UTC by Thomas Klausner
Modified: 2009-10-18 15:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Klausner 2009-10-11 12:41:39 UTC
Version:           2.2.0 (using KDE 4.3.1)
Compiler:          gcc (GCC) 4.1.3 20080704 prerelease (NetBSD nb2 20081120) 
OS:                NetBSD
Installed from:    NetBSD pkgsrc

When I start up amarok-2.2.0, there's a splash screen; and behind it (after a few seconds) a window where it asks for my password (for last.fm).  At first I was confused because amarok just seemed to hang. Then I clicked away the splash screen and saw the entry box.

I'm using openbox as window manager. On the amarok mailing list, Christopher Schwartz reported that he sees the same problem with compiz/gnome 2.28 using amarok git from sunday Oct 4 2009, while Valentin Rouet doesn't see the problem with kwin/kde4.
Comment 1 Mark Kretschmann 2009-10-11 12:54:43 UTC
Hmm, I could swear I've seen this reported before. Maybe on the forum or so.
Comment 2 Mark Kretschmann 2009-10-11 12:55:57 UTC
That said... it's very likely that OpenBox is at fault here. It may not be fully compatible with the NetWM spec.

KWin is one of the most compatible window managers in this regard.
Comment 3 Mark Kretschmann 2009-10-11 13:28:33 UTC
Ok, a KWin developer said this:

"13:23 <lmurray> EWMH doesn't seem to state anything about the layering of splash windows"


So we probably need to fix this in Amarok, by hiding the splash explicitly when the wallet dialog comes up.
Comment 4 Mark Kretschmann 2009-10-11 14:20:49 UTC
I've fixed this:


commit 99ebf391215fd19607b8b84afb171fa93dc3fdc4
Author: Mark Kretschmann <kretschmann@kde.org>
Date:   Sun Oct 11 14:17:25 2009 +0200

    Hide the splash screen if Last.fm service opens config dialog (KWallet).

    NOTE: This needs to be ported to CredentialStorage too, if we resurrect
    that class.

    BUG: 210179
Comment 5 Thomas Klausner 2009-10-11 15:04:59 UTC
Thank you for fixing this, and so quickly as well!
Comment 6 Mark Kretschmann 2009-10-18 08:03:31 UTC
*** Bug 210927 has been marked as a duplicate of this bug. ***
Comment 7 James J. Dines 2009-10-18 13:59:09 UTC
I would like to close this in Mandriva bugzilla, but I would like to clarify your fix first.  Do you hide the splash screen if last.fm opens KWallet as described in your comment, or do you do so if *ANY* application opens KWallet?

Also, apologies for the duplicate bug, but "Amarok splash kwallet" yielded a Zeroo Bugs Found result when I searched the database :-(
Comment 8 Mark Kretschmann 2009-10-18 14:39:12 UTC
@James: Uhm, I'm not sure I understand your question.

Amarok now hides its splash screen before opening the KWallet dialog. That's what it does, no less, no more.
Comment 9 James J. Dines 2009-10-18 15:20:56 UTC
@Mark:  In comment #4 you include the commit message for commit commit 99ebf391215fd19607b8b84afb171fa93dc3fdc4, which states in part: " Hide the splash screen if Last.fm service opens config dialog (KWallet)."

I was just clarifying that you meant that it does so whenever *any* application opens KWallet, and not just last.fm

Thanks