Bug 209966 - Amarok dont update track name played from internet stream
Summary: Amarok dont update track name played from internet stream
Status: RESOLVED DUPLICATE of bug 211748
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.2.0
Platform: Fedora RPMs Linux
: NOR normal with 3 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-09 10:55 UTC by xapeiron
Modified: 2009-10-27 18:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Frozen track name (247.53 KB, image/png)
2009-10-27 14:34 UTC, xapeiron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xapeiron 2009-10-09 10:55:07 UTC
Version:           2.2.0 (using KDE 4.3.1)
OS:                Linux
Installed from:    Fedora RPMs

Every time I playing radio stream (http://www.play.cz/radio/danceradio128.ogg.m3u) 
Amarok sets name of the track just for the first time.

When radio change track/song, in Amarok remains name of first played track/song.

In another audio player, track names are updating as expected.
Comment 1 Piotr 'piter' Hlawski 2009-10-27 11:10:06 UTC
The same on my machine:

OS: Arch Linux 
KDE: 4.3.2
Amarok: 2.2.0
Stream URL: http://nerdcologne.de:8000/fresh.ogg
Comment 2 Mark Kretschmann 2009-10-27 13:49:36 UTC
Where exactly does it not update? We need to know that.
Comment 3 xapeiron 2009-10-27 14:34:03 UTC
Created attachment 37910 [details]
Frozen track name
Comment 4 xapeiron 2009-10-27 14:40:28 UTC
(In reply to comment #2)
> Where exactly does it not update? We need to know that.

On The screenshot above, I highlight where :-)

Try to play radio stream I mentioned above.
The radio changes track name when song is changed, but in Amarok (in Current track, Window title, etc.) is still track of the first song. 

When I try to play stream in VLC, track name is changed as expected.
Comment 5 Mark Kretschmann 2009-10-27 16:50:36 UTC
Which Phonon backed are you using?
Comment 6 Mark Kretschmann 2009-10-27 17:37:32 UTC
So I've actually just tested this, with Phonon-xine, KDE 4.3.2, Amarok 2.2-GIT. Amarok updates the metadata correctly.

I assume that you're using a different Phonon backend (perhaps GStreamer) which is buggy.
Comment 7 Piotr 'piter' Hlawski 2009-10-27 17:54:29 UTC
I'm using Amarok with Xine backend and it happens the same as xapeiron said. Amarok does not change track title - only the first one is displayed. Tested on http://nerdcologne.de:8000/fresh.ogg (Kohina fresh tunes)
Comment 8 xapeiron 2009-10-27 18:28:24 UTC
(In reply to comment #6)
> So I've actually just tested this, with Phonon-xine, KDE 4.3.2, Amarok 2.2-GIT.
> Amarok updates the metadata correctly.
> 
> I assume that you're using a different Phonon backend (perhaps GStreamer) which
> is buggy.

Hi, I'm currently using 
phonon-backend-xine-4.3.1-102.fc11
Amarok 2.2.0
KDE 4.3.2
Comment 9 Mark Kretschmann 2009-10-27 18:54:35 UTC
This could be related to BUG 211748, so I'm merging the reports.

*** This bug has been marked as a duplicate of bug 211748 ***