Bug 209601 - crash while using alt-tab; happens reasonably often (a few times a week)
Summary: crash while using alt-tab; happens reasonably often (a few times a week)
Status: RESOLVED DUPLICATE of bug 179865
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-06 06:35 UTC by maurice barnum
Modified: 2009-10-06 08:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description maurice barnum 2009-10-06 06:35:19 UTC
Application that crashed: kwin
Version of the application: 4.3.1 (KDE 4.3.1)
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.31.1 x86_64
Distribution: "Fedora release 11 (Leonidas)"

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#5  0x0000000001fa23b0 in ?? ()
#6  0x00007fc20f125be1 in KWin::WindowPaintData::WindowPaintData(struct KWin::EffectWindow *) (this=0x7fff5305fa90, w=0x1cf9f90) at /usr/src/debug/kdebase-workspace-4.3.1/kwin/lib/kwineffects.cpp:76
#7  0x00007fc1f4be6474 in KWin::BoxSwitchEffect::paintWindowThumbnail (this=0x1d78f50, w=0x1cf9f90) at /usr/src/debug/kdebase-workspace-4.3.1/kwin/effects/boxswitch/boxswitch.cpp:747
#8  0x00007fc1f4be8077 in KWin::BoxSwitchEffect::paintScreen (this=0x1d78f50, mask=0, region=<value optimized out>, data=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.3.1/kwin/effects/boxswitch/boxswitch.cpp:157
#9  0x00007fc20f6010eb in KWin::EffectsHandlerImpl::paintScreen (this=0x1ca5820, mask=0, region=
        {d = 0x1f2c7a0, static shared_empty = {ref = {_q_value = 588}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, data=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.3.1/kwin/effects.cpp:122
#10 0x00007fc20f123bbf in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=@0x7fff53060100)
    at /usr/src/debug/kdebase-workspace-4.3.1/kwin/lib/kwineffects.cpp:206
#11 0x00007fc20f6010eb in KWin::EffectsHandlerImpl::paintScreen (this=0x1ca5820, mask=0, region=
        {d = 0x1f2c7a0, static shared_empty = {ref = {_q_value = 588}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, data=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.3.1/kwin/effects.cpp:122
#12 0x00007fc20f123bbf in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=@0x7fff53060100)
    at /usr/src/debug/kdebase-workspace-4.3.1/kwin/lib/kwineffects.cpp:206
#13 0x00007fc20f6010eb in KWin::EffectsHandlerImpl::paintScreen (this=0x1ca5820, mask=0, region=
        {d = 0x1f2c7a0, static shared_empty = {ref = {_q_value = 588}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, data=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.3.1/kwin/effects.cpp:122
#14 0x00007fc1f4c4bf45 in KWin::TrackMouseEffect::paintScreen (this=0x1d3ff40, mask=0, region=
        {d = 0x1f2c7a0, static shared_empty = {ref = {_q_value = 588}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, data=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.3.1/kwin/effects/trackmouse/trackmouse.cpp:71
#15 0x00007fc20f6010eb in KWin::EffectsHandlerImpl::paintScreen (this=0x1ca5820, mask=0, region=
        {d = 0x1f2c7a0, static shared_empty = {ref = {_q_value = 588}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, data=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.3.1/kwin/effects.cpp:122
#16 0x00007fc20f5ec265 in KWin::Scene::paintScreen (this=0x1ca2300, mask=0x7fff5306027c, region=0x7fff53060390) at /usr/src/debug/kdebase-workspace-4.3.1/kwin/scene.cpp:134
#17 0x00007fc20f5fa924 in KWin::SceneOpenGL::paint (this=0x1ca2300, damage=<value optimized out>, toplevels=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.3.1/kwin/scene_opengl.cpp:746
#18 0x00007fc20f5e80de in KWin::Workspace::performCompositing (this=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.3.1/kwin/composite.cpp:420
#19 0x00007fc20f584666 in KWin::Workspace::qt_metacall (this=0x1c9d000, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff53060530)
    at /usr/src/debug/kdebase-workspace-4.3.1/x86_64-redhat-linux-gnu/kwin/workspace.moc:473
#20 0x00007fc20ccdf7dc in QMetaObject::activate (sender=0x1c9d428, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x1cf9f90) at kernel/qobject.cpp:3113
#21 0x00007fc20ccd97de in QObject::event (this=0x1c9d428, e=0x1cf9f90) at kernel/qobject.cpp:1075
#22 0x00007fc20d3b669c in QApplicationPrivate::notify_helper (this=0x19b6b50, receiver=0x1c9d428, e=0x7fff53060b30) at kernel/qapplication.cpp:4056
#23 0x00007fc20d3bd8fe in QApplication::notify (this=0x7fff53060e90, receiver=0x1c9d428, e=0x7fff53060b30) at kernel/qapplication.cpp:4021
#24 0x00007fc20e8d5b56 in KApplication::notify (this=0x7fff53060e90, receiver=0x1c9d428, event=0x7fff53060b30) at /usr/src/debug/kdelibs-4.3.1/kdeui/kernel/kapplication.cpp:302
#25 0x00007fc20ccca59c in QCoreApplication::notifyInternal (this=0x7fff53060e90, receiver=0x1c9d428, event=0x7fff53060b30) at kernel/qcoreapplication.cpp:610
#26 0x00007fc20ccf4fc2 in QCoreApplication::sendEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.h:213
#27 QTimerInfoList::activateTimers (event=<value optimized out>, receiver=<value optimized out>) at kernel/qeventdispatcher_unix.cpp:572
#28 0x00007fc20ccf29ed in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
#29 0x00007fc2056e790e in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#30 0x00007fc2056eb0e8 in ?? () from /lib64/libglib-2.0.so.0
#31 0x00007fc2056eb20a in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#32 0x00007fc20ccf2936 in QEventDispatcherGlib::processEvents (this=0x199dab0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#33 0x00007fc20d448f8e in QGuiEventDispatcherGlib::processEvents (this=0x1cf9f90, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#34 0x00007fc20ccc8ed2 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 36}) at kernel/qeventloop.cpp:149
#35 0x00007fc20ccc92a4 in QEventLoop::exec (this=0x7fff53060dd0, flags={i = 0}) at kernel/qeventloop.cpp:201
#36 0x00007fc20cccb439 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#37 0x00007fc20f59adb4 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.3.1/kwin/main.cpp:522
#38 0x00007fc209c47a2d in __libc_start_main () from /lib64/libc.so.6
#39 0x00000000004007a9 in _start ()

This bug may be a duplicate of or related to bug 204991

Reported using DrKonqi
Comment 1 Martin Flöser 2009-10-06 08:56:25 UTC
fixed in 4.3.2

*** This bug has been marked as a duplicate of bug 179865 ***