Bug 204991 - crash upon ALT-TAB to Mozilla Thunderbird (icedove)
Summary: crash upon ALT-TAB to Mozilla Thunderbird (icedove)
Status: RESOLVED DUPLICATE of bug 179865
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-24 18:19 UTC by Steffen Möller
Modified: 2009-08-24 18:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen Möller 2009-08-24 18:19:01 UTC
Application that crashed: kwin
Version of the application: 4.3.00 (KDE 4.3.0)
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-1-amd64 x86_64
Distribution: Debian GNU/Linux 4.0r8 (etch)

What I was doing when the application crashed:
the usual thing. I have just updated some KDE packages via apt-get update and have not yet rebooted. This might make a difference for your interpretation.

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#5  0x0000000001b49a70 in ?? ()
#6  0x00007f1784b99c87 in WindowPaintData (this=0x7ffff10aa370, w=0x20c0070) at ../../../kwin/lib/kwineffects.cpp:76
#7  0x00007f177857d8d7 in KWin::BoxSwitchEffect::paintWindowThumbnail (this=0x1d68ab0, w=0x20c0070) at ../../../kwin/effects/boxswitch/boxswitch.cpp:747
#8  0x00007f177857f58f in KWin::BoxSwitchEffect::paintScreen (this=0x1d68ab0, mask=8, region=..., data=<value optimized out>) at ../../../kwin/effects/boxswitch/boxswitch.cpp:157
#9  0x00007f1786036337 in KWin::EffectsHandlerImpl::paintScreen (this=0x1c833f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#10 0x00007f1784b97520 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:206
#11 0x00007f1786036337 in KWin::EffectsHandlerImpl::paintScreen (this=0x1c833f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#12 0x00007f17785b9565 in KWin::ZoomEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:73
#13 0x00007f1786036337 in KWin::EffectsHandlerImpl::paintScreen (this=0x1c833f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#14 0x00007f1786021f1a in KWin::Scene::paintScreen (this=0x1c82540, mask=0x7ffff10aaa8c, region=0x7ffff10aab90) at ../../kwin/scene.cpp:134
#15 0x00007f1786030a4f in KWin::SceneOpenGL::paint (this=0x1c82540, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:746
#16 0x00007f178601d386 in KWin::Workspace::performCompositing (this=0x1c78a90) at ../../kwin/composite.cpp:420
#17 0x00007f1785fb9b6a in KWin::Workspace::qt_metacall (this=0x1c78a90, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff10aad20) at ./workspace.moc:473
#18 0x00007f178219d682 in QMetaObject::activate (sender=0x1c78eb8, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x11) at kernel/qobject.cpp:3112
#19 0x00007f1782197bf3 in QObject::event (this=0x1c78eb8, e=0x20c0070) at kernel/qobject.cpp:1074
#20 0x00007f17828ca80d in QApplicationPrivate::notify_helper (this=0x1b632b0, receiver=0x1c78eb8, e=0x7ffff10ab3d0) at kernel/qapplication.cpp:4056
#21 0x00007f17828d286a in QApplication::notify (this=0x7ffff10ab740, receiver=0x1c78eb8, e=0x7ffff10ab3d0) at kernel/qapplication.cpp:4021
#22 0x00007f1785843b2b in KApplication::notify (this=0x7ffff10ab740, receiver=0x1c78eb8, event=0x7ffff10ab3d0) at ../../kdeui/kernel/kapplication.cpp:302
#23 0x00007f178218851c in QCoreApplication::notifyInternal (this=0x7ffff10ab740, receiver=0x1c78eb8, event=0x7ffff10ab3d0) at kernel/qcoreapplication.cpp:610
#24 0x00007f17821b4826 in QCoreApplication::sendEvent (this=0x1b67000) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#25 QTimerInfoList::activateTimers (this=0x1b67000) at kernel/qeventdispatcher_unix.cpp:572
#26 0x00007f17821b0c9d in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
#27 0x00007f177cb697aa in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#28 0x00007f177cb6cdf8 in ?? () from /usr/lib/libglib-2.0.so.0
#29 0x00007f177cb6cfac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#30 0x00007f17821b0bff in QEventDispatcherGlib::processEvents (this=0x1b496a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#31 0x00007f178296164f in QGuiEventDispatcherGlib::processEvents (this=0x20c0070, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#32 0x00007f1782186de2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007f17821871b4 in QEventLoop::exec (this=0x7ffff10ab680, flags=...) at kernel/qeventloop.cpp:201
#34 0x00007f1782189424 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#35 0x00007f1785fd18d8 in kdemain (argc=3, argv=0x7ffff10abc28) at ../../kwin/main.cpp:527
#36 0x00007f1785c5a5c6 in __libc_start_main (main=0x400710 <main>, argc=3, ubp_av=0x7ffff10abc28, init=0x400740 <__libc_csu_init>, fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7ffff10abc18) at libc-start.c:222
#37 0x0000000000400649 in _start () at ../sysdeps/x86_64/elf/start.S:113

Reported using DrKonqi
Comment 1 Martin Flöser 2009-08-24 18:33:30 UTC

*** This bug has been marked as a duplicate of bug 179865 ***