Bug 209376 - OSD show only on manual track change
Summary: OSD show only on manual track change
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Notifications (show other bugs)
Version: 2.3-GIT
Platform: Archlinux Packages Linux
: HI normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 210431 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-10-04 11:16 UTC by dory.thibault
Modified: 2009-10-13 14:19 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dory.thibault 2009-10-04 11:16:00 UTC
Version:           2.2 (using KDE 4.3.1)
OS:                Linux
Installed from:    Unspecified Linux

I'm using Amarok 2.2 on Archlinux 64bit and since first RC available in Arch I'm experiencing the same little bug.
The OSD does not appear when track change automaticaly at the end of a song, the only moment it appears is when I manualy change the track or change the volume.
This wasn't the case with Amarok 2.1

Please ask if you need more information.
Comment 1 Myriam Schweingruber 2009-10-04 12:09:59 UTC
This works fine for me in 2.2 (installed from tarball) on Kubuntu 9.04, KDE 4.3.1, might be a packaging issue?
Comment 2 dory.thibault 2009-10-04 12:14:03 UTC
Hum could be... I'm posting a bug on the Archlinux bugtracker too.
But this would be realy weird, I don't think they modify Amarok before compiling it. Is there any specific options (with ./configure for example) related to OSD when compiling Amarok?
Comment 3 Anthony Vital 2009-10-04 12:36:02 UTC
I can confirm, using debian packages.
Comment 4 dory.thibault 2009-10-05 15:39:26 UTC
I can confirm this is not a packaging problem, this problem does not appears on a computer's friend using the distro as me (64bit too).
I don't know what's special with my configuration, I've a nvidia card but so do he...
Comment 5 Mark Kretschmann 2009-10-05 16:55:21 UTC
You might be using different Phonon backends?
Comment 6 dory.thibault 2009-10-05 17:11:45 UTC
I'm using the xine backend, I always had problem with the gstreamer backend. Even right now I cannot get a sound from Amarok with the gstreamer backend even if the it work when I test sound in the system settings.
I'll ask my friend to know what backend he is using.
Comment 7 Mark Kretschmann 2009-10-10 15:38:49 UTC
Actually I can reproduce this now. Seems to be a regression.
Comment 8 Mark Kretschmann 2009-10-10 15:56:31 UTC
I think this commit may have caused the regression:


commit ba24bbf839143577713b3b256623a792a4028e0f
Author: Seb Ruiz <ruiz@kde.org>
Date:   Sun Jun 21 01:03:08 2009 +0000

    The OSD no longer subscribes to metadata changes. This fixes showing the
    osd when a track finishes (because finishedPlaying updates stats which
    notifies observers). It also fixes annoying problems of showing the osd
    when metadata changes (eg, editing a title) or the scanner updates a
    particular Track.

    svn path=/trunk/extragear/multimedia/amarok/; revision=984541
Comment 9 Mark Kretschmann 2009-10-10 16:10:39 UTC
Fixed it:

commit c5a8f3a019bce644a83dc110b5e41d281c0741e9
Author: Mark Kretschmann <kretschmann@kde.org>
Date:   Sat Oct 10 16:08:36 2009 +0200

    Regression fix: OSD was not shown on automatic track change.

    BUG: 209376
Comment 10 Kevin Funk 2009-10-13 14:19:31 UTC
*** Bug 210431 has been marked as a duplicate of this bug. ***