Bug 209115 - the boxswitch one - looked different somehow
Summary: the boxswitch one - looked different somehow
Status: RESOLVED DUPLICATE of bug 179865
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-01 16:41 UTC by Steffen Möller
Modified: 2009-10-01 21:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen Möller 2009-10-01 16:41:06 UTC
Application that crashed: kwin
Version of the application: 4.3.1 (KDE 4.3.1)
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-1-amd64 x86_64
Distribution: Debian GNU/Linux 4.0r8 (etch)

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#5  0x0000000001057a70 in ?? ()
#6  0x00007f47e71a5c87 in WindowPaintData (this=0x7fffd23e4ac0, w=0x13a9160) at ../../../kwin/lib/kwineffects.cpp:76
#7  0x00007f47dab828d7 in KWin::BoxSwitchEffect::paintWindowThumbnail (this=0x12777f0, w=0x13a9160) at ../../../kwin/effects/boxswitch/boxswitch.cpp:747
#8  0x00007f47dab8458f in KWin::BoxSwitchEffect::paintScreen (this=0x12777f0, mask=8, region=..., data=<value optimized out>) at ../../../kwin/effects/boxswitch/boxswitch.cpp:157
#9  0x00007f47e86442a7 in KWin::EffectsHandlerImpl::paintScreen (this=0x119b2f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#10 0x00007f47e71a3520 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:206
#11 0x00007f47e86442a7 in KWin::EffectsHandlerImpl::paintScreen (this=0x119b2f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#12 0x00007f47dabbe585 in KWin::ZoomEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:73
#13 0x00007f47e86442a7 in KWin::EffectsHandlerImpl::paintScreen (this=0x119b2f0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#14 0x00007f47e862f78a in KWin::Scene::paintScreen (this=0x1194570, mask=0x7fffd23e51dc, region=0x7fffd23e52f0) at ../../kwin/scene.cpp:134
#15 0x00007f47e863e47f in KWin::SceneOpenGL::paint (this=0x1194570, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:746
#16 0x00007f47e862a9d2 in KWin::Workspace::performCompositing (this=0x118a0f0) at ../../kwin/composite.cpp:420
#17 0x00007f47e85c6c3a in KWin::Workspace::qt_metacall (this=0x118a0f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd23e5480) at ./workspace.moc:473
#18 0x00007f47e47a6682 in QMetaObject::activate (sender=0x118a518, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x11) at kernel/qobject.cpp:3112
#19 0x00007f47e47a0bf3 in QObject::event (this=0x118a518, e=0x13a9160) at kernel/qobject.cpp:1074
#20 0x00007f47e4ed380d in QApplicationPrivate::notify_helper (this=0x10712a0, receiver=0x118a518, e=0x7fffd23e5b30) at kernel/qapplication.cpp:4056
#21 0x00007f47e4edb86a in QApplication::notify (this=0x7fffd23e5ea0, receiver=0x118a518, e=0x7fffd23e5b30) at kernel/qapplication.cpp:4021
#22 0x00007f47e7e5043b in KApplication::notify (this=0x7fffd23e5ea0, receiver=0x118a518, event=0x7fffd23e5b30) at ../../kdeui/kernel/kapplication.cpp:302
#23 0x00007f47e479151c in QCoreApplication::notifyInternal (this=0x7fffd23e5ea0, receiver=0x118a518, event=0x7fffd23e5b30) at kernel/qcoreapplication.cpp:610
#24 0x00007f47e47bd826 in QCoreApplication::sendEvent (this=0x1074fe0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#25 QTimerInfoList::activateTimers (this=0x1074fe0) at kernel/qeventdispatcher_unix.cpp:572
#26 0x00007f47e47b9c9d in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
#27 0x00007f47df16f12a in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#28 0x00007f47df172988 in ?? () from /lib/libglib-2.0.so.0
#29 0x00007f47df172b3c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#30 0x00007f47e47b9bff in QEventDispatcherGlib::processEvents (this=0x10576a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#31 0x00007f47e4f6a64f in QGuiEventDispatcherGlib::processEvents (this=0x13a9160, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#32 0x00007f47e478fde2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007f47e47901b4 in QEventLoop::exec (this=0x7fffd23e5de0, flags=...) at kernel/qeventloop.cpp:201
#34 0x00007f47e4792424 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#35 0x00007f47e85deae8 in kdemain (argc=3, argv=0x7fffd23e6388) at ../../kwin/main.cpp:522
#36 0x00007f47e82675c6 in __libc_start_main (main=0x400710 <main>, argc=3, ubp_av=0x7fffd23e6388, init=0x400740 <__libc_csu_init>, fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7fffd23e6378) at libc-start.c:222
#37 0x0000000000400649 in _start () at ../sysdeps/x86_64/elf/start.S:113

This bug may be a duplicate of or related to bug 205785

Reported using DrKonqi
Comment 1 Martin Flöser 2009-10-01 21:39:49 UTC

*** This bug has been marked as a duplicate of bug 179865 ***