Bug 205785 - The typical "change windows" ALT-TAB bug - just my KDE version was updated in the meantime
Summary: The typical "change windows" ALT-TAB bug - just my KDE version was updated in...
Status: RESOLVED DUPLICATE of bug 179865
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-31 14:17 UTC by Steffen Möller
Modified: 2009-09-01 16:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen Möller 2009-08-31 14:17:27 UTC
Application that crashed: kwin
Version of the application: 4.3.00 (KDE 4.3.0)
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-1-amd64 x86_64
Distribution: Debian GNU/Linux 4.0r8 (etch)

What I was doing when the application crashed:
nothing more to add - it is a duplicate

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#5  0x0000000000010000 in ?? ()
#6  0x00007f24c126dc87 in WindowPaintData (this=0x7fffa4eb3780, w=0x1440520) at ../../../kwin/lib/kwineffects.cpp:76
#7  0x00007f24b4c4b8d7 in KWin::BoxSwitchEffect::paintWindowThumbnail (this=0x13fe1b0, w=0x1440520) at ../../../kwin/effects/boxswitch/boxswitch.cpp:747
#8  0x00007f24b4c4d58f in KWin::BoxSwitchEffect::paintScreen (this=0x13fe1b0, mask=8, region=..., data=<value optimized out>) at ../../../kwin/effects/boxswitch/boxswitch.cpp:157
#9  0x00007f24c270a337 in KWin::EffectsHandlerImpl::paintScreen (this=0x134d550, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#10 0x00007f24c126b520 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:206
#11 0x00007f24c270a337 in KWin::EffectsHandlerImpl::paintScreen (this=0x134d550, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#12 0x00007f24b4c87565 in KWin::ZoomEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:73
#13 0x00007f24c270a337 in KWin::EffectsHandlerImpl::paintScreen (this=0x134d550, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#14 0x00007f24c26f5f1a in KWin::Scene::paintScreen (this=0x134b1c0, mask=0x7fffa4eb3e9c, region=0x7fffa4eb3fa0) at ../../kwin/scene.cpp:134
#15 0x00007f24c2704a4f in KWin::SceneOpenGL::paint (this=0x134b1c0, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:746
#16 0x00007f24c26f1386 in KWin::Workspace::performCompositing (this=0x1346290) at ../../kwin/composite.cpp:420
#17 0x00007f24c268db6a in KWin::Workspace::qt_metacall (this=0x1346290, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffa4eb4130) at ./workspace.moc:473
#18 0x00007f24be871682 in QMetaObject::activate (sender=0x13466b8, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x11) at kernel/qobject.cpp:3112
#19 0x00007f24be86bbf3 in QObject::event (this=0x13466b8, e=0x1440520) at kernel/qobject.cpp:1074
#20 0x00007f24bef9e80d in QApplicationPrivate::notify_helper (this=0x122f2b0, receiver=0x13466b8, e=0x7fffa4eb47e0) at kernel/qapplication.cpp:4056
#21 0x00007f24befa686a in QApplication::notify (this=0x7fffa4eb4b50, receiver=0x13466b8, e=0x7fffa4eb47e0) at kernel/qapplication.cpp:4021
#22 0x00007f24c1f17b2b in KApplication::notify (this=0x7fffa4eb4b50, receiver=0x13466b8, event=0x7fffa4eb47e0) at ../../kdeui/kernel/kapplication.cpp:302
#23 0x00007f24be85c51c in QCoreApplication::notifyInternal (this=0x7fffa4eb4b50, receiver=0x13466b8, event=0x7fffa4eb47e0) at kernel/qcoreapplication.cpp:610
#24 0x00007f24be888826 in QCoreApplication::sendEvent (this=0x1233000) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#25 QTimerInfoList::activateTimers (this=0x1233000) at kernel/qeventdispatcher_unix.cpp:572
#26 0x00007f24be884c9d in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
#27 0x00007f24b923d7aa in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#28 0x00007f24b9240df8 in ?? () from /usr/lib/libglib-2.0.so.0
#29 0x00007f24b9240fac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#30 0x00007f24be884bff in QEventDispatcherGlib::processEvents (this=0x12156a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#31 0x00007f24bf03564f in QGuiEventDispatcherGlib::processEvents (this=0x1440520, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#32 0x00007f24be85ade2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007f24be85b1b4 in QEventLoop::exec (this=0x7fffa4eb4a90, flags=...) at kernel/qeventloop.cpp:201
#34 0x00007f24be85d424 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#35 0x00007f24c26a58d8 in kdemain (argc=3, argv=0x7fffa4eb5038) at ../../kwin/main.cpp:527
#36 0x00007f24c232e5c6 in __libc_start_main (main=0x400710 <main>, argc=3, ubp_av=0x7fffa4eb5038, init=0x400740 <__libc_csu_init>, fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7fffa4eb5028) at libc-start.c:222
#37 0x0000000000400649 in _start () at ../sysdeps/x86_64/elf/start.S:113

This bug may be a duplicate of or related to bug 204991

Reported using DrKonqi
Comment 1 Martin Flöser 2009-09-01 16:16:39 UTC
*sigh* thanks for reporting a duplicate, if you know that it is a duplicate. It just took me about three minutes to set the duplicate mark. That's just wrong spent development time :-(

*** This bug has been marked as a duplicate of bug 179865 ***