Bug 204737 - kate crashes after accidentially hitting ctrl - enter
Summary: kate crashes after accidentially hitting ctrl - enter
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-22 08:36 UTC by Martin Schwinzerl
Modified: 2009-08-23 01:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Schwinzerl 2009-08-22 08:36:30 UTC
Application that crashed: kate
Version of the application: 3.3.0
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-ARCH i686

What I was doing when the application crashed:
I was editing files in a fairly large session ( ~50 files open at that particular moment) when I accidentially hit ctrl - enter, which send kate crashing. Operation prior to that point was normal and I'm not able to recreate the crash by typing the key combination in comparable circumstances, so the 
key pressing might have nothing to do with this particular crash.

 -- Backtrace:
Application: Kate (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0xb2cf697a in KateSmartCursor::setPositionInternal () from /usr/lib/kde4/katepart.so
#7  0xb2cf6d52 in KateSmartCursor::translate () from /usr/lib/kde4/katepart.so
#8  0xb2cfc1bf in KateSmartGroup::translateChanged () from /usr/lib/kde4/katepart.so
#9  0xb2cffa97 in KateSmartManager::slotTextChanged () from /usr/lib/kde4/katepart.so
#10 0xb2cffe2f in KateSmartManager::qt_metacall () from /usr/lib/kde4/katepart.so
#11 0xb7e9698c in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#12 0xb7e975c2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#13 0xb2cce173 in KateEditHistory::editDone () from /usr/lib/kde4/katepart.so
#14 0xb2cb8daa in KateDocument::editWrapLine () from /usr/lib/kde4/katepart.so
#15 0xb2cba99c in KateDocument::newLine () from /usr/lib/kde4/katepart.so
#16 0xb2d4c61c in KateViewInternal::doReturn () from /usr/lib/kde4/katepart.so
#17 0xb2d4cd40 in KateViewInternal::keyPressEvent () from /usr/lib/kde4/katepart.so
#18 0xb2d4bf39 in KateViewInternal::eventFilter () from /usr/lib/kde4/katepart.so
#19 0xb7e8011a in QCoreApplicationPrivate::sendThroughObjectEventFilters () from /usr/lib/libQtCore.so.4
#20 0xb6b0d69c in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#21 0xb6b15e21 in QApplication::notify () from /usr/lib/libQtGui.so.4
#22 0xb754ffaa in KApplication::notify () from /usr/lib/libkdeui.so.5
#23 0xb7e80fab in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#24 0xb6b0e59e in ?? () from /usr/lib/libQtGui.so.4
#25 0xb6ba7ccd in ?? () from /usr/lib/libQtGui.so.4
#26 0xb6baa15c in ?? () from /usr/lib/libQtGui.so.4
#27 0xb6b808f7 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4
#28 0xb6babc22 in ?? () from /usr/lib/libQtGui.so.4
#29 0xb6717d98 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#30 0xb671b3e0 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#31 0xb671b513 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#32 0xb7eab6ac in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#33 0xb6bab355 in ?? () from /usr/lib/libQtGui.so.4
#34 0xb7e7f559 in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#35 0xb7e7f9aa in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#36 0xb7e81e1f in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#37 0xb6b0d547 in QApplication::exec () from /usr/lib/libQtGui.so.4
#38 0xb5a74a8d in kdemain () from /usr/lib/libkdeinit4_kate.so
#39 0x0804de22 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-08-23 01:08:16 UTC
Merging with bug 200450 which seems to have a better backtrace. Thanks

*** This bug has been marked as a duplicate of bug 200450 ***