Bug 207133 - Konqueror crash on close.
Summary: Konqueror crash on close.
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-12 00:43 UTC by bencord0
Modified: 2009-09-12 16:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bencord0 2009-09-12 00:43:45 UTC
Application that crashed: konqueror
Version of the application: 4.3.1 (KDE 4.3.1)
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.1
Operating System: Linux 2.6.31-gentoo x86_64

What I was doing when the application crashed:
Closing Konqueror normally, crashes. I have recompiled all of kde with the debug use flag (I'm using gentoo).

I ran konqueror from commandline, navigated to google.co.uk and closed using the top right corner x button.
From the error messages posted to stdout, the bug is in kio cleaning up.

<---excerpt from output --->

konqueror(19660)/khtml (part) KHTMLPart::openUrl: KHTMLPart(0x8975e0) opening KUrl("http://www.google.co.uk/")                                                                               
konqueror(19660)/kio (Scheduler) KIO::SchedulerPrivate::findIdleSlave: Resume metadata is ""                                                                                                 
konqueror(19660)/kio (Scheduler) KIO::SchedulerPrivate::findIdleSlave: HOLD: Reusing held slave for KUrl("http://www.google.co.uk/")                                                         
konqueror(19660)/khtml (html) DOM::HTMLDocumentImpl::changeModes:  using compatibility parseMode                                                                                             
konqueror(19660)/khtml (html) DOM::HTMLDocumentImpl::changeModes:  using strict parseMode                                                                                                    
konqueror(19660)/kio (Slave) KIO::Slave::createSlave: createSlave "http" for KUrl("http://www.google.co.uk/intl/en_uk/images/logo.gif")                                                      
konqueror(19660)/kio (KIOConnection) KIO::ConnectionServer::listenForRemote: Listening on  "local:/tmp/ksocket-bencord0/konquerora19660.slave-socket"                                        
konqueror(19660)/kio (Slave) KIO::Slave::createSlave: createSlave "http" for KUrl("http://www.google.co.uk/extern_js/f/CgJlbhICdWsrMAo4NiwrMA44BywrMBg4BCwrMCU4yYgBLCswJjgFLCswJzgCLA/LjosnZMNP7c.js")
konqueror(19660)/kio (KIOConnection) KIO::ConnectionServer::listenForRemote: Listening on  "local:/tmp/ksocket-bencord0/konquerorS19660.slave-socket"                                                 
konqueror(19660)/kio (KIOJob) KIO::SlaveInterface::dispatch: error  160   ""                                                                                                                          
konqueror(19660)/kio (KIOJob) KIO::SlaveInterface::dispatch: error  160   ""                                                                                                                          
konqueror(19660) KonqMainWindow::addClosedWindowToUndoList:                                                                                                                                           
konqueror(19660) KonqClosedWindowItem::KonqClosedWindowItem: "Closed_Window10730256"                                                                                                                  

[skipping output]

konqueror(19660) KonqClosedWindowItem::KonqClosedWindowItem: "Closed_Window13889024"
konqueror(19660) KonqMainWindow::addClosedWindowToUndoList: done
konqueror(19660)/khtml (part) KHTMLPart::~KHTMLPart: KHTMLPart(0x8975e0)
konqueror(19660)/kparts KParts::Part::~Part: deleting widget QWidget(0x1230d50, name = "khtml_part_widget") "khtml_part_widget"
konqueror(19660) KonqMainWindow::checkPreloadResourceUsage: Running from tty, not keeping for preloading
konqueror(19660) KonqMainWindow::checkPreloadResourceUsage: Running from tty, not keeping for preloading
konqueror(19660)/khtml KHTMLFactory::~KHTMLFactory: KHTMLFactory(0xfbdcb0)
konqueror(19660)/khtml KHTMLGlobal::finalCheck: 1 docs not deleted
konqueror(19660)/khtml KHTMLGlobal::finalCheck: Document DOM::HTMLDocumentImpl(0xbfb830) wasn't deleted
konqueror: /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/khtml/khtml_global.cpp:258: static void KHTMLGlobal::finalCheck(): Assertion `!s_refcnt' failed.
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = konqueror path = <unknown> pid = 19660
sock_file=/home/bencord0/.kde4/socket-nutmeg/kdeinit4__0

[1]+  Stopped                 konqueror


 -- Backtrace:
Application: Konqueror (konqueror), signal: Aborted
[KCrash Handler]
#5  0x00007f30b3792c45 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#6  0x00007f30b3794070 in *__GI_abort () at abort.c:88
#7  0x00007f30b378bc8a in *__GI___assert_fail (assertion=0x7f30aa08c059 "!s_refcnt", file=<value optimized out>, line=258, function=0x7f30aa08c1e0 "static void KHTMLGlobal::finalCheck()")
    at assert.c:78
#8  0x00007f30a9d6826b in KHTMLGlobal::finalCheck () at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/khtml/khtml_global.cpp:258
#9  0x00007f30a500883a in ~KHTMLFactory (this=0xfbdcb0) at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/khtml/khtml_factory.cpp:35
#10 0x00007f30b6970b8e in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x121d220}, end={i = 0xa749b0}) at /usr/include/qt4/QtCore/qalgorithms.h:350
#11 0x00007f30b6970da9 in ~FactoryHash (this=0x4ccc) at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kdecore/util/klibrary.cpp:93
#12 0x00007f30b696ff52 in destroy () at /var/tmp/portage/kde-base/kdelibs-4.3.1/work/kdelibs-4.3.1/kdecore/util/klibrary.cpp:97
#13 0x00007f30b37956bd in *__GI_exit (status=0) at exit.c:75
#14 0x00007f30b377f5e4 in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fffad11cd08) at libc-start.c:258
#15 0x00000000004008f9 in _start ()

This bug may be a duplicate of or related to bug 206623

Reported using DrKonqi
Comment 1 Dario Andres 2009-09-12 16:33:03 UTC
Thanks

*** This bug has been marked as a duplicate of bug 151453 ***