Bug 206623 - Konqueror crash on close
Summary: Konqueror crash on close
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-07 13:47 UTC by rapsys
Modified: 2009-09-07 14:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rapsys 2009-09-07 13:47:51 UTC
Application that crashed: konqueror
Version of the application: 4.3.1 (KDE 4.3.1)
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-server-0.rc8.1mnb i686
Distribution: "Mandriva Linux 2010.0"

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Aborted
[KCrash Handler]
#6  0xffffe424 in __kernel_vsyscall ()
#7  0xb6810611 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#8  0xb6811f62 in abort () at abort.c:88
#9  0xb680969e in __assert_fail (assertion=0xb1c639c9 "!s_refcnt", file=0xb1c63938 "/home/mandrake/rpm/BUILD/kdelibs-4.3.1/khtml/khtml_global.cpp", line=258, 
    function=0xb1c63b40 "static void KHTMLGlobal::finalCheck()") at assert.c:78
#10 0xb18c2484 in KHTMLGlobal::finalCheck () at /usr/src/debug/kdelibs-4.3.1/khtml/khtml_global.cpp:258
#11 0xb221e0c5 in ~KHTMLFactory (this=0xa0968c0) at /usr/src/debug/kdelibs-4.3.1/khtml/khtml_factory.cpp:35
#12 0xb7fd15de in QObjectCleanupHandler::clear (this=0x9d1bf30) at kernel/qobjectcleanuphandler.cpp:140
#13 0xb7fd1631 in ~QObjectCleanupHandler (this=0x9d1bf30) at kernel/qobjectcleanuphandler.cpp:86
#14 0xb7db481d in destroy () at /usr/src/debug/kdelibs-4.3.1/kdecore/util/kpluginfactory.cpp:29
#15 0xb7c825d9 in ~KCleanUpGlobalStatic (this=0xb7e5c474) at /usr/src/debug/kdelibs-4.3.1/kdecore/kernel/kglobal.h:62
#16 0xb68136df in __run_exit_handlers (status=0, listp=0xb6944304, run_list_atexit=true) at exit.c:78
#17 0xb681374f in exit (status=0) at exit.c:100
#18 0x0804dbb0 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x9c8db4f "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8051ba4 "0") at /usr/src/debug/kdelibs-4.3.1/kinit/kinit.cpp:677
#19 0x0804e2ed in handle_launcher_request (sock=8, who=<value optimized out>) at /usr/src/debug/kdelibs-4.3.1/kinit/kinit.cpp:1169
#20 0x0804f04c in handle_requests (waitForPid=<value optimized out>) at /usr/src/debug/kdelibs-4.3.1/kinit/kinit.cpp:1362
#21 0x0804f8c5 in main (argc=2, argv=0xbf955b74, envp=0xbf955b80) at /usr/src/debug/kdelibs-4.3.1/kinit/kinit.cpp:1793

Reported using DrKonqi
Comment 1 Dario Andres 2009-09-07 14:00:36 UTC
Thanks

*** This bug has been marked as a duplicate of bug 151453 ***