Bug 206884 - Ark : can't open password protected 7zip and RAR archives
Summary: Ark : can't open password protected 7zip and RAR archives
Status: RESOLVED DUPLICATE of bug 35371
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal with 151 votes (vote)
Target Milestone: ---
Assignee: Harald Hvaal
URL:
Keywords:
: 188556 234638 235382 (view as bug list)
Depends on:
Blocks: 35371
  Show dependency treegraph
 
Reported: 2009-09-09 18:55 UTC by the.tux.l33t
Modified: 2013-11-28 07:07 UTC (History)
15 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Sample of full encrypted 7z archive for Ark testing. password: 123456 (18.60 KB, application/x-7z-compressed)
2009-09-10 13:08 UTC, the.tux.l33t
Details
Sample of full encrypted RAR archive for Ark testing. password: 123456 (18.44 KB, application/x-rar)
2009-09-10 13:10 UTC, the.tux.l33t
Details

Note You need to log in before you can comment on or make changes to this bug.
Description the.tux.l33t 2009-09-09 18:55:21 UTC
Version:            (using KDE 4.3.1)
OS:                Linux
Installed from:    Unspecified Linux

I tried to open some password protected 7zip and RAR archives but Ark can't open it. There is Loading archive... progress bar going left and right, but nothing happens. I try opening password protected archives with other archive managers (e.g. File Roller) and it works (it ask's for password), so probably there is some error in Ark.

Ark Version 2.13, KDE 4.3.1
Comment 1 Raphael Kubo da Costa 2009-09-09 20:12:18 UTC
Can you attach sample 7zip and RAR files that do not work with their passwords?
Comment 2 the.tux.l33t 2009-09-10 13:08:21 UTC
Created attachment 36840 [details]
Sample of full encrypted 7z archive for Ark testing.

password: 123456

Ark can't open and extract full encrypted 7z archive.
Comment 3 the.tux.l33t 2009-09-10 13:10:03 UTC
Created attachment 36841 [details]
Sample of full encrypted RAR archive for Ark testing.
password: 123456

Ark can't open and extract full encrypted RAR archive.
Comment 4 the.tux.l33t 2009-09-10 13:15:40 UTC
(In reply to comment #1)
> Can you attach sample 7zip and RAR files that do not work with their passwords?

OK, password: 123456

It seems that Ark have problems with full encrypted archives (RAR and 7zip "Encrypt file names" option). This archives request password, before viewing and extracting their contents.

With normal encryption, Ark can open archive, and extract archive contents.
Comment 5 Raphael Kubo da Costa 2009-09-12 05:43:14 UTC
*** Bug 188556 has been marked as a duplicate of this bug. ***
Comment 6 Raphael Kubo da Costa 2009-09-12 05:44:34 UTC
OK, this is actually a generalization of bug 188556, which only mentioned header-protected RAR archives.

Since this report is more general and contains attached test cases, I'm marking the other one as a duplicate of this one. Thanks!
Comment 7 Alfonso Tarantini 2009-10-12 23:20:42 UTC
Isn't the problem "upstream"?
I mean, how is Ark supposed to know that 7z wants a password if 7z just hangs prompting for input. There should be an option in 7z to make it return immediately if a password is needed.
A workaround would be an "open with password" command in the Ark File menu (and/or in context menus). Ugly though.
I'm looking into this bug because I find the "Encrypt file names" option quite useful.
Comment 8 kioftes 2010-01-29 21:07:16 UTC
Same problem here....never managed to unpack any password protected rar file with ark....it works however smoothly using the command line....
Comment 9 Kyrill Detinov 2010-04-11 19:30:54 UTC
Ark v2.14, KDE SC 4.4.2.
Ark still doesn't open RAR archives with encrypted headers.
Comment 10 Luke 2010-04-13 03:44:21 UTC
ark still doesn't open passoword protected rar archives, this is ridiculous - this bug is rolling for almost a decade now
 
kde 4.4.2, archlinux 2.6.33, ark 2.14, qt 4.6.2, unrar 3.93
Comment 11 EGD 2010-04-13 17:37:55 UTC
i reproduce this bug.

i use kde 4.4.2, ark 4.4.2, qt 4.6.2, unrar 3.90.4
Comment 12 Raphael Kubo da Costa 2010-04-18 00:04:32 UTC
*** Bug 234638 has been marked as a duplicate of this bug. ***
Comment 13 Raphael Kubo da Costa 2010-04-25 21:40:22 UTC
*** Bug 235382 has been marked as a duplicate of this bug. ***
Comment 14 76jplvqw7t 2010-04-27 19:46:07 UTC
For ark-kdeutils 3.X series submitted a patch.
I know it is different program, but same logi may apply.
See: 
http://bugs.pearsoncomputing.net/show_bug.cgi?id=181
Still no password suuport for 7z but header encrypted RARs now get correctly opened/extracted (ark kde3)
Comment 15 zazy 2010-06-07 16:02:26 UTC
Almost one full year and no solutions... neither an ugly one... nothing at all. These are things bringing people away from Linux and KDE. KDE packages quality is rapidly degrading :-(
Comment 16 Ezio Vergine 2010-06-20 13:56:41 UTC
same problem. Ok i can use console and unrar program but is a big problem for newbie. Fileroller (gnome archive manager) work but i hate gtk program.
Comment 17 Alexey Shildyakov 2010-06-20 19:41:12 UTC
Possibly this is duplicate of the bug 35371
Comment 18 Florian Hubold 2010-06-21 16:20:01 UTC
(In reply to comment #16)
> Fileroller (gnome archive manager) work but i hate gtk program.

I don't get it. This bug has 265 votes, and is open for 9 months. 
And another FLOSS program gets it right, but Ark can't do the same?


Could we pretty please get this fixed?
Comment 19 Raphael Kubo da Costa 2010-06-25 16:37:09 UTC
Merging with bug 35371.

*** This bug has been marked as a duplicate of bug 35371 ***
Comment 20 Manuel 2013-11-28 07:04:34 UTC
Is this still open? If I try to open the attached samples the file content is not shown. There is also no question for the password.
Comment 21 Manuel 2013-11-28 07:07:06 UTC
Sorry,   I was mislead by the crossed out bug 35371 link.