Bug 206852 - kmail thinks unencrypted attachments are encrypted/signed
Summary: kmail thinks unencrypted attachments are encrypted/signed
Status: RESOLVED DUPLICATE of bug 195683
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-09 12:41 UTC by James Bhatt
Modified: 2009-09-28 17:03 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Bhatt 2009-09-09 12:41:10 UTC
Version:            (using KDE 4.3.1)
OS:                Linux
Installed from:    SuSE RPMs

I receive an unencrypted email with an unencrypted attachment (tested: .rar, .ods, .docx filetypes) using an IMAP account.

I can read the email just fine, attachments are listed as usual.  I know the attachment is unencrypted because I sent it myself from another (web based) account.

Clicking or right-clicking the attachment and choosing to save the attachment opens KDE4 file-picker.

Choose 'Save' to save it wherever.  

Kmail asks two questions on after the other. From memory the text is:
First: 'Attachment part <name> is encrypted.  Do you want to keep the encryption?' (Yes, No)
Second: 'Attachment part <name> has a signature. Do you want to keep the signature?' (Yes, No)

If I click Yes to either of these questions, kmail crashes.  If I click No to both, kmail saves a zero byte file.

If I instead choose to open the attachment with the associated application (eg Ark, OpenOffice) from within kmail without saving it, the attachment opens in the application just fine.

I have 3 Identities, each with 1 IMAP account each.  My default identity had encryption set up using gpg.  Before this, saving attachments used to work. Not sure if this was the cause of the problem so I removed all encryption stuff from that identity.

Problem still happens on the default identity, and it also happens on any other account/identity, even though those have never been set up to use encryption.

Using kmail standalone, from the openSUSE 11.1 KDE4 Factory repos, 32bit arch.
Comment 1 James Bhatt 2009-09-09 12:43:06 UTC
Forgot to say, I posted on the opensuse forums here: http://forums.opensuse.org/applications/421501-kmail-thinks-attachment-encrypted.html
Comment 2 Nicky726 2009-09-12 02:22:22 UTC
I can confirm this on Arch Linux current 64bit KDEmod 4.3.1 and previous. I use just one identity and it doesn't have encription set up.
Comment 3 Nicky726 2009-09-12 02:57:11 UTC
Seems to be related to <a href="https://bugs.kde.org/show_bug.cgi?id=195683">bug 195683</a>.
Comment 4 Will Stephenson 2009-09-28 17:03:19 UTC
Du-du-dupe

*** This bug has been marked as a duplicate of bug 195683 ***