Bug 195683 - kmail crashes saving attachment / saves empty file
Summary: kmail crashes saving attachment / saves empty file
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: 1.11.90
Platform: Unlisted Binaries Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 196865 201261 206852 213971 238016 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-06-08 16:37 UTC by Mike71
Modified: 2012-08-19 10:52 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike71 2009-06-08 16:37:30 UTC
Application that crashed: kontact
Version of the application: 4.3.0 pre
KDE Version: 4.2.88 (KDE 4.2.88 (KDE 4.3 >= 20090527)) "release 135"
Qt Version: 4.5.1
Operating System: Linux 2.6.27.21-0.1-default x86_64
Distribution: "openSUSE 11.1 (x86_64)"

What I was doing when the application crashed:
I received an email with a .zip-File attached. I can open it from kmail and the archive seems fine.
When I try to save it I am asked if I want to keep the encryption and the signature of the file. This I already find odd since I am quite sure that there is neither a signature nor any encryption involved.

Anyway, when I select to not keep the signature and encryption, the file is saved empty, ie. it has 0B file size. If I choose to keep both, then Kmail crashes either after the second question (signature) and sometimes after the first. This happened in all but one cases (I tried a lot)

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  0x00007f533e5c2d3e in memcpy () from /lib64/libc.so.6
#6  0x00007f53403daca4 in QByteArray::realloc (this=0x11767b8, alloc=4) at /usr/include/bits/string3.h:52
#7  0x00007f53403db821 in QByteArray::operator= (this=0x11767b8, str=0x7f532cc10d05 "text") at tools/qbytearray.cpp:873
#8  0x00007f532c77b9e9 in KMMessagePart::clear (this=0x11767a8) at /usr/src/debug/kdepim-4.2.88svn973768/kmail/kmmsgpart.cpp:66
#9  0x00007f532c66adca in KMMessage::bodyPart (aDwBodyPart=0x13175d0, aPart=0x0, withBody=true) at /usr/src/debug/kdepim-4.2.88svn973768/kmail/kmmessage.cpp:2712
#10 0x00007f532c90e5a9 in KMSaveAttachmentsCommand::saveItem (this=0x1643710, node=0x1176780, url=@0x7fff4ce2d220) at /usr/src/debug/kdepim-4.2.88svn973768/kmail/partNode.h:99
#11 0x00007f532c90fbed in KMSaveAttachmentsCommand::slotSaveAll (this=0x1643710) at /usr/src/debug/kdepim-4.2.88svn973768/kmail/kmcommands.cpp:2526
#12 0x00007f532c91232d in KMSaveAttachmentsCommand::qt_metacall (this=0x1643710, _c=QMetaObject::InvokeMetaMethod, _id=24335208, _a=<value optimized out>)
    at /usr/src/debug/kdepim-4.2.88svn973768/build/kmail/kmcommands.moc:799
#13 0x00007f53404d6c22 in QMetaObject::activate (sender=0x1556260, from_signal_index=<value optimized out>, to_signal_index=13, argv=0x3) at kernel/qobject.cpp:3120
#14 0x00007f532c8f86a9 in KMLoadPartsCommand::execute (this=0x1735368) at /usr/src/debug/kdepim-4.2.88svn973768/kmail/kmcommands.cpp:2745
#15 0x00007f532c912b6c in KMLoadPartsCommand::slotStart (this=0x1556260) at /usr/src/debug/kdepim-4.2.88svn973768/kmail/kmcommands.cpp:2720
#16 0x00007f532c904482 in KMCommand::qt_metacall (this=0x1556260, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff4ce2daa0)
    at /usr/src/debug/kdepim-4.2.88svn973768/build/kmail/kmcommands.moc:86
#17 0x00007f532c904636 in KMLoadPartsCommand::qt_metacall (this=0x1735368, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x3) at /usr/src/debug/kdepim-4.2.88svn973768/build/kmail/kmcommands.moc:1852
#18 0x00007f53404d6c22 in QMetaObject::activate (sender=0x1576d50, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x3) at kernel/qobject.cpp:3120
#19 0x00007f53404dbf9f in QSingleShotTimer::timerEvent (this=0x1576d50) at kernel/qtimer.cpp:298
#20 0x00007f53404d0f43 in QObject::event (this=0x1576d50, e=0x0) at kernel/qobject.cpp:1082
#21 0x00007f533f1b478d in QApplicationPrivate::notify_helper (this=0x649390, receiver=0x1576d50, e=0x7fff4ce2e1a0) at kernel/qapplication.cpp:4057
#22 0x00007f533f1bca2a in QApplication::notify (this=0x7fff4ce2e5a0, receiver=0x1576d50, e=0x7fff4ce2e1a0) at kernel/qapplication.cpp:4022
#23 0x00007f53412fc04b in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#24 0x00007f53404c115c in QCoreApplication::notifyInternal (this=0x7fff4ce2e5a0, receiver=0x1576d50, event=0x7fff4ce2e1a0) at kernel/qcoreapplication.cpp:610
#25 0x00007f53404ee5c0 in QTimerInfoList::activateTimers (this=0x6390e0) at kernel/qcoreapplication.h:213
#26 0x00007f53404ea93d in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:164
#27 0x00007f5339d6c0fb in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#28 0x00007f5339d6f8cd in ?? () from /usr/lib64/libglib-2.0.so.0
#29 0x00007f5339d6fa8b in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#30 0x00007f53404ea89f in QEventDispatcherGlib::processEvents (this=0x60df60, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:324
#31 0x00007f533f24bb0f in QGuiEventDispatcherGlib::processEvents (this=0x1735368, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#32 0x00007f53404bf9f2 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 1289938112}) at kernel/qeventloop.cpp:149
#33 0x00007f53404bfdbd in QEventLoop::exec (this=0x7fff4ce2e500, flags={i = 1289938192}) at kernel/qeventloop.cpp:200
#34 0x00007f53404c20a4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#35 0x0000000000404995 in main (argc=1, argv=0x7fff4ce2ec88) at /usr/src/debug/kdepim-4.2.88svn973768/kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-07-06 19:05:57 UTC
*** Bug 196865 has been marked as a duplicate of this bug. ***
Comment 2 Christophe Giboudeaux 2009-07-23 19:19:56 UTC
*** Bug 201261 has been marked as a duplicate of this bug. ***
Comment 3 Will Stephenson 2009-09-28 17:03:19 UTC
*** Bug 206852 has been marked as a duplicate of this bug. ***
Comment 4 Christophe Giboudeaux 2009-11-12 23:42:26 UTC
*** Bug 213971 has been marked as a duplicate of this bug. ***
Comment 5 Christophe Giboudeaux 2011-02-14 13:40:18 UTC
*** Bug 238016 has been marked as a duplicate of this bug. ***
Comment 6 Myriam Schweingruber 2012-08-19 10:52:18 UTC
Thank you for your report. Kmail1 is currently unmaintained and the code has changed sufficiently in Kmail2 so the backtraces are not really useful anymore. Should you experience the same crash in Kmail 4.8.5 or later, please open a new report for Kmail2. Thank you for your understanding