Bug 206312 - video preview widget doesn't always offer playback
Summary: video preview widget doesn't always offer playback
Status: RESOLVED DUPLICATE of bug 252539
Alias: None
Product: kdemultimedia
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Multimedia Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-05 01:52 UTC by Sladjan
Modified: 2012-08-15 11:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sladjan 2009-09-05 01:52:01 UTC
Version:           1.3 (using 4.3.1 (KDE 4.3.1), Debian packages)
Compiler:          cc
OS:                Linux (x86_64) release 2.6.30-1-amd64

Hi,

(I have installed the mplayerthumbs 4:4.3.1-1 package too if that's important.)

The preview widget in Dolphin doesn't always show the playback button. Instead a slideshow is shown displaying frames of the video (correctly).

It seems that this is related to mp4 files by Youtube. I downloaded them with a script:
javascript:if(document.location.href.match(/http:\/\/[a-zA-Z\.]*youtube\.com\/watch/)){document.location.href='http://www.youtube.com/get_video?fmt='+(isHDAvailable?'22':'18')+'&video_id='+swfArgs['video_id']+'&t='+swfArgs['t']}

When I go to another filetype first (avi, mp3) I do always get the playback button. After I trying another filetype like this, the button will show up for mp4 files too. When I close all Dolphin windows now I have to do this again for a new instance of Dolphin.

Regards,
Sladi
Comment 1 FiNeX 2009-12-01 10:42:40 UTC
Is this bug related to bug #198994?
Comment 2 Jekyll Wu 2012-01-06 03:54:35 UTC
I can reproduce the reported problem using KDE SC 4.8 RC2. 

It happens to every mp4 files I have tried. The problem disappears after previewing other files(mkv,avi,etc). Switching phonon backends does not make difference.
Comment 3 Jekyll Wu 2012-01-08 03:18:41 UTC
maybe related with bug 252539.
Comment 4 Jekyll Wu 2012-08-15 11:11:53 UTC
Should be also fixed by the commit for bug 252539

*** This bug has been marked as a duplicate of bug 252539 ***