Bug 205120 - KBuildSycoca crash handler launches upon initial login of KDE 4.3 from official debian amd64 builds
Summary: KBuildSycoca crash handler launches upon initial login of KDE 4.3 from offici...
Status: RESOLVED DUPLICATE of bug 202871
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: ksycoca (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-25 20:21 UTC by Marc Jeffrey Driftmeyer
Modified: 2009-08-25 23:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Jeffrey Driftmeyer 2009-08-25 20:21:29 UTC
Application that crashed: kbuildsycoca4
Version of the application: 1.1
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-1-amd64 x86_64
Distribution: Debian GNU/Linux unstable (sid)

 -- Backtrace:
Application: KBuildSycoca (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#5  KSycocaEntry::offset (this=0x0) at ../../kdecore/sycoca/ksycocaentry.cpp:132
#6  0x00007f930cf8894d in KBuildMimeTypeFactory::savePatternLists (this=0x1507b00, str=...) at ../../kded/kbuildmimetypefactory.cpp:361
#7  0x00007f930cf88df3 in KBuildMimeTypeFactory::save (this=0x1507b00, str=...) at ../../kded/kbuildmimetypefactory.cpp:307
#8  0x00007f930cf81d21 in KBuildSycoca::save (this=0x22438e0, str=0x1508400) at ../../kded/kbuildsycoca.cpp:525
#9  0x00007f930cf83ee5 in KBuildSycoca::recreate (this=0x22438e0) at ../../kded/kbuildsycoca.cpp:433
#10 0x00007f930cf85d4b in kdemain (argc=2, argv=0x14529c0) at ../../kded/kbuildsycoca.cpp:829
#11 0x0000000000407264 in launch (argc=2, _name=0x1454d58 "/usr/bin/kbuildsycoca4", args=<value optimized out>, cwd=0x0, envc=0, envs=0x1454d85 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x1454d8d "") at ../../kinit/kinit.cpp:676
#12 0x0000000000407a28 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1168
#13 0x0000000000407fae in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1361
#14 0x000000000040863b in main (argc=2, argv=0x7fff469f2698, envp=0x7fff469f26b0) at ../../kinit/kinit.cpp:1788

This bug may be a duplicate of or related to bug 199745

Reported using DrKonqi
Comment 1 Dario Andres 2009-08-25 23:18:01 UTC
Merging with bug 202871. Thanks

*** This bug has been marked as a duplicate of bug 202871 ***