Bug 204998 - Event disappears from view when editing it
Summary: Event disappears from view when editing it
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: 4.3
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 207357 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-08-24 20:30 UTC by Albert Astals Cid
Modified: 2009-09-15 01:41 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Albert Astals Cid 2009-08-24 20:30:31 UTC
Version:            (using KDE 4.3.0)
OS:                Linux
Installed from:    Ubuntu Packages

How to reproduce:
 * Create a whole day event
 * Edit it, change the name, press Apply and Ok
 * The event will disappear from the view.

Notes:
 * Pressing Ok only works
 * The event is not lost, if you restart korganizer it is still there
Comment 1 Moritz Isselstein 2009-08-25 10:45:19 UTC
bump

Version: 4.3.0 (KDE 4.3.00 (KDE 4.3.0) "release 158", KDE:KDE4:Factory:Desktop / openSUSE_11.1)
Kernel: Linux (x86_64) release 2.6.27.29-0.1-default

* behaviour as described
* to be clear: pressing only ok also reproduces the error with me
Comment 2 Ondrej Machulda 2009-08-30 14:05:52 UTC
Confirmed on my gentoo. 

From my observing, you don't have to edit the name to make the event disappear - same effect when date of the event is changed.

It also don't have to be just whole day event, it's same when it is multiple-day event.

Attaching my steps to reproduce, originally prepared for my bug reporting :)

> Steps to reproduce:
> 1) create new event, leave all setting default, since they don't have probably any affect
> 2) close and start korganizer (so that event is saved)
> 3) find the event in calendar, open it's properties
> 4) change date of event, save
> 5) event disappear from calendar
> After koragnizer being reloaded again, event appears correctly in calendar on the new date

---
KDE Version 	4.3.0 (KDE 4.3.00 (KDE 4.3.0), Gentoo)
Operating System 	Linux (i686) release 2.6.30-gentoo-r4
Compiler 	i686-pc-linux-gnu-gcc
Comment 3 Hannes Schweizer 2009-09-08 23:24:33 UTC
confirmed as well for:

KDE Version       4.3.1
Operating System  Linux (x86_64) release 2.6.30-gentoo-r4

At first I suspected corrupted config/ics files. However removing the complete config and starting with a fresh ics does not help much either.
Comment 4 Dion Moult 2009-09-13 12:57:49 UTC
Confirmed KDE 4.3.1, Gentoo AMD64 2.6.30-gentoo-r5.
Comment 5 Christophe Marin 2009-09-14 17:57:23 UTC
*** Bug 207357 has been marked as a duplicate of this bug. ***
Comment 6 Allen Winter 2009-09-15 01:41:26 UTC
Thomas just committed a fix for this.
In trunk => revision 1023565
In 4.3 branch => revision 1023576

The fix will be released with KDE 4.3.2 and higher.