Bug 204144 - Limit number of keyboard layouts to switch
Summary: Limit number of keyboard layouts to switch
Status: RESOLVED FIXED
Alias: None
Product: system-config-printer-kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Unspecified
: NOR wishlist
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
: 174134 204900 266399 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-08-17 10:44 UTC by Dotan Cohen
Modified: 2011-02-16 03:33 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2009-08-17 10:44:12 UTC
Version:            (using KDE 4.3.0)
Installed from:    Ubuntu Packages

Please add the ability to limit which keyboard layouts are rotated when performing the Switch Layout keyboard shortcut. I have some layouts configured that I do not use often (US-English as the wife does not know Dvorak, Greek, Russian) so I'd like to keep them configured however it is a pain when I only use two layouts regularly (Dvorak, Hebrew). Thanks.
Comment 1 jonasz 2009-08-17 22:27:28 UTC
Yes, it was very useful feature in KDE3. It was named "Sticky switching" there. I just can't understand why it was removed in "kde4".
Comment 2 Andriy Rysin 2010-05-18 04:41:35 UTC
*** Bug 204900 has been marked as a duplicate of this bug. ***
Comment 3 Andriy Rysin 2010-05-24 03:37:40 UTC
*** Bug 174134 has been marked as a duplicate of this bug. ***
Comment 4 Andriy Rysin 2010-10-30 20:52:31 UTC
I had blogged about implementation of spare layouts which hopefully cover the need for this feature. I am planning to push this into KDE 4.6 so any feedback is appreciated.
http://codersgrumble.blogspot.com/2010/10/kxkb-spare-layouts-poor-mans-sticky.html
Comment 5 Andriy Rysin 2010-11-02 04:26:41 UTC
SVN commit 1192111 by rysin:

Introduce spare layouts and support > 4 layouts
BUG: 204144
FIXED-IN: 4.6.0

 M  +5 -2      CMakeLists.txt  
 M  +2 -3      TODO  
 M  +1 -1      flags.cpp  
 M  +2 -2      flags.h  
 M  +32 -9     kcm_keyboard.ui  
 M  +66 -9     kcm_keyboard_widget.cpp  
 M  +1 -0      kcm_keyboard_widget.h  
 M  +7 -0      kcm_view_models.cpp  
 M  +15 -62    keyboard_applet.cpp  
 M  +3 -4      keyboard_applet.h  
 M  +27 -0     keyboard_config.cpp  
 M  +5 -0      keyboard_config.h  
 M  +5 -3      keyboard_daemon.cpp  
 M  +2 -2      keyboard_daemon.h  
 M  +58 -25    layout_memory.cpp  
 M  +6 -5      layout_memory.h  
 A             layout_tray_icon.cpp   [License: GPL (v2+)]
 A             layout_tray_icon.h   [License: GPL (v2+)]
 M  +7 -152    layout_widget.cpp  
 M  +1 -38     layout_widget.h  
 D             layout_widget_plugin.cpp  
 A             layouts_menu.cpp   [License: GPL (v2+)]
 A             layouts_menu.h   [License: GPL (v2+)]
 M  +20 -0     x11_helper.cpp  
 M  +28 -0     x11_helper.h  
 M  +72 -21    xkb_helper.cpp  
 M  +5 -3      xkb_helper.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1192111
Comment 6 Andriy Rysin 2010-11-02 04:28:14 UTC
Ok "spare layouts" feature is committed to trunk, I'd appreciate if somebody can give it a try before 4.6.0 is out.
Comment 7 Dotan Cohen 2010-11-02 08:21:41 UTC
Thanks, Andi, is there a way to test without building trunk?
Comment 8 Andriy Rysin 2010-11-02 15:35:31 UTC
(In reply to comment #7)
> Thanks, Andi, is there a way to test without building trunk?
Maybe your distro has alpha packages for KDE, otherwise not sure
Comment 9 Andriy Rysin 2011-02-16 03:33:22 UTC
*** Bug 266399 has been marked as a duplicate of this bug. ***