Bug 202797 - crash while changing active Window with ALT-TAB and clicking to background window outside of TAB-window
Summary: crash while changing active Window with ALT-TAB and clicking to background wi...
Status: RESOLVED DUPLICATE of bug 179865
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-06 14:08 UTC by Steffen Möller
Modified: 2009-08-06 14:11 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen Möller 2009-08-06 14:08:37 UTC
Application that crashed: kwin
Version of the application: 4.3.00 (KDE 4.3.0)
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-1-amd64 x86_64
Distribution: Debian GNU/Linux 5.0.2 (lenny)

What I was doing when the application crashed:
I did what I normally don't do and used the mouse to select the backgound window, but I had already pressed ALT-TAB with the other hand in parallel. Krash.

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#5  0x00007f7792583c84 in WindowPaintData (this=0x7fffe06fa680, w=0x1bb7700) at ../../../kwin/lib/kwineffects.cpp:76
#6  0x00007f7785f6a8d7 in KWin::BoxSwitchEffect::paintWindowThumbnail (this=0x1bc5600, w=0x1bb7700) at ../../../kwin/effects/boxswitch/boxswitch.cpp:747
#7  0x00007f7785f6c58f in KWin::BoxSwitchEffect::paintScreen (this=0x1bc5600, mask=8, region=..., data=<value optimized out>) at ../../../kwin/effects/boxswitch/boxswitch.cpp:157
#8  0x00007f7793a20337 in KWin::EffectsHandlerImpl::paintScreen (this=0x1b1c010, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#9  0x00007f7792581520 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:206
#10 0x00007f7793a20337 in KWin::EffectsHandlerImpl::paintScreen (this=0x1b1c010, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#11 0x00007f7785fa6565 in KWin::ZoomEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:73
#12 0x00007f7793a20337 in KWin::EffectsHandlerImpl::paintScreen (this=0x1b1c010, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#13 0x00007f7793a0bf1a in KWin::Scene::paintScreen (this=0x1ad31d0, mask=0x7fffe06fad9c, region=0x7fffe06faea0) at ../../kwin/scene.cpp:134
#14 0x00007f7793a1aa4f in KWin::SceneOpenGL::paint (this=0x1ad31d0, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:746
#15 0x00007f7793a07386 in KWin::Workspace::performCompositing (this=0x1acdf20) at ../../kwin/composite.cpp:420
#16 0x00007f77939a3b6a in KWin::Workspace::qt_metacall (this=0x1acdf20, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffe06fb030) at ./workspace.moc:473
#17 0x00007f778fb87602 in QMetaObject::activate (sender=0x1ace348, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x11) at kernel/qobject.cpp:3112
#18 0x00007f778fb81b73 in QObject::event (this=0x1ace348, e=0x1bb7700) at kernel/qobject.cpp:1074
#19 0x00007f77902b47ad in QApplicationPrivate::notify_helper (this=0x19be0e0, receiver=0x1ace348, e=0x7fffe06fb6e0) at kernel/qapplication.cpp:4056
#20 0x00007f77902bc80a in QApplication::notify (this=0x7fffe06fba50, receiver=0x1ace348, e=0x7fffe06fb6e0) at kernel/qapplication.cpp:4021
#21 0x00007f779322db2b in KApplication::notify (this=0x7fffe06fba50, receiver=0x1ace348, event=0x7fffe06fb6e0) at ../../kdeui/kernel/kapplication.cpp:302
#22 0x00007f778fb7249c in QCoreApplication::notifyInternal (this=0x7fffe06fba50, receiver=0x1ace348, event=0x7fffe06fb6e0) at kernel/qcoreapplication.cpp:610
#23 0x00007f778fb9e7a6 in QCoreApplication::sendEvent (this=0x19c1e20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#24 QTimerInfoList::activateTimers (this=0x19c1e20) at kernel/qeventdispatcher_unix.cpp:572
#25 0x00007f778fb9ac1d in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
#26 0x00007f778a5557aa in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#27 0x00007f778a558df8 in ?? () from /usr/lib/libglib-2.0.so.0
#28 0x00007f778a558fac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#29 0x00007f778fb9ab7f in QEventDispatcherGlib::processEvents (this=0x19a44d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#30 0x00007f779034b5ef in QGuiEventDispatcherGlib::processEvents (this=0x1bb7700, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#31 0x00007f778fb70d62 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007f778fb71134 in QEventLoop::exec (this=0x7fffe06fb990, flags=...) at kernel/qeventloop.cpp:201
#33 0x00007f778fb733a4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#34 0x00007f77939bb8d8 in kdemain (argc=3, argv=0x7fffe06fbf38) at ../../kwin/main.cpp:527
#35 0x00007f77936445c6 in __libc_start_main (main=0x400710 <main>, argc=3, ubp_av=0x7fffe06fbf38, init=0x400740 <__libc_csu_init>, fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7fffe06fbf28) at libc-start.c:222
#36 0x0000000000400649 in _start () at ../sysdeps/x86_64/elf/start.S:113

This bug may be a duplicate of or related to bug 202644

Reported using DrKonqi
Comment 1 Martin Flöser 2009-08-06 14:11:16 UTC

*** This bug has been marked as a duplicate of bug 179865 ***