Bug 202644 - crash upon change of applications with ALT-TAB, happens every few days/weeks since 4.2
Summary: crash upon change of applications with ALT-TAB, happens every few days/weeks ...
Status: RESOLVED DUPLICATE of bug 179865
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-05 15:54 UTC by Steffen Möller
Modified: 2009-08-05 16:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen Möller 2009-08-05 15:54:44 UTC
Application that crashed: kwin
Version of the application: 4.3.00 (KDE 4.3.0)
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-1-amd64 x86_64
Distribution: Debian GNU/Linux 5.0.2 (lenny)

What I was doing when the application crashed:
I moved from Mozilla (read Icedove) to the terminal (read console), or wanted to at least. Normally I do this with ALT-TAB, but I cannot tell 100%ish since I don't notice doing it :)  Firefox (Iceweasel) was also open. Not much else, really. No sound was playing. No special periphery, except a USB trackball and a USB keyboard, but I experience the same bug also when using tha laptop's keyboard with nothing attached. No second monitor. FIX THIS, PLEASE!!!

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#5  0x0000000000000040 in ?? ()
#6  0x00007fd967369c87 in WindowPaintData (this=0x7fff0a546d40, w=0x2ab2ce0) at ../../../kwin/lib/kwineffects.cpp:76
#7  0x00007fd9577248d7 in KWin::BoxSwitchEffect::paintWindowThumbnail (this=0x26c0ed0, w=0x2ab2ce0) at ../../../kwin/effects/boxswitch/boxswitch.cpp:747
#8  0x00007fd95772658f in KWin::BoxSwitchEffect::paintScreen (this=0x26c0ed0, mask=8, region=..., data=<value optimized out>) at ../../../kwin/effects/boxswitch/boxswitch.cpp:157
#9  0x00007fd968806337 in KWin::EffectsHandlerImpl::paintScreen (this=0x263ba10, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#10 0x00007fd967367520 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:206
#11 0x00007fd968806337 in KWin::EffectsHandlerImpl::paintScreen (this=0x263ba10, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#12 0x00007fd957760565 in KWin::ZoomEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:73
#13 0x00007fd968806337 in KWin::EffectsHandlerImpl::paintScreen (this=0x263ba10, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#14 0x00007fd9687f1f1a in KWin::Scene::paintScreen (this=0x25f6960, mask=0x7fff0a54745c, region=0x7fff0a547560) at ../../kwin/scene.cpp:134
#15 0x00007fd968800a4f in KWin::SceneOpenGL::paint (this=0x25f6960, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:746
#16 0x00007fd9687ed386 in KWin::Workspace::performCompositing (this=0x25edd40) at ../../kwin/composite.cpp:420
#17 0x00007fd968789b6a in KWin::Workspace::qt_metacall (this=0x25edd40, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff0a5476f0) at ./workspace.moc:473
#18 0x00007fd96496d602 in QMetaObject::activate (sender=0x25ee168, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x11) at kernel/qobject.cpp:3112
#19 0x00007fd964967b73 in QObject::event (this=0x25ee168, e=0x2ab2ce0) at kernel/qobject.cpp:1074
#20 0x00007fd96509a7ad in QApplicationPrivate::notify_helper (this=0x24800e0, receiver=0x25ee168, e=0x7fff0a547da0) at kernel/qapplication.cpp:4056
#21 0x00007fd9650a280a in QApplication::notify (this=0x7fff0a548110, receiver=0x25ee168, e=0x7fff0a547da0) at kernel/qapplication.cpp:4021
#22 0x00007fd968013b2b in KApplication::notify (this=0x7fff0a548110, receiver=0x25ee168, event=0x7fff0a547da0) at ../../kdeui/kernel/kapplication.cpp:302
#23 0x00007fd96495849c in QCoreApplication::notifyInternal (this=0x7fff0a548110, receiver=0x25ee168, event=0x7fff0a547da0) at kernel/qcoreapplication.cpp:610
#24 0x00007fd9649847a6 in QCoreApplication::sendEvent (this=0x2483e20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#25 QTimerInfoList::activateTimers (this=0x2483e20) at kernel/qeventdispatcher_unix.cpp:572
#26 0x00007fd964980c1d in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
#27 0x00007fd95f33b7aa in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#28 0x00007fd95f33edf8 in ?? () from /usr/lib/libglib-2.0.so.0
#29 0x00007fd95f33efac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#30 0x00007fd964980b7f in QEventDispatcherGlib::processEvents (this=0x24664d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#31 0x00007fd9651315ef in QGuiEventDispatcherGlib::processEvents (this=0x2ab2ce0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#32 0x00007fd964956d62 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007fd964957134 in QEventLoop::exec (this=0x7fff0a548050, flags=...) at kernel/qeventloop.cpp:201
#34 0x00007fd9649593a4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#35 0x00007fd9687a18d8 in kdemain (argc=3, argv=0x7fff0a5485f8) at ../../kwin/main.cpp:527
#36 0x00007fd96842a5c6 in __libc_start_main (main=0x400710 <main>, argc=3, ubp_av=0x7fff0a5485f8, init=0x400740 <__libc_csu_init>, fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7fff0a5485e8) at libc-start.c:222
#37 0x0000000000400649 in _start () at ../sysdeps/x86_64/elf/start.S:113

This bug may be a duplicate of or related to bug 193934

Reported using DrKonqi
Comment 1 Martin Flöser 2009-08-05 16:16:37 UTC

*** This bug has been marked as a duplicate of bug 179865 ***