Bug 202736 - Desktops effects disabled at each login
Summary: Desktops effects disabled at each login
Status: RESOLVED DUPLICATE of bug 202274
Alias: None
Product: kwin
Classification: Unclassified
Component: compositing (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 202897 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-08-06 02:10 UTC by Markus Strobl
Modified: 2009-08-28 18:30 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
KWIN log (17.39 KB, text/plain)
2009-08-06 02:13 UTC, Markus Strobl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Strobl 2009-08-06 02:10:32 UTC
Version:            (using KDE 4.3.0)
OS:                Linux
Installed from:    Gentoo Packages

At each login desktop effects are disabled. When going to system settings and clicking "enable" a notification shows up stating that compositing has been disabled by an unnamed application. Clicking "enable" a second time will enable the effects and they work properly until the next login and the whole thing repeats.

Attached is the debug output of kwin. I added some new lines to break the log into 3 parts:

1: kwin --replace
2: First click on "enable effects" (which fails)
3: Second click on "enable effects" (succeeds)

Graphics are ATI R430 using the open source Radeon driver.
Comment 1 Markus Strobl 2009-08-06 02:13:37 UTC
Created attachment 35893 [details]
KWIN log
Comment 2 lucas 2009-08-06 03:14:33 UTC
Line of interest:

kwin(4085): Compositing self-check failed, disabling compositing.
Comment 3 FiNeX 2009-08-07 11:23:01 UTC
*** Bug 202897 has been marked as a duplicate of this bug. ***
Comment 4 Nikos Chantziaras 2009-08-07 17:32:27 UTC
I confirm on Gentoo 64-bit, Radeon HD4870 with Catalyst drivers 9.7.
Comment 5 sergio.guibert 2009-08-08 15:42:33 UTC
I confirm this behavior with the same kwin log entries for kubuntu 9.04 64-bits with kde 4.3 and catalyst drivers 9.7 for Radeon HD4870.
Comment 6 jcb1985 2009-08-28 18:18:31 UTC
I confirm this bug with Kubuntu 9.04 32-bits with kde 4.3 and catalyst drivers 9.8
when going to system settings, it says that the effects are activated, but temporarily disabled. 
when clicking on resuming it says that compositing has been disabled bu an unnamed application
Comment 7 Thomas Lübking 2009-08-28 18:30:11 UTC

*** This bug has been marked as a duplicate of bug 202274 ***