Bug 193934 - KDE crashes when switching between applications
Summary: KDE crashes when switching between applications
Status: RESOLVED DUPLICATE of bug 179865
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-24 19:37 UTC by Stefano Fornari
Modified: 2009-05-25 00:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefano Fornari 2009-05-24 19:37:58 UTC
Version:            (using KDE 4.2.3)
OS:                Linux
Installed from:    Ubuntu Packages

I noticed that when I switch between applications with ALT+Tab and one of the applications it should circulate closes, KDE crashes very often.
Comment 1 Dario Andres 2009-05-24 20:48:49 UTC
What error message do you get ? Which application is crashing ?
Thanks
Comment 2 Stefano Fornari 2009-05-25 00:09:07 UTC
This is the message:

A Fatal Error Occurred
The application KWin (kwin) crashed and caused the signal 11 (SIGSEGV).
Please help us improve the software you use by filing a report at http://bugs.kde.org. Useful details include how to reproduce the error, documents that were loaded, etc.

And this the details:

This backtrace appears to be of no use.
This is probably because your packages are built in a way which prevents creation of proper backtraces, or the stack frame was seriously corrupted in the crash.

(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb62ba710 (LWP 3436)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0xb7f56430 in __kernel_vsyscall ()
[Current thread is 0 (process 3436)]

Thread 1 (Thread 0xb62ba710 (LWP 3436)):
#0  0xb7f56430 in __kernel_vsyscall ()
#1  0xb67e9780 in nanosleep () from /lib/tls/i686/cmov/libc.so.6
#2  0xb67e95be in sleep () from /lib/tls/i686/cmov/libc.so.6
#3  0xb7d108b2 in ?? () from /usr/lib/libkdeui.so.5
#4  0xb7d11274 in KCrash::defaultCrashHandler () from /usr/lib/libkdeui.so.5
#5  <signal handler called>
#6  0xb7e60bba in KWin::WindowPaintData::WindowPaintData () from /usr/lib/libkwineffects.so.1
#7  0xb45e536c in ?? () from /usr/lib/kde4/kwin4_effect_builtins.so
#8  0xb45e8642 in ?? () from /usr/lib/kde4/kwin4_effect_builtins.so
#9  0xb7f293ff in ?? () from /usr/lib/libkdeinit4_kwin.so
#10 0xb7e5f3b6 in KWin::Effect::paintScreen () from /usr/lib/libkwineffects.so.1
#11 0xb7f293ff in ?? () from /usr/lib/libkdeinit4_kwin.so
#12 0xb7e5f3b6 in KWin::Effect::paintScreen () from /usr/lib/libkwineffects.so.1
#13 0xb7f293ff in ?? () from /usr/lib/libkdeinit4_kwin.so
#14 0xb461d8ed in ?? () from /usr/lib/kde4/kwin4_effect_builtins.so
#15 0xb7f293ff in ?? () from /usr/lib/libkdeinit4_kwin.so
#16 0xb7f15510 in ?? () from /usr/lib/libkdeinit4_kwin.so
#17 0xb7f214ba in ?? () from /usr/lib/libkdeinit4_kwin.so
#18 0xb7f10806 in ?? () from /usr/lib/libkdeinit4_kwin.so
#19 0xb7eabbad in ?? () from /usr/lib/libkdeinit4_kwin.so
#20 0xb6cf9ca8 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#21 0xb6cfa932 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#22 0xb6d35717 in QTimer::timeout () from /usr/lib/libQtCore.so.4
#23 0xb6cff6fe in QTimer::timerEvent () from /usr/lib/libQtCore.so.4
#24 0xb6cf415f in QObject::event () from /usr/lib/libQtCore.so.4
#25 0xb6f91e9c in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#26 0xb6f9a19e in QApplication::notify () from /usr/lib/libQtGui.so.4
#27 0xb7ca094d in KApplication::notify () from /usr/lib/libkdeui.so.5
#28 0xb7ec12ed in ?? () from /usr/lib/libkdeinit4_kwin.so
#29 0xb6ce3a3b in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#30 0xb6d12d71 in ?? () from /usr/lib/libQtCore.so.4
#31 0xb6d0f4e0 in ?? () from /usr/lib/libQtCore.so.4
#32 0xb6429b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#33 0xb642d0eb in ?? () from /usr/lib/libglib-2.0.so.0
#34 0xb642d268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#35 0xb6d0f438 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#36 0xb7033365 in ?? () from /usr/lib/libQtGui.so.4
#37 0xb6ce206a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#38 0xb6ce24aa in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#39 0xb6ce4959 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#40 0xb6f91d17 in QApplication::exec () from /usr/lib/libQtGui.so.4
#41 0xb7ec5182 in kdemain () from /usr/lib/libkdeinit4_kwin.so
#42 0x08048732 in _start ()
#0  0xb7f56430 in __kernel_vsyscall ()

It is quite reproducible: Close a window and then quickly press alt-tab; I use Box Switch as effect, but I am sure it happened also when I tried the other effects.

HTH
Comment 3 Dario Andres 2009-05-25 00:18:26 UTC
Could you please install the "kdebase-workspace-dbg" package and generate a new crash to get a completer backtrace? 

(This is probably related to the Desktop Effects)
Thanks
Comment 4 Stefano Fornari 2009-05-25 00:40:08 UTC
Here we go

Application: KWin (kwin), signal SIGSEGV

Thread 1 (Thread 0xb62ae710 (LWP 14594)):
[KCrash Handler]
#6  0x00000000 in ?? ()
#7  0xb45d936c in KWin::BoxSwitchEffect::paintWindowThumbnail (this=0x976dfd8, w=0x975c1d0) at /build/buildd/kdebase-workspace-4.2.2/kwin/effects/boxswitch.cpp:761
#8  0xb45dc642 in KWin::BoxSwitchEffect::paintScreen (this=0x976dfd8, mask=8, region={d = 0xbf864ca8, static shared_empty = {ref = {_q_value = 261}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbf864e88) at /build/buildd/kdebase-workspace-4.2.2/kwin/effects/boxswitch.cpp:147
#9  0xb7f1d3ff in KWin::EffectsHandlerImpl::paintScreen (this=0x96e4a18, mask=8, region={d = 0xbf864ce8, static shared_empty = {ref = {_q_value = 261}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbf864e88) at /build/buildd/kdebase-workspace-4.2.2/kwin/effects.cpp:122
#10 0xb7e533b6 in KWin::Effect::paintScreen (this=0x9757748, mask=8, region={d = 0xbf864d28, static shared_empty = {ref = {_q_value = 261}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbf864e88) at /build/buildd/kdebase-workspace-4.2.2/kwin/lib/kwineffects.cpp:199
#11 0xb7f1d3ff in KWin::EffectsHandlerImpl::paintScreen (this=0x96e4a18, mask=8, region={d = 0xbf864d68, static shared_empty = {ref = {_q_value = 261}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbf864e88) at /build/buildd/kdebase-workspace-4.2.2/kwin/effects.cpp:122
#12 0xb7e533b6 in KWin::Effect::paintScreen (this=0x9754688, mask=8, region={d = 0xbf864da8, static shared_empty = {ref = {_q_value = 261}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbf864e88) at /build/buildd/kdebase-workspace-4.2.2/kwin/lib/kwineffects.cpp:199
#13 0xb7f1d3ff in KWin::EffectsHandlerImpl::paintScreen (this=0x96e4a18, mask=8, region={d = 0xbf864dfc, static shared_empty = {ref = {_q_value = 261}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbf864e88) at /build/buildd/kdebase-workspace-4.2.2/kwin/effects.cpp:122
#14 0xb46118ed in KWin::ZoomEffect::paintScreen (this=0x96d2ca0, mask=8, region={d = 0xbf864e48, static shared_empty = {ref = {_q_value = 261}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbf864e88) at /build/buildd/kdebase-workspace-4.2.2/kwin/effects/zoom.cpp:73
#15 0xb7f1d3ff in KWin::EffectsHandlerImpl::paintScreen (this=0x96e4a18, mask=8, region={d = 0xbf864ee0, static shared_empty = {ref = {_q_value = 261}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbf864e88) at /build/buildd/kdebase-workspace-4.2.2/kwin/effects.cpp:122
#16 0xb7f09510 in KWin::Scene::paintScreen (this=0x96ec310, mask=0xbf864f64, region=0xbf865024) at /build/buildd/kdebase-workspace-4.2.2/kwin/scene.cpp:133
#17 0xb7f154ba in KWin::SceneOpenGL::paint (this=0x96ec310, damage={d = 0xbf865024, static shared_empty = {ref = {_q_value = 261}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, toplevels=
        {{p = {static shared_null = {ref = {_q_value = 3659}, alloc = 0, begin = 0, end = 0, sharable = 1, array = {0x0}}, d = 0xbf865020}, d = 0xbf865020}})
    at /build/buildd/kdebase-workspace-4.2.2/kwin/scene_opengl.cpp:724
#18 0xb7f04806 in KWin::Workspace::performCompositing (this=0x96cfbc0) at /build/buildd/kdebase-workspace-4.2.2/kwin/composite.cpp:384
#19 0xb7e9fbad in KWin::Workspace::qt_metacall (this=0x96cfbc0, _c=QMetaObject::InvokeMetaMethod, _id=140, _a=0xbf8650f8)
    at /build/buildd/kdebase-workspace-4.2.2/obj-i486-linux-gnu/kwin/workspace.moc:446
#20 0xb6cedca8 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#21 0xb6cee932 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#22 0xb6d29717 in QTimer::timeout () from /usr/lib/libQtCore.so.4
#23 0xb6cf36fe in QTimer::timerEvent () from /usr/lib/libQtCore.so.4
#24 0xb6ce815f in QObject::event () from /usr/lib/libQtCore.so.4
#25 0xb6f85e9c in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#26 0xb6f8e19e in QApplication::notify () from /usr/lib/libQtGui.so.4
#27 0xb7c9494d in KApplication::notify () from /usr/lib/libkdeui.so.5
#28 0xb7eb52ed in KWin::Application::notify (this=0xbf865878, o=0x96cfe14, e=0xbf86559c) at /build/buildd/kdebase-workspace-4.2.2/kwin/main.cpp:368
#29 0xb6cd7a3b in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#30 0xb6d06d71 in ?? () from /usr/lib/libQtCore.so.4
#31 0xb6d034e0 in ?? () from /usr/lib/libQtCore.so.4
#32 0xb641db88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#33 0xb64210eb in ?? () from /usr/lib/libglib-2.0.so.0
#34 0xb6421268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#35 0xb6d03438 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#36 0xb7027365 in ?? () from /usr/lib/libQtGui.so.4
#37 0xb6cd606a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#38 0xb6cd64aa in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#39 0xb6cd8959 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#40 0xb6f85d17 in QApplication::exec () from /usr/lib/libQtGui.so.4
#41 0xb7eb9182 in kdemain (argc=3, argv=0xbf865a54) at /build/buildd/kdebase-workspace-4.2.2/kwin/main.cpp:519
#42 0x08048732 in main (argc=-1268509688, argv=0xb689e201) at /build/buildd/kdebase-workspace-4.2.2/obj-i486-linux-gnu/kwin/kwin_dummy.cpp:3
Comment 5 Martin Flöser 2009-05-25 00:46:51 UTC

*** This bug has been marked as a duplicate of bug 179865 ***