Bug 201983 - Game is lost (forty eight) while game can still be won
Summary: Game is lost (forty eight) while game can still be won
Status: RESOLVED FIXED
Alias: None
Product: kpat
Classification: Applications
Component: solver (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
: 247388 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-07-30 11:28 UTC by Paul van Noort
Modified: 2011-01-26 11:56 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot presumed lost game..obviously winnable (72.95 KB, image/jpeg)
2009-07-30 11:31 UTC, Paul van Noort
Details
game is lost? screenshot (82.59 KB, image/jpeg)
2009-07-30 11:32 UTC, Paul van Noort
Details
savegame (Mod3), where the bug occures (6.01 KB, application/octet-stream)
2009-08-23 12:03 UTC, Hagen Meyer
Details
Save game that transitions from unwinnable to winnable (5.41 KB, text/xml)
2009-11-19 07:34 UTC, Parker Coates
Details
Winnable Forty & Eight savegame 2270389 deemed unwinnable (5.41 KB, text/xml)
2010-02-04 23:43 UTC, Wouter Haffmans
Details
Winnable Forty & Eight savegame 1887872835 (5.41 KB, text/xml)
2010-02-04 23:53 UTC, Wouter Haffmans
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul van Noort 2009-07-30 11:28:31 UTC
Version:           3.1 (using 4.2.00 (KDE 4.2.0) "release 93", KDE:KDE4:Factory:Desktop / openSUSE_11.0)
Compiler:          gcc
OS:                Linux (i686) release 2.6.25.20-0.4-pae

while playing forty eight (and other games from kpat) the solver is not as smart as i am.. I can solve games it can not. No surprise there.. but i have come across different games stated as cannot be won and even "game is lost" while the game is (undoubtedly) winnable.
Comment 1 Paul van Noort 2009-07-30 11:31:54 UTC
Created attachment 35733 [details]
screenshot presumed lost game..obviously winnable

this game is lost? No really.. take a better look
Comment 2 Paul van Noort 2009-07-30 11:32:58 UTC
Created attachment 35734 [details]
game is lost? screenshot
Comment 3 Stephan Kulow 2009-07-30 11:59:25 UTC
screenshots are worthless, attach savegames
Comment 4 Hagen Meyer 2009-08-23 12:03:11 UTC
Created attachment 36386 [details]
savegame (Mod3), where the bug occures

This savegame is for Mod3, but the bug is the same.

In this savegame, the solver marks the game as lost but when you click on the pile of cards (bottom right) the game is winnable again.
Comment 5 Parker Coates 2009-11-19 07:32:33 UTC
Hagen, each game type has its own solver, so bugs for each should be reported separately. If the Mod3 issue is still present, open a new report.
Comment 6 Parker Coates 2009-11-19 07:34:45 UTC
Created attachment 38437 [details]
Save game that transitions from unwinnable to winnable

Open the attached saved game. It is reported as unwinnable. Move the 10 of clubs to the open pile. The game is now reported as winnable.
Comment 7 Parker Coates 2009-11-19 07:35:34 UTC
Changing state from WAITINGFORINFO since we now have a testcase.
Comment 8 Wouter Haffmans 2010-02-04 23:43:41 UTC
Created attachment 40536 [details]
Winnable Forty & Eight savegame 2270389 deemed unwinnable

If it's of any help: I have a Forty & Eight savegame. Using KPat 3.3 (KDE SC 4.4 RC 2 / 4.3.95), the game is claimed to be unwinnable by the solver. Move the 7 of hearts which is on top of the 8 of hearts to the empty pile and the solver will tell you the game is winnable.

For your info: I managed to solve this game, so it is winnable in the saved situation.
Comment 9 Wouter Haffmans 2010-02-04 23:53:37 UTC
Created attachment 40537 [details]
Winnable Forty & Eight savegame 1887872835

And here's another similar save game (also Forty & Eight). Move the 8 of diamonds (2nd column) to the empty spot, and you can solve the game.
Comment 10 Parker Coates 2010-08-14 19:49:22 UTC
*** Bug 247388 has been marked as a duplicate of this bug. ***
Comment 11 Stephan Kulow 2011-01-26 11:56:39 UTC
SVN commit 1217203 by coolo:

move whole lines too
BUG: 201983


 M  +1 -1      fortyeightsolver.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1217203