Bug 201955 - konqueror crash on close
Summary: konqueror crash on close
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-30 02:46 UTC by Marc Schiffbauer
Modified: 2009-07-31 15:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Schiffbauer 2009-07-30 02:46:46 UTC
Application that crashed: konqueror
Version of the application: 4.2.98 (KDE 4.2.98 (KDE 4.3 RC3))
KDE Version: 4.2.98 (KDE 4.2.98 (KDE 4.3 RC3))
Qt Version: 4.5.2
Operating System: Linux 2.6.30-gentoo-r2 x86_64

What I was doing when the application crashed:
konqui crashed after closing the window

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Aborted
[KCrash Handler]
#5  0x00007f48315df645 in raise () from /lib/libc.so.6
#6  0x00007f48315e0b63 in abort () from /lib/libc.so.6
#7  0x00007f48315d86d9 in __assert_fail () from /lib/libc.so.6
#8  0x00007f481b8082cb in KHTMLGlobal::finalCheck () at /var/tmp/portage/kde-base/kdelibs-4.2.98/work/kdelibs-4.2.98/khtml/khtml_global.cpp:258
#9  0x00007f48202d37ba in ~KHTMLFactory (this=0x9d0d40) at /var/tmp/portage/kde-base/kdelibs-4.2.98/work/kdelibs-4.2.98/khtml/khtml_factory.cpp:35
#10 0x00007f48338c4401 in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x9d4e30}, end={i = 0x9cd4b0}) at /usr/include/qt4/QtCore/qalgorithms.h:350
#11 0x00007f48338c4629 in ~FactoryHash (this=0x543c) at /var/tmp/portage/kde-base/kdelibs-4.2.98/work/kdelibs-4.2.98/kdecore/util/klibrary.cpp:93
#12 0x00007f48338c3762 in destroy () at /var/tmp/portage/kde-base/kdelibs-4.2.98/work/kdelibs-4.2.98/kdecore/util/klibrary.cpp:97
#13 0x00007f48315e2225 in ?? () from /lib/libc.so.6
#14 0x00007f48315e2285 in exit () from /lib/libc.so.6
#15 0x0000000000407312 in launch (argc=4, _name=0x659978 "konqueror", args=0x6599d4 "", cwd=0x6599d5 "/home/mschiff/docs", envc=62, envs=<value optimized out>, reset_env=true, tty=0x0, 
    avoid_loops=false, startup_id_str=0x65a610 "bart;1248914563;553462;7698_TIME153069625") at /var/tmp/portage/kde-base/kdelibs-4.2.98/work/kdelibs-4.2.98/kinit/kinit.cpp:676
#16 0x0000000000407e22 in handle_launcher_request (sock=14, who=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.2.98/work/kdelibs-4.2.98/kinit/kinit.cpp:1168
#17 0x00000000004084d9 in handle_requests (waitForPid=0) at /var/tmp/portage/kde-base/kdelibs-4.2.98/work/kdelibs-4.2.98/kinit/kinit.cpp:1352
#18 0x0000000000408a7d in main (argc=2, argv=0x7fff819f84a8, envp=0x7fff819f84c0) at /var/tmp/portage/kde-base/kdelibs-4.2.98/work/kdelibs-4.2.98/kinit/kinit.cpp:1788

This bug may be a duplicate of or related to bug 200152

Reported using DrKonqi
Comment 1 Dario Andres 2009-07-31 15:39:20 UTC
Merging with bug 151453. Thanks

*** This bug has been marked as a duplicate of bug 151453 ***