Bug 200152 - crash after closing window
Summary: crash after closing window
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-14 11:13 UTC by Michał Kudła
Modified: 2009-07-14 16:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Kudła 2009-07-14 11:13:24 UTC
Application that crashed: konqueror
Version of the application: 4.2.96 (KDE 4.2.96 (KDE 4.3 RC2))
KDE Version: 4.2.96 (KDE 4.2.96 (KDE 4.3 RC2))
Qt Version: 4.5.2
Operating System: Linux 2.6.28-gentoo-r5 i686
Distribution: "Gentoo Base System release 2.0.0"

What I was doing when the application crashed:
crash after closing window: site allegro.pl

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Aborted
[KCrash Handler]
#6  0xffffe424 in __kernel_vsyscall ()
#7  0xb68a8670 in raise () from /lib/libc.so.6
#8  0xb68a9eb8 in abort () from /lib/libc.so.6
#9  0xb68a16ee in __assert_fail () from /lib/libc.so.6
#10 0xb1e8b982 in KHTMLGlobal::finalCheck () at /var/tmp/portage/kde-base/kdelibs-4.2.96/work/kdelibs-4.2.96/khtml/khtml_global.cpp:258
#11 0xb245d3cc in ~KHTMLFactory (this=0x8db8ac0) at /var/tmp/portage/kde-base/kdelibs-4.2.96/work/kdelibs-4.2.96/khtml/khtml_factory.cpp:35
#12 0xb7d3e2f1 in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x8dbe7f0}, end={i = 0x8db96d8}) at /usr/include/qt4/QtCore/qalgorithms.h:350
#13 0xb7d3e368 in qDeleteAll<FactoryHash> (c=@0x8db8fb8) at /usr/include/qt4/QtCore/qalgorithms.h:358
#14 0xb7d3e582 in ~FactoryHash (this=0x8db8fb8) at /var/tmp/portage/kde-base/kdelibs-4.2.96/work/kdelibs-4.2.96/kdecore/util/klibrary.cpp:93
#15 0xb7d3d3ad in destroy () at /var/tmp/portage/kde-base/kdelibs-4.2.96/work/kdelibs-4.2.96/kdecore/util/klibrary.cpp:97
#16 0xb7c13adb in ~KCleanUpGlobalStatic (this=0xb7d92450) at /var/tmp/portage/kde-base/kdelibs-4.2.96/work/kdelibs-4.2.96/kdecore/kernel/kglobal.h:62
#17 0xb68ab551 in exit () from /lib/libc.so.6
#18 0x0804e53d in launch (argc=2, _name=0x8084e0c "konqueror", args=0x8084e41 "", cwd=0x8084e42 "/home/m1k0", envc=61, 
    envs=0x8084e51 "MANPATH=/home/m1k0/.gentoo/java-config-2/current-user-vm/man:/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/i686-pc-linux-gnu/2.18/man:/usr/share/gcc-data/i686-pc-linux-gnu/4.3.3/man:/et"..., reset_env=true, tty=0x0, avoid_loops=false, startup_id_str=0x8085a10 "0") at /var/tmp/portage/kde-base/kdelibs-4.2.96/work/kdelibs-4.2.96/kinit/kinit.cpp:676
#19 0x0804f097 in handle_launcher_request (sock=10, who=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.2.96/work/kdelibs-4.2.96/kinit/kinit.cpp:1168
#20 0x0804f712 in handle_requests (waitForPid=0) at /var/tmp/portage/kde-base/kdelibs-4.2.96/work/kdelibs-4.2.96/kinit/kinit.cpp:1352
#21 0x0804fcfa in main (argc=2, argv=0xbfacee44, envp=0xbfacee50) at /var/tmp/portage/kde-base/kdelibs-4.2.96/work/kdelibs-4.2.96/kinit/kinit.cpp:1788

Reported using DrKonqi
Comment 1 Dario Andres 2009-07-14 16:11:28 UTC
Merging with bug 151453. Thanks

*** This bug has been marked as a duplicate of bug 151453 ***