Bug 200527 - Resizing the GUI window looses the user chosen proportions of the layout
Summary: Resizing the GUI window looses the user chosen proportions of the layout
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.2-SVN
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 209806 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-07-17 11:04 UTC by Myriam Schweingruber
Modified: 2009-11-12 06:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Myriam Schweingruber 2009-07-17 11:04:10 UTC
I changed the layout to equal width of the three views. When clicking on the 'restore' button of the window, then 'maximize' again, the proportions are changed back to the apparently default 1:1:2 width.

Default seems now to be the 1:1:2 proportion, it should be 1:1:1 IMHO.
Comment 1 Myriam Schweingruber 2009-10-08 00:20:33 UTC
*** Bug 209806 has been marked as a duplicate of this bug. ***
Comment 2 Mark Kretschmann 2009-11-06 08:29:28 UTC
I've just fixed this:

NOTE: Args, my browser is borked. Someone please close the report as FIXED.



commit 606a2fd7714f80b820cbe837133accc2e90ec264
Author: Mark Kretschmann <kretschmann@kde.org>
Date:   Fri Nov 6 08:22:10 2009 +0100

    Fix: 1) Resizing borked layout. 2) Layout was not crash persistant.

    I think this is a pretty important fix. This had annoyed me (and probably
    others) a great deal. Now, when you resize main window, the proportions
    of the panes will be kept correctly.

    BUG: 200527
    BUG: 211509
Comment 3 Myriam Schweingruber 2009-11-06 09:57:27 UTC
Thanks :)
Comment 4 Mark Kretschmann 2009-11-06 12:57:19 UTC
Have to reopen this, we have found that it doesn't work in all cases. Further investigation needed.
Comment 5 Mark Kretschmann 2009-11-07 09:35:15 UTC
Please test this:


commit e33c6103b7f2985428bd74444878041ee6624302
Author: Mark Kretschmann <kretschmann@kde.org>
Date:   Fri Nov 6 18:42:10 2009 +0100

    Applied Nikolaj's layout resizing patch.

    The patch works fine here on my box. It doesn't work correctly on
    NHN's box in all cases. There is only one way to find out what's
    going on here: We need your help. Please test if the layout propoertions
    stay correct after resizing Amarok's main window in various ways.
Comment 6 Myriam Schweingruber 2009-11-07 10:22:16 UTC
Just tested on mine:
it works! But I see a one second delay when maximizing, it first shows a 1:1:2 layout again, then switches back to 1:1:1
Comment 7 Mark Kretschmann 2009-11-12 06:45:58 UTC
Fixed for 2.2.1.