Bug 200181 - Konqueror crashed when view two tabs (notify, .., KonqView::slotMouseOverInfo, KHTMLPart::overURL)
Summary: Konqueror crashed when view two tabs (notify, .., KonqView::slotMouseOverInfo...
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 184604 203690 206561 207724 208987 210634 211349 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-07-14 15:42 UTC by boldak
Modified: 2009-10-21 19:20 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description boldak 2009-07-14 15:42:55 UTC
Application that crashed: konqueror
Version of the application: 4.2.96 (KDE 4.2.96 (KDE 4.3 RC2))
KDE Version: 4.2.96 (KDE 4.2.96 (KDE 4.3 RC2))
Qt Version: 4.5.0
Operating System: Linux 2.6.28-13-generic x86_64
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
Konqueror crashed when i opened two tabs with this web site. First tab: http://www.lynx.cz/?cls=default and second tab: http://www.svethardware.cz/index.jsp

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#5  QCoreApplication::notifyInternal (this=0x7ffff88f9c10, receiver=0x0, event=0x7ffff88f6770) at kernel/qcoreapplication.cpp:586
#6  0x00007f0be4fec98d in KonqMainWindow::event (this=0x3d76b30, e=0x7ffff88f6770) at /usr/include/qt4/QtCore/qcoreapplication.h:213
#7  0x00007f0bed96e78d in QApplicationPrivate::notify_helper (this=0x1ab6230, receiver=0x3d76b30, e=0x7ffff88f6770) at kernel/qapplication.cpp:4084
#8  0x00007f0bed97697a in QApplication::notify (this=0x7ffff88f9c10, receiver=0x3d76b30, e=0x7ffff88f6770) at kernel/qapplication.cpp:4049
#9  0x00007f0beeab163b in KApplication::notify (this=0x7ffff88f9c10, receiver=0x3d76b30, event=0x7ffff88f6770) at /build/buildd/kde4libs-4.2.96/kdeui/kernel/kapplication.cpp:302
#10 0x00007f0bf03e575c in QCoreApplication::notifyInternal (this=0x7ffff88f9c10, receiver=0x3d76b30, event=0x7ffff88f6770) at kernel/qcoreapplication.cpp:602
#11 0x00007f0be4f9609d in KonqView::slotMouseOverInfo (this=0x3df8860, item=@0x7ffff88f6f40) at /usr/include/qt4/QtCore/qcoreapplication.h:213
#12 0x00007f0be4f99a31 in KonqView::qt_metacall (this=0x3df8860, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff88f68d0)
    at /build/buildd/kdebase-4.2.96/obj-x86_64-linux-gnu/apps/konqueror/src/konqview.moc:127
#13 0x00007f0bf03fb1f2 in QMetaObject::activate (sender=0x4269fb0, from_signal_index=<value optimized out>, to_signal_index=35, argv=0xffffffff) at kernel/qobject.cpp:3069
#14 0x00007f0befbff4e5 in KParts::BrowserExtension::mouseOverInfo (this=0x3, _t1=<value optimized out>) at /build/buildd/kde4libs-4.2.96/obj-x86_64-linux-gnu/kparts/browserextension.moc:377
#15 0x00007f0bdd611497 in KHTMLPart::overURL (this=0x3db6a10, url=<value optimized out>, target=@0x7ffff88f74b0) at /build/buildd/kde4libs-4.2.96/khtml/khtml_part.cpp:3534
#16 0x00007f0bdd61347e in KHTMLPart::handleMouseMoveEventOver (this=0x3db6a10, event=<value optimized out>) at /build/buildd/kde4libs-4.2.96/khtml/khtml_part.cpp:6338
#17 0x00007f0bdd61382b in KHTMLPart::khtmlMouseMoveEvent (this=0x3db6a10, event=0x7ffff88f7c40) at /build/buildd/kde4libs-4.2.96/khtml/khtml_part.cpp:6386
#18 0x00007f0bf03f589d in QObject::event (this=0x3db6a10, e=0x7ffff88f7c40) at kernel/qobject.cpp:1149
#19 0x00007f0bed96e78d in QApplicationPrivate::notify_helper (this=0x1ab6230, receiver=0x3db6a10, e=0x7ffff88f7c40) at kernel/qapplication.cpp:4084
#20 0x00007f0bed97697a in QApplication::notify (this=0x7ffff88f9c10, receiver=0x3db6a10, e=0x7ffff88f7c40) at kernel/qapplication.cpp:4049
#21 0x00007f0beeab163b in KApplication::notify (this=0x7ffff88f9c10, receiver=0x3db6a10, event=0x7ffff88f7c40) at /build/buildd/kde4libs-4.2.96/kdeui/kernel/kapplication.cpp:302
#22 0x00007f0bf03e575c in QCoreApplication::notifyInternal (this=0x7ffff88f9c10, receiver=0x3db6a10, event=0x7ffff88f7c40) at kernel/qcoreapplication.cpp:602
#23 0x00007f0bdd5ed6b8 in KHTMLView::mouseMoveEvent (this=0x43b0530, _mouse=0x7ffff88f88b0) at /usr/include/qt4/QtCore/qcoreapplication.h:213
#24 0x00007f0bed9bf768 in QWidget::event (this=0x43b0530, event=0x7ffff88f88b0) at kernel/qwidget.cpp:7501
#25 0x00007f0bedd5940b in QFrame::event (this=0x43b0530, e=0x7ffff88f88b0) at widgets/qframe.cpp:559
#26 0x00007f0bdd5ea975 in KHTMLView::widgetEvent (this=0x43b0530, e=0x0) at /build/buildd/kde4libs-4.2.96/khtml/khtmlview.cpp:2325
#27 0x00007f0bdd5eac54 in KHTMLView::eventFilter (this=0x43b0530, o=0x41cee70, e=0x7ffff88f88b0) at /build/buildd/kde4libs-4.2.96/khtml/khtmlview.cpp:2189
#28 0x00007f0bf03e4a68 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x41cee70, event=0x7ffff88f88b0) at kernel/qcoreapplication.cpp:718
#29 0x00007f0bed96e75c in QApplicationPrivate::notify_helper (this=0x1ab6230, receiver=0x41cee70, e=0x7ffff88f88b0) at kernel/qapplication.cpp:4080
#30 0x00007f0bed9770da in QApplication::notify (this=<value optimized out>, receiver=0x41cee70, e=0x7ffff88f88b0) at kernel/qapplication.cpp:3786
#31 0x00007f0beeab163b in KApplication::notify (this=0x7ffff88f9c10, receiver=0x41cee70, event=0x7ffff88f88b0) at /build/buildd/kde4libs-4.2.96/kdeui/kernel/kapplication.cpp:302
#32 0x00007f0bf03e575c in QCoreApplication::notifyInternal (this=0x7ffff88f9c10, receiver=0x41cee70, event=0x7ffff88f88b0) at kernel/qcoreapplication.cpp:602
#33 0x00007f0bed976328 in QApplicationPrivate::sendMouseEvent (receiver=0x41cee70, event=0x7ffff88f88b0, alienWidget=0x41cee70, nativeWidget=0x3d76b30, buttonDown=<value optimized out>, 
    lastMouseReceiver=@0x7f0bee3d2eb0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#34 0x00007f0bed9768a2 in QApplicationPrivate::sendSyntheticEnterLeave (this=<value optimized out>, widget=0x441b2e0) at kernel/qapplication.cpp:3022
#35 0x00007f0bed9c4d1a in QWidget::setVisible (this=0x441b2e0, visible=<value optimized out>) at kernel/qwidget.cpp:6944
#36 0x00007f0bed9a8905 in QStackedLayout::setCurrentIndex (this=0x3dfd960, index=0) at ../../include/QtGui/../../src/gui/kernel/qwidget.h:473
#37 0x00007f0bed9a8c4d in QStackedLayout::takeAt (this=0x3dfd960, index=0) at kernel/qstackedlayout.cpp:267
#38 0x00007f0bed997edf in QLayout::removeWidget (this=0x3dfd960, widget=0x3df5320) at kernel/qlayout.cpp:1408
#39 0x00007f0beeba4c74 in KTabWidget::Private::removeTab (this=0x3e5a9d0, index=0) at /build/buildd/kde4libs-4.2.96/kdeui/widgets/ktabwidget.cpp:141
#40 0x00007f0beeba4de5 in KTabWidget::removeTab (this=0x3e5b8c0, index=0) at /build/buildd/kde4libs-4.2.96/kdeui/widgets/ktabwidget.cpp:592
#41 0x00007f0be4fb43be in KonqFrameTabs::childFrameRemoved (this=0x3e5b8c0, frame=0x3df5348) at /build/buildd/kdebase-4.2.96/apps/konqueror/src/konqtabs.cpp:255
#42 0x00007f0be4fa06c5 in KonqViewManager::removeTab (this=0x292cba0, currentFrame=0x3df5348, emitAboutToRemoveSignal=<value optimized out>)
    at /build/buildd/kdebase-4.2.96/apps/konqueror/src/konqviewmanager.cpp:394
#43 0x00007f0be4fa88df in KonqViewManager::removeView (this=0x292cba0, view=0x3e4ac30) at /build/buildd/kdebase-4.2.96/apps/konqueror/src/konqviewmanager.cpp:583
#44 0x00007f0be4fa97d0 in KonqViewManager::removePart (this=0x292cba0, part=<value optimized out>) at /build/buildd/kdebase-4.2.96/apps/konqueror/src/konqviewmanager.cpp:625
#45 0x00007f0befbf6dac in ~Part (this=0x3e4a9c0, __vtt_parm=0x7f0bddcee970) at /build/buildd/kde4libs-4.2.96/kparts/part.cpp:203
#46 0x00007f0bdd6201a8 in ~KHTMLPart (this=0x3e4a9c0) at /build/buildd/kde4libs-4.2.96/khtml/khtml_part.cpp:625
#47 0x00007f0bf03f5865 in QObject::event (this=0x3e4a9c0, e=0x0) at kernel/qobject.cpp:1101
#48 0x00007f0bed96e78d in QApplicationPrivate::notify_helper (this=0x1ab6230, receiver=0x3e4a9c0, e=0x58961b0) at kernel/qapplication.cpp:4084
#49 0x00007f0bed97697a in QApplication::notify (this=0x7ffff88f9c10, receiver=0x3e4a9c0, e=0x58961b0) at kernel/qapplication.cpp:4049
#50 0x00007f0beeab163b in KApplication::notify (this=0x7ffff88f9c10, receiver=0x3e4a9c0, event=0x58961b0) at /build/buildd/kde4libs-4.2.96/kdeui/kernel/kapplication.cpp:302
#51 0x00007f0bf03e575c in QCoreApplication::notifyInternal (this=0x7ffff88f9c10, receiver=0x3e4a9c0, event=0x58961b0) at kernel/qcoreapplication.cpp:602
#52 0x00007f0bf03e63ca in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1a21320) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#53 0x00007f0bf040f1e3 in postEventSourceDispatch (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#54 0x00007f0bec3cc20a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#55 0x00007f0bec3cf8e0 in ?? () from /usr/lib/libglib-2.0.so.0
#56 0x00007f0bec3cfa7c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#57 0x00007f0bf040ee6f in QEventDispatcherGlib::processEvents (this=0x1ab5c70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:323
#58 0x00007f0beda06bef in QGuiEventDispatcherGlib::processEvents (this=0x3, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#59 0x00007f0bf03e4002 in QEventLoop::processEvents (this=<value optimized out>, flags={i = -124806832}) at kernel/qeventloop.cpp:149
#60 0x00007f0bf03e43cd in QEventLoop::exec (this=0x7ffff88f9990, flags={i = -124806752}) at kernel/qeventloop.cpp:200
#61 0x00007f0bf03e6694 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:880
#62 0x00007f0be501fd02 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /build/buildd/kdebase-4.2.96/apps/konqueror/src/konqmain.cpp:271
#63 0x0000000000407215 in launch (argc=4, _name=0x1a5d448 "konqueror", args=<value optimized out>, cwd=0x1a5d481 "/home/boldak/Dokumenty", envc=31, envs=0x1a5d969 "", reset_env=true, tty=0x0, 
    avoid_loops=false, startup_id_str=0x1a5d972 "boldak-desktop;1247577938;915608;3758_TIME2577824") at /build/buildd/kde4libs-4.2.96/kinit/kinit.cpp:676
#64 0x0000000000407a38 in handle_launcher_request (sock=15, who=<value optimized out>) at /build/buildd/kde4libs-4.2.96/kinit/kinit.cpp:1168
#65 0x0000000000407fc5 in handle_requests (waitForPid=0) at /build/buildd/kde4libs-4.2.96/kinit/kinit.cpp:1352
#66 0x0000000000408b26 in main (argc=2, argv=0x7ffff88fb2f8, envp=0x7ffff88fb310) at /build/buildd/kde4libs-4.2.96/kinit/kinit.cpp:1788

Reported using DrKonqi
Comment 1 Dario Andres 2009-07-14 16:21:53 UTC
The backtrace looks related to bug 184604 (which only happens in filebrowsing mode). Can you reproduce the crash at will using that two webpageS?
Thanks
Comment 2 Dario Andres 2009-07-14 16:58:56 UTC
The reporter sent me an email:
---------

Yes, I try reproduce this bug. When I now open this webpages in different tabs
so this bug not find. I dont know where is problem. :(

-------

The other report said that you had to have the mouse cursor over some file, so I'm wondering if in this case you would need to have the mouse cursor over some specific text/link/image/element.
Comment 3 Dario Andres 2009-08-16 21:06:22 UTC
*** Bug 203690 has been marked as a duplicate of this bug. ***
Comment 4 Michael Leupold 2009-09-07 01:23:14 UTC
Are you sure this bug didn't happen when you closed one of the tabs? At least that's what the crash report suggests.
Comment 5 Dario Andres 2009-09-07 14:18:53 UTC
*** Bug 206561 has been marked as a duplicate of this bug. ***
Comment 6 Dario Andres 2009-09-07 14:19:16 UTC
Bug 206561 provides a new testcase, can you check it ? Thanks
Comment 7 David Faure 2009-09-07 15:49:10 UTC
From the bt: yes the mouse needs to be over a link at the time the tab is closed.

I initially thought I saw the problem, but there are in fact two KHTMLParts involved in this backtrace - the one is being deleted, and the one which gets the "mouse over url" event. I don't know if the mouse has to be over a url in the first or in the second khtml part.

If someone can reproduceably get the crash, a valgrind log would be very useful.
Comment 8 Dario Andres 2009-09-07 16:32:13 UTC
Additional information:
--------------

** (attempt of) Testcase steps:

Run directly on Valgrind as the slowdown will help us to reproduce the crash

- Start Konqueror
(it opens an empty/home/intro tab)  (I have the introduction page as default)
- Create a new blank tab
The new tab is focused/active
- Start loading the URL: http://www.pcinpact.com/affichage/52354-kde-43-nouveautes-version-finale/74209.htm
DO NOT WAIT FOR IT TO BE LOADED, CONTINUE INMEDIATLY
- Open the Terminal emulator (Settings/Show terminal panel)
- Write "exit" in the terminal, DO NOT press enter yet
- Wait until the page loads 50% (the first texts starts appearing, but the image in the middle is not there yet)
- Hover one of the links in the bottom of the page, DO NOT CLICK IT ( I used the "Personnaliser Windows", the second link in the middle line of the footer)
(The terminal panel still has keyboard focus)
- Press enter
- Konqueror should crash (if not, repeat or restart Konqueror)

If you wait until the page is completely loaded it may not work. 
Valgrind should help us with this as it slowdowns everything.

** Valgrind log:

==12906==                                                                                                                     
==12906== Invalid read of size 4                                                                                              
==12906==    at 0x4DD5930: QObject::d_func() (qobject.h:118)                                                                  
==12906==    by 0x4EE6185: QCoreApplication::notifyInternal(QObject*, QEvent*) (qcoreapplication.cpp:593)                     
==12906==    by 0x40BF29D: KonqMainWindow::event(QEvent*) (qcoreapplication.h:213)                                            
==12906==    by 0x51BD2DA: QApplicationPrivate::notify_helper(QObject*, QEvent*) (qapplication.cpp:4056)                      
==12906==    by 0x51BD135: QApplication::notify(QObject*, QEvent*) (qapplication.cpp:4021)                                    
==12906==    by 0x47F4CB9: KApplication::notify(QObject*, QEvent*) (kapplication.cpp:302)                                     
==12906==    by 0x4EE61C0: QCoreApplication::notifyInternal(QObject*, QEvent*) (qcoreapplication.cpp:610)                     
==12906==    by 0x405CCE6: KonqView::slotMouseOverInfo(KFileItem const&) (qcoreapplication.h:213)                             
==12906==    by 0x40621D8: KonqView::qt_metacall(QMetaObject::Call, int, void**) (konqview.moc:127)                           
==12906==    by 0x4EFF9C9: QMetaObject::activate(QObject*, int, int, void**) (qobject.cpp:3112)                               
==12906==    by 0x4EFFD41: QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (qobject.cpp:3186)                
==12906==    by 0x41D2B02: KParts::BrowserExtension::mouseOverInfo(KFileItem const&) (browserextension.moc:377)               
==12906==    by 0x9D8991E: KHTMLPart::resetHoverText() (khtml_part.cpp:3506)                                                  
==12906==    by 0x9D7011D: KHTMLView::eventFilter(QObject*, QEvent*) (khtmlview.cpp:2186)                                     
==12906==    by 0x4EE649E: QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) (qcoreapplication.cpp:726)                                                                                                                             
==12906==    by 0x51BD2B6: QApplicationPrivate::notify_helper(QObject*, QEvent*) (qapplication.cpp:4052)                      
==12906==    by 0x51BD135: QApplication::notify(QObject*, QEvent*) (qapplication.cpp:4021)                                    
==12906==    by 0x47F4CB9: KApplication::notify(QObject*, QEvent*) (kapplication.cpp:302)                                     
==12906==    by 0x4EE61C0: QCoreApplication::notifyInternal(QObject*, QEvent*) (qcoreapplication.cpp:610)                     
==12906==    by 0x4EE9B86: QCoreApplication::sendEvent(QObject*, QEvent*) (qcoreapplication.h:213)                            
==12906==    by 0x51B94E3: QApplicationPrivate::dispatchEnterLeave(QWidget*, QWidget*) (qapplication.cpp:2584)                
==12906==    by 0x51BA72A: QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&) (qapplication.cpp:2908)                                                                                           
==12906==    by 0x51BACD4: QApplicationPrivate::sendSyntheticEnterLeave(QWidget*) (qapplication.cpp:3006)                     
==12906==    by 0x521C92A: QWidgetPrivate::hideChildren(bool) (qwidget.cpp:7093)                                              
==12906==    by 0x521C88E: QWidgetPrivate::hideChildren(bool) (qwidget.cpp:7079)                                              
==12906==    by 0x521C88E: QWidgetPrivate::hideChildren(bool) (qwidget.cpp:7079)                                              
==12906==    by 0x521C88E: QWidgetPrivate::hideChildren(bool) (qwidget.cpp:7079)                                              
==12906==    by 0x521C88E: QWidgetPrivate::hideChildren(bool) (qwidget.cpp:7079)                                              
==12906==    by 0x521C88E: QWidgetPrivate::hideChildren(bool) (qwidget.cpp:7079)                                              
==12906==    by 0x521C88E: QWidgetPrivate::hideChildren(bool) (qwidget.cpp:7079)                                              
==12906==    by 0x521BCA6: QWidgetPrivate::hide_helper() (qwidget.cpp:6843)                                                   
==12906==    by 0x521C450: QWidget::setVisible(bool) (qwidget.cpp:7012)                                                       
==12906==    by 0x51FDCAD: QWidget::hide() (qwidget.h:477)                                                                    
==12906==    by 0x521FD79: QWidget::setParent(QWidget*, QFlags<Qt::WindowType>) (qwidget.cpp:9204)                            
==12906==    by 0x521FBB5: QWidget::setParent(QWidget*) (qwidget.cpp:9172)                                                    
==12906==    by 0x409790A: KonqMainWindow::insertChildFrame(KonqFrameBase*, int) (konqmainwindow.cpp:5498)                    
==12906==    by 0x407736F: KonqFrameContainerBase::replaceChildFrame(KonqFrameBase*, KonqFrameBase*) (konqframecontainer.cpp:32)                                                                                                                            
==12906==    by 0x4069746: KonqViewManager::removeView(KonqView*) (konqviewmanager.cpp:562)                                   
==12906==    by 0x4069C62: KonqViewManager::slotPassiveModePartDeleted() (konqviewmanager.cpp:644)                            
==12906==    by 0x4070672: KonqViewManager::qt_metacall(QMetaObject::Call, int, void**) (konqviewmanager.moc:93)              
==12906==    by 0x4EFF9C9: QMetaObject::activate(QObject*, int, int, void**) (qobject.cpp:3112)                               
==12906==    by 0x4EFFE0C: QMetaObject::activate(QObject*, QMetaObject const*, int, int, void**) (qobject.cpp:3206)           
==12906==    by 0x4F012E7: QObject::destroyed(QObject*) (moc_qobject.cpp:143)                                                 
==12906==    by 0x4EFA8A9: QObject::~QObject() (qobject.cpp:757)                                                              
==12906==    by 0x41C887E: KParts::Part::~Part() (part.cpp:212)                                                               
==12906==    by 0x41C8F59: KParts::ReadOnlyPart::~ReadOnlyPart() (part.cpp:459)                                               
==12906==    by 0xE28041F: Konsole::Part::~Part() (Part.cpp:114)                                                              
==12906==    by 0x4F00F9D: qDeleteInEventHandler(QObject*) (qobject.cpp:3814)                                                 
==12906==    by 0x4EFBC27: QObject::event(QEvent*) (qobject.cpp:1093)                                                         
==12906==    by 0x51BD2DA: QApplicationPrivate::notify_helper(QObject*, QEvent*) (qapplication.cpp:4056)
==12906==  Address 0x4 is not stack'd, malloc'd or (recently) free'd
KCrash: Application 'konqueror' crashing...
sock_file=/home/kde-devel/.kde4/socket-emiDell/kdeinit4__0

[1]+  Detenido                valgrind --num-callers=50 konqueror
bash-4.0$ ==12906==
==12906== ERROR SUMMARY: 36 errors from 3 contexts (suppressed: 407 from 3)
==12906== malloc/free: in use at exit: 26,308,419 bytes in 160,425 blocks.
==12906== malloc/free: 1,047,686 allocs, 887,261 frees, 218,676,312 bytes allocated.
==12906== For counts of detected errors, rerun with: -v
==12906== searching for pointers to 160,425 not-freed blocks.
==12906== checked 66,205,304 bytes.
==12906==
==12906== LEAK SUMMARY:
==12906==    definitely lost: 49,536 bytes in 2,049 blocks.
==12906==      possibly lost: 218,062 bytes in 5,217 blocks.
==12906==    still reachable: 26,040,821 bytes in 153,159 blocks.
==12906==         suppressed: 0 bytes in 0 blocks.
==12906== Rerun with --leak-check=full to see details of leaked memory.
Comment 9 Dario Andres 2009-09-07 16:43:31 UTC
The patch proposed at http://pastebin.com/d4f11121a seems to be fix the testcase I added (only tested once, valgrind is slow. I'm going to recheck later). It also seems to fix the DolphinPart crash

--- apps/konqueror/src/konqmainwindow.cpp    (revision 1019778)
+++ apps/konqueror/src/konqmainwindow.cpp    (working copy)
 -5635,8 +5635,11 @@ bool KonqMainWindow::event( QEvent* e )
         // Forward the event to all views
         MapViews::ConstIterator it = m_mapViews.constBegin();
         MapViews::ConstIterator end = m_mapViews.constEnd();
-        for (; it != end; ++it )
-            QApplication::sendEvent( (*it)->part(), e );
+        for (; it != end; ++it ) {
+            if ((*it)->part() != 0L) {
+                QApplication::sendEvent( (*it)->part(), e );
+            }
+        }
         return true;
     }
     if ( KParts::OpenUrlEvent::test( e ) )
Comment 10 David Faure 2009-09-08 14:51:56 UTC
SVN commit 1021167 by dfaure:

Remove part from m_mapViews before actually deleting it (which can lead to a
mouse-over-url event which is then sent to all views in the map).
Many thanks to lemma for the analysis of the problem.
BUGS: 200181, 184604


 M  +5 -4      konqviewmanager.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1021167
Comment 11 David Faure 2009-09-17 23:19:57 UTC
*** Bug 207724 has been marked as a duplicate of this bug. ***
Comment 12 Dario Andres 2009-09-30 16:01:16 UTC
*** Bug 208987 has been marked as a duplicate of this bug. ***
Comment 13 Dario Andres 2009-10-18 01:57:03 UTC
*** Bug 210634 has been marked as a duplicate of this bug. ***
Comment 14 Dario Andres 2009-10-18 01:57:07 UTC
*** Bug 184604 has been marked as a duplicate of this bug. ***
Comment 15 Dario Andres 2009-10-21 19:20:13 UTC
*** Bug 211349 has been marked as a duplicate of this bug. ***