Bug 184604 - konqueror crash by typing "exit" in terminal emulator (notify, KonqView::slotMouseOverInfo, DolphinPart::slotRequestItemInfo)
Summary: konqueror crash by typing "exit" in terminal emulator (notify, KonqView::slot...
Status: RESOLVED DUPLICATE of bug 200181
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Unspecified
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 188267 206375 206410 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-02-17 09:43 UTC by Felix Lemke
Modified: 2009-10-18 01:57 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Lemke 2009-02-17 09:43:46 UTC
Version:            (using Devel)
Installed from:    Compiled sources

When I open the terminal emulator and type "exit" or push "Ctrl-D" konqueror crashs. It happens only when the mouse cursor is over the file view just before the terminal is closed.

Anwendung: Konqueror (konqueror), Signal SIGSEGV
[?1034h[Thread debugging using libthread_db enabled]
[Current thread is 0 (LWP 6077)]

Thread 2 (Thread 0xb1c64b90 (LWP 6085)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6410ed1 in select () from /lib/libc.so.6
#2  0xb72102a7 in QProcessManager::run (this=0x806be60) at io/qprocess_unix.cpp:300
#3  0xb713e72e in QThreadPrivate::start (arg=0x806be60) at thread/qthread_unix.cpp:184
#4  0xb70de175 in start_thread () from /lib/libpthread.so.0
#5  0xb6417dae in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5e336d0 (LWP 6077)):
[KCrash Handler]
#6  QCoreApplication::notifyInternal (this=0xbf92e3a8, receiver=0x0, event=0xbf92c994) at kernel/qcoreapplication.cpp:578
#7  0xb7e99884 in KonqMainWindow::event (this=0x8148368, e=0xbf92c994) at /usr/include/QtCore/qcoreapplication.h:209
#8  0xb685451c in QApplicationPrivate::notify_helper (this=0x80608b0, receiver=0x8148368, e=0xbf92c994) at kernel/qapplication.cpp:4051
#9  0xb685c8fa in QApplication::notify (this=0xbf92e3a8, receiver=0x8148368, e=0xbf92c994) at kernel/qapplication.cpp:4016
#10 0xb77c9e4d in KApplication::notify (this=0xbf92e3a8, receiver=0x8148368, event=0xbf92c994) at /usr/src/debug/kdelibs-4.2.63.svn925121/kdeui/kernel/kapplication.cpp:307
#11 0xb723284b in QCoreApplication::notifyInternal (this=0xbf92e3a8, receiver=0x8148368, event=0xbf92c994) at kernel/qcoreapplication.cpp:594
#12 0xb7e3c934 in KonqView::slotMouseOverInfo (this=0x84e4410, item=@0xbf92cc1c) at /usr/include/QtCore/qcoreapplication.h:209
#13 0xb7e407ef in KonqView::qt_metacall (this=0x84e4410, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0xbf92caac) at /usr/src/debug/kdebase-4.2.63.svn925121/build/apps/konqueror/src/konqview.moc:126
#14 0xb7248b98 in QMetaObject::activate (sender=0x84e9d08, from_signal_index=35, to_signal_index=35, argv=0xbf92caac) at kernel/qobject.cpp:3064
#15 0xb724a312 in QMetaObject::activate (sender=0x84e9d08, m=0xb7d7f9ec, local_signal_index=31, argv=0xbf92caac) at kernel/qobject.cpp:3136
#16 0xb7d691e3 in KParts::BrowserExtension::mouseOverInfo (this=0x84e9d08, _t1=@0xbf92cc1c) at /usr/src/debug/kdelibs-4.2.63.svn925121/build/kparts/browserextension.moc:375
#17 0xb3ac3ddf in DolphinPart::slotRequestItemInfo (this=0x84ebc80, item=@0xbf92cc1c) at /usr/src/debug/kdebase-4.2.63.svn925121/apps/dolphin/src/dolphinpart.cpp:308
#18 0xb3ac55fe in DolphinPart::qt_metacall (this=0x84ebc80, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xbf92cbec)
    at /usr/src/debug/kdebase-4.2.63.svn925121/build/apps/dolphin/src/dolphinpart.moc:115
#19 0xb7248b98 in QMetaObject::activate (sender=0x86275b0, from_signal_index=40, to_signal_index=40, argv=0xbf92cbec) at kernel/qobject.cpp:3064
#20 0xb724a312 in QMetaObject::activate (sender=0x86275b0, m=0xb3a8aec4, local_signal_index=13, argv=0xbf92cbec) at kernel/qobject.cpp:3136
#21 0xb3a59eb3 in DolphinView::requestItemInfo (this=0x86275b0, _t1=@0xbf92cc1c) at /usr/src/debug/kdebase-4.2.63.svn925121/build/apps/dolphin/src/dolphinview.moc:304
#22 0xb3a5a5c1 in DolphinView::clearHoverInformation (this=0x86275b0) at /usr/src/debug/kdebase-4.2.63.svn925121/apps/dolphin/src/dolphinview.cpp:1113
#23 0xb3a61027 in DolphinView::qt_metacall (this=0x86275b0, _c=QMetaObject::InvokeMetaMethod, _id=46, _a=0xbf92ccc8)
    at /usr/src/debug/kdebase-4.2.63.svn925121/build/apps/dolphin/src/dolphinview.moc:204
#24 0xb7248b98 in QMetaObject::activate (sender=0x84ac7c0, from_signal_index=16, to_signal_index=16, argv=0x0) at kernel/qobject.cpp:3064
#25 0xb724a312 in QMetaObject::activate (sender=0x84ac7c0, m=0xb3a8a43c, local_signal_index=12, argv=0x0) at kernel/qobject.cpp:3136
#26 0xb3a482c7 in DolphinController::viewportEntered (this=0x84ac7c0) at /usr/src/debug/kdebase-4.2.63.svn925121/build/apps/dolphin/src/dolphincontroller.moc:213
#27 0xb3a482ed in DolphinController::emitViewportEntered (this=0x84ac7c0) at /usr/src/debug/kdebase-4.2.63.svn925121/apps/dolphin/src/dolphincontroller.cpp:215
#28 0xb3a4e5e4 in DolphinIconsView::leaveEvent (this=0x84c6760, event=0xbf92d298) at /usr/src/debug/kdebase-4.2.63.svn925121/apps/dolphin/src/dolphiniconsview.cpp:314
#29 0xb68ab082 in QWidget::event (this=0x84c6760, event=0xbf92d298) at kernel/qwidget.cpp:7637
#30 0xb6c67a03 in QFrame::event (this=0x84c6760, e=0xbf92d298) at widgets/qframe.cpp:554
#31 0xb6d0881d in QAbstractScrollArea::event (this=0x84c6760, e=0xbf92d298) at widgets/qabstractscrollarea.cpp:913
#32 0xb6db2cd7 in QAbstractItemView::event (this=0x84c6760, event=0xbf92d298) at itemviews/qabstractitemview.cpp:1396
#33 0xb6dcc9b4 in QListView::event (this=0x84c6760, e=0xbf92d298) at itemviews/qlistview.cpp:1914
#34 0xb685451c in QApplicationPrivate::notify_helper (this=0x80608b0, receiver=0x84c6760, e=0xbf92d298) at kernel/qapplication.cpp:4051
#35 0xb685c8fa in QApplication::notify (this=0xbf92e3a8, receiver=0x84c6760, e=0xbf92d298) at kernel/qapplication.cpp:4016
#36 0xb77c9e4d in KApplication::notify (this=0xbf92e3a8, receiver=0x84c6760, event=0xbf92d298) at /usr/src/debug/kdelibs-4.2.63.svn925121/kdeui/kernel/kapplication.cpp:307
#37 0xb723284b in QCoreApplication::notifyInternal (this=0xbf92e3a8, receiver=0x84c6760, event=0xbf92d298) at kernel/qcoreapplication.cpp:594
#38 0xb685b983 in QApplicationPrivate::dispatchEnterLeave (enter=0x8148368, leave=0x85f4c08) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:208
#39 0xb685c3ca in QApplicationPrivate::sendMouseEvent (receiver=0x8148368, event=0xbf92d388, alienWidget=0x0, nativeWidget=0x8148368, buttonDown=0xb70d5a20, lastMouseReceiver=@0xb70d5a24)
    at kernel/qapplication.cpp:2897
#40 0xb685c6e9 in QApplicationPrivate::sendSyntheticEnterLeave (this=0x80608b0, widget=0x85f4c08) at kernel/qapplication.cpp:2995
#41 0xb68a94cc in QWidgetPrivate::hideChildren (this=0x84c06a0, spontaneous=false) at kernel/qwidget.cpp:7054
#42 0xb68a9480 in QWidgetPrivate::hideChildren (this=0x84e11f8, spontaneous=false) at kernel/qwidget.cpp:7040
#43 0xb68a9480 in QWidgetPrivate::hideChildren (this=0x84ef8d0, spontaneous=false) at kernel/qwidget.cpp:7040
#44 0xb68a9480 in QWidgetPrivate::hideChildren (this=0x83a0590, spontaneous=false) at kernel/qwidget.cpp:7040
#45 0xb68a9480 in QWidgetPrivate::hideChildren (this=0x83a0240, spontaneous=false) at kernel/qwidget.cpp:7040
#46 0xb68a9480 in QWidgetPrivate::hideChildren (this=0x8376788, spontaneous=false) at kernel/qwidget.cpp:7040
#47 0xb68a9480 in QWidgetPrivate::hideChildren (this=0x853cc70, spontaneous=false) at kernel/qwidget.cpp:7040
#48 0xb68a9688 in QWidgetPrivate::hide_helper (this=0x853cc70) at kernel/qwidget.cpp:6804
#49 0xb68b10b0 in QWidget::setVisible (this=0x8613778, visible=false) at kernel/qwidget.cpp:6973
#50 0xb68af4b0 in QWidget::setParent (this=0x8613778, parent=0x0, f={i = -1080895664}) at ../../include/QtGui/../../src/gui/kernel/qwidget.h:472
#51 0xb68af61e in QWidget::setParent (this=0xb7326490, parent=0x0) at kernel/qwidget.cpp:9115
#52 0xb7e785eb in KonqMainWindow::insertChildFrame (this=0x8148368, frame=0x837672c) at /usr/src/debug/kdebase-4.2.63.svn925121/apps/konqueror/src/konqmainwindow.cpp:5525
#53 0xb7e57d60 in KonqFrameContainerBase::replaceChildFrame (this=0x814838c, oldFrame=0x861378c, newFrame=0x837672c)
    at /usr/src/debug/kdebase-4.2.63.svn925121/apps/konqueror/src/konqframecontainer.cpp:32
#54 0xb7e50225 in KonqViewManager::removeView (this=0x81c5780, view=0x86690c0) at /usr/src/debug/kdebase-4.2.63.svn925121/apps/konqueror/src/konqviewmanager.cpp:540
#55 0xb7e50c1a in KonqViewManager::slotPassiveModePartDeleted (this=0x81c5780) at /usr/src/debug/kdebase-4.2.63.svn925121/apps/konqueror/src/konqviewmanager.cpp:618
#56 0xb7e5109b in KonqViewManager::qt_metacall (this=0x81c5780, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbf92d9fc)
    at /usr/src/debug/kdebase-4.2.63.svn925121/build/apps/konqueror/src/konqviewmanager.moc:92
#57 0xb7248b98 in QMetaObject::activate (sender=0x854c148, from_signal_index=0, to_signal_index=1, argv=0xbf92d9fc) at kernel/qobject.cpp:3064
#58 0xb7248fc0 in QMetaObject::activate (sender=0x854c148, m=0xb73211a8, from_local_signal_index=0, to_local_signal_index=1, argv=0xbf92d9fc) at kernel/qobject.cpp:3156
#59 0xb724904b in QObject::destroyed (this=0x854c148, _t1=0x854c148) at .moc/release-shared/moc_qobject.cpp:143
#60 0xb7249d99 in ~QObject (this=0x854c148) at kernel/qobject.cpp:764
#61 0xb7d60357 in ~Part (this=0x854c148, __vtt_parm=0xb302ea88) at /usr/src/debug/kdelibs-4.2.63.svn925121/kparts/part.cpp:212
#62 0xb7d6066a in ~ReadOnlyPart (this=0x854c148, __vtt_parm=0xb302ea84) at /usr/src/debug/kdelibs-4.2.63.svn925121/kparts/part.cpp:459
#63 0xb302c240 in ~Part (this=0x854c148) at /usr/src/debug/kdebase-4.2.63.svn925121/apps/konsole/src/Part.cpp:116
#64 0xb72419b5 in qDeleteInEventHandler (o=0xb7326490) at kernel/qobject.cpp:3764
#65 0xb72432a3 in QObject::event (this=0x854c148, e=0x853c190) at kernel/qobject.cpp:1096
#66 0xb685451c in QApplicationPrivate::notify_helper (this=0x80608b0, receiver=0x854c148, e=0x853c190) at kernel/qapplication.cpp:4051
#67 0xb685c7ee in QApplication::notify (this=0xbf92e3a8, receiver=0x854c148, e=0x853c190) at kernel/qapplication.cpp:3598
#68 0xb77c9e4d in KApplication::notify (this=0xbf92e3a8, receiver=0x854c148, event=0x853c190) at /usr/src/debug/kdelibs-4.2.63.svn925121/kdeui/kernel/kapplication.cpp:307
#69 0xb723284b in QCoreApplication::notifyInternal (this=0xbf92e3a8, receiver=0x854c148, event=0x853c190) at kernel/qcoreapplication.cpp:594
#70 0xb7233495 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x804c330) at kernel/qcoreapplication.h:208
#71 0xb723368d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1124
#72 0xb725e75f in postEventSourceDispatch (s=0x806ab20) at kernel/qcoreapplication.h:213
#73 0xb61762d9 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#74 0xb617985b in ?? () from /usr/lib/libglib-2.0.so.0
#75 0xb61799d8 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#76 0xb725e3a8 in QEventDispatcherGlib::processEvents (this=0x8060280, flags={i = -1080893224}) at kernel/qeventdispatcher_glib.cpp:318
#77 0xb68f4245 in QGuiEventDispatcherGlib::processEvents (this=0x8060280, flags={i = -1080893176}) at kernel/qguieventdispatcher_glib.cpp:197
#78 0xb7230e8a in QEventLoop::processEvents (this=0xbf92e180, flags={i = -1080893112}) at kernel/qeventloop.cpp:144
#79 0xb72312ca in QEventLoop::exec (this=0xbf92e180, flags={i = -1080893048}) at kernel/qeventloop.cpp:195
#80 0xb7233759 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:872
#81 0xb6854397 in QApplication::exec () at kernel/qapplication.cpp:3526
#82 0xb7ecb07f in kdemain (argc=4, argv=0xbf92e724) at /usr/src/debug/kdebase-4.2.63.svn925121/apps/konqueror/src/konqmain.cpp:257
#83 0x08048722 in main (argc=) at /usr/src/debug/kdebase-4.2.63.svn925121/build/apps/konqueror/src/konqueror_dummy.cpp:3
Comment 1 FiNeX 2009-02-17 15:07:24 UTC
I can reproduce only when I'm on file view mode, when I'm browsing web pages I cannot reproduce the crash. I'm using trunk r927301.
Comment 2 Felix Lemke 2009-02-17 15:50:04 UTC
The same for me.
Comment 3 Jonathan Thomas 2009-04-15 15:02:43 UTC
*** Bug 188267 has been marked as a duplicate of this bug. ***
Comment 4 Dario Andres 2009-09-05 17:11:33 UTC
*** Bug 206375 has been marked as a duplicate of this bug. ***
Comment 5 Dario Andres 2009-09-06 16:29:19 UTC
*** Bug 206410 has been marked as a duplicate of this bug. ***
Comment 6 Dario Andres 2009-09-30 16:01:54 UTC
This could/should be fixed by the commit on bug 200181, can anyone check that ? Thanks
Comment 7 Dario Andres 2009-10-18 01:57:07 UTC

*** This bug has been marked as a duplicate of bug 200181 ***