Bug 199888 - Konqueror crashed on exit
Summary: Konqueror crashed on exit
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-12 17:02 UTC by Marcus Harrison
Modified: 2009-07-12 19:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Harrison 2009-07-12 17:02:12 UTC
Application that crashed: konqueror
Version of the application: 4.2.96 (KDE 4.2.96 (KDE 4.3 RC2))
KDE Version: 4.2.96 (KDE 4.2.96 (KDE 4.3 RC2))
Qt Version: 4.5.2
Operating System: Linux 2.6.30-gentoo-r1 i686

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Aborted
[KCrash Handler]
#6  0xb806e424 in __kernel_vsyscall ()
#7  0xb68b9980 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#8  0xb68bb1c8 in abort () at abort.c:88
#9  0xb68b2a5e in __assert_fail (assertion=0xb26f64d1 "!s_refcnt", file=0xb26f642c "/var/tmp/portage/kde-base/kdelibs-4.2.96/work/kdelibs-4.2.96/khtml/khtml_global.cpp", line=258, 
    function=0xb26f6640 "static void KHTMLGlobal::finalCheck()") at assert.c:78
#10 0xb235cbe4 in KHTMLGlobal::finalCheck () at /var/tmp/portage/kde-base/kdelibs-4.2.96/work/kdelibs-4.2.96/khtml/khtml_global.cpp:258
#11 0xb20f73bc in ~KHTMLFactory (this=0x93eb0d0) at /var/tmp/portage/kde-base/kdelibs-4.2.96/work/kdelibs-4.2.96/khtml/khtml_factory.cpp:35
#12 0xb7dc63d1 in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x9cc8a88}, end={i = 0x94b1538}) at /usr/include/qt4/QtCore/qalgorithms.h:350
#13 0xb7dc6448 in qDeleteAll<FactoryHash> (c=@0x9485678) at /usr/include/qt4/QtCore/qalgorithms.h:358
#14 0xb7dc6672 in ~FactoryHash (this=0x9485678) at /var/tmp/portage/kde-base/kdelibs-4.2.96/work/kdelibs-4.2.96/kdecore/util/klibrary.cpp:93
#15 0xb7dc545d in destroy () at /var/tmp/portage/kde-base/kdelibs-4.2.96/work/kdelibs-4.2.96/kdecore/util/klibrary.cpp:97
#16 0xb7c9ac8b in ~KCleanUpGlobalStatic (this=0xb7e1a450) at /var/tmp/portage/kde-base/kdelibs-4.2.96/work/kdelibs-4.2.96/kdecore/kernel/kglobal.h:62
#17 0xb68bc859 in __run_exit_handlers (status=0, listp=0xb69d5304, run_list_atexit=true) at exit.c:78
#18 0xb68bc8bf in exit (status=0) at exit.c:100
#19 0x0804e50d in launch (argc=2, _name=0x9089fec "konqueror", args=0x9089fff "", cwd=0x0, envc=1, envs=0x908a004 "DISPLAY=:0.0", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x80524a0 "0") at /var/tmp/portage/kde-base/kdelibs-4.2.96/work/kdelibs-4.2.96/kinit/kinit.cpp:676
#20 0x0804f077 in handle_launcher_request (sock=7, who=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.2.96/work/kdelibs-4.2.96/kinit/kinit.cpp:1168
#21 0x0804f737 in handle_requests (waitForPid=0) at /var/tmp/portage/kde-base/kdelibs-4.2.96/work/kdelibs-4.2.96/kinit/kinit.cpp:1361
#22 0x0804fce4 in main (argc=2, argv=0xbfff27e4, envp=0xbfff27f0) at /var/tmp/portage/kde-base/kdelibs-4.2.96/work/kdelibs-4.2.96/kinit/kinit.cpp:1788

This bug may be a duplicate of or related to bug 199529

Reported using DrKonqi
Comment 1 FiNeX 2009-07-12 19:20:49 UTC

*** This bug has been marked as a duplicate of bug 151453 ***