Bug 199529 - konqueror crash on exit
Summary: konqueror crash on exit
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-09 09:54 UTC by René Serral
Modified: 2009-07-09 10:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description René Serral 2009-07-09 09:54:02 UTC
Application that crashed: konqueror
Version of the application: 4.3.60 (KDE 4.3.60 (KDE 4.4 >= 20090624))
KDE Version: 4.3.60 (KDE 4.3.60 (KDE 4.4 >= 20090624))
Qt Version: 4.5.1
Operating System: Linux 2.6.30-notuxonice i686
Distribution: Debian GNU/Linux 5.0.2 (lenny)

What I was doing when the application crashed:
From some time now, konqueror compiled from SVN (currently version from past week) crashes almost always when closing the application (~99% of the times)

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Aborted
[KCrash Handler]
#6  0xb7fec424 in __kernel_vsyscall ()
#7  0xb65483a0 in raise () from /lib/i686/cmov/libc.so.6
#8  0xb654ba55 in abort () from /lib/i686/cmov/libc.so.6
#9  0xb65414be in __assert_fail () from /lib/i686/cmov/libc.so.6
#10 0xb259db2d in KHTMLGlobal::finalCheck () at /media/kdesvn/kde4svn/src/kdelibs/khtml/khtml_global.cpp:258
#11 0xb2f5a323 in ~KHTMLFactory (this=0x9e02148, __in_chrg=<value optimized out>) at /media/kdesvn/kde4svn/src/kdelibs/khtml/khtml_factory.cpp:35
#12 0xb7d0b0cb in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin=..., end=...) at /usr/include/qt4/QtCore/qalgorithms.h:350
#13 0xb7d0b130 in qDeleteAll<FactoryHash> (c=...) at /usr/include/qt4/QtCore/qalgorithms.h:358
#14 0xb7d0b349 in ~FactoryHash (this=0x9e02800, __in_chrg=<value optimized out>) at /media/kdesvn/kde4svn/src/kdelibs/kdecore/util/klibrary.cpp:93
#15 0xb7d0a1d2 in destroy () at /media/kdesvn/kde4svn/src/kdelibs/kdecore/util/klibrary.cpp:97
#16 0xb7bcd443 in ~KCleanUpGlobalStatic (this=0xb7d651d0, __in_chrg=<value optimized out>) at /media/kdesvn/kde4svn/src/kdelibs/kdecore/kernel/kglobal.h:62
#17 0xb654d559 in exit () from /lib/i686/cmov/libc.so.6
#18 0x0804e95b in launch (argc=2, _name=0x9ad477c "konqueror", args=0x9ad47df "/home/rserral/Documents", cwd=0x9ad47df "/home/rserral/Documents", envc=41, envs=0x9ad4dde "", reset_env=true, tty=0x0, 
    avoid_loops=false, startup_id_str=0x9ad4de2 "0") at /media/kdesvn/kde4svn/src/kdelibs/kinit/kinit.cpp:676
#19 0x0804f0c2 in handle_launcher_request (sock=16, who=0x80527fc "wrapper") at /media/kdesvn/kde4svn/src/kdelibs/kinit/kinit.cpp:1168
#20 0x0804f9c9 in handle_requests (waitForPid=0) at /media/kdesvn/kde4svn/src/kdelibs/kinit/kinit.cpp:1352
#21 0x080503d6 in main (argc=2, argv=0xbfcb42f4, envp=0xbfcb4300) at /media/kdesvn/kde4svn/src/kdelibs/kinit/kinit.cpp:1788

This bug may be a duplicate of or related to bug 166637

Reported using DrKonqi
Comment 1 FiNeX 2009-07-09 10:34:43 UTC

*** This bug has been marked as a duplicate of bug 151453 ***