Bug 199748 - I'm trying to add new default software to associate with a mimetype but got this crash instead, actually, for me, KBuildSyscoca always crash with this KDE 4.3 RC1.
Summary: I'm trying to add new default software to associate with a mimetype but got t...
Status: RESOLVED DUPLICATE of bug 202871
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: ksycoca (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
: 216210 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-07-11 07:11 UTC by BLeAm
Modified: 2009-11-27 23:05 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description BLeAm 2009-07-11 07:11:26 UTC
Application that crashed: kbuildsycoca4
Version of the application: 1.1
KDE Version: 4.2.95 (KDE 4.2.95 (KDE 4.3 RC1))
Qt Version: 4.5.0
Operating System: Linux 2.6.30-020630-generic i686
Distribution: Ubuntu 9.04

 -- Backtrace:
Application: KBuildSycoca (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  KSycocaEntry::offset (this=0x8128328) at /build/buildd/kde4libs-4.2.95/kdecore/sycoca/ksycocaentry.cpp:132
#7  0xb3ba5b6f in KBuildMimeTypeFactory::save (this=0x8128328, str=@0x8144228) at /build/buildd/kde4libs-4.2.95/kded/kbuildmimetypefactory.cpp:306
#8  0xb3b9e354 in KBuildSycoca::save (this=0x85f5018, str=0x8144228) at /build/buildd/kde4libs-4.2.95/kded/kbuildsycoca.cpp:525
#9  0xb3ba04d5 in KBuildSycoca::recreate (this=0x85f5018) at /build/buildd/kde4libs-4.2.95/kded/kbuildsycoca.cpp:433
#10 0xb3ba24a3 in kdemain (argc=2, argv=0x80b3080) at /build/buildd/kde4libs-4.2.95/kded/kbuildsycoca.cpp:829
#11 0x0804e1c0 in launch (argc=2, _name=0x80b3134 "/usr/bin/kbuildsycoca4", args=0x80b3158 "", cwd=0x0, envc=0, envs=0x80b315d "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x80b3161 "") at /build/buildd/kde4libs-4.2.95/kinit/kinit.cpp:672
#12 0x0804e99d in handle_launcher_request (sock=7, who=<value optimized out>) at /build/buildd/kde4libs-4.2.95/kinit/kinit.cpp:1164
#13 0x0804ef25 in handle_requests (waitForPid=0) at /build/buildd/kde4libs-4.2.95/kinit/kinit.cpp:1357
#14 0x0804fb0a in main (argc=2, argv=0xbfd17124, envp=0xbfd17130) at /build/buildd/kde4libs-4.2.95/kinit/kinit.cpp:1784

Reported using DrKonqi
Comment 1 Dario Andres 2009-07-11 13:03:04 UTC
Did you also used "Kubuntu Backports PPA" as bug 199300 ?
Thanks
Comment 2 BLeAm 2009-07-11 14:18:03 UTC
I'm not so sure whether does this help, but in my case, I've removed .local and .config which is located in home directory(Additional, I've also removed all FILES in ~/.kde/cache-{systemname}/ and all FILES in ~/.kde/cache-{systemname}/kpc.) then re-login and that crash of kbuildsyscoca4 has gone.
Comment 3 Christoph Feck 2009-11-26 23:49:49 UTC
*** Bug 216210 has been marked as a duplicate of this bug. ***
Comment 4 David Faure 2009-11-27 23:05:33 UTC
Same crash as 202871 (using that one since it has a better description)

*** This bug has been marked as a duplicate of bug 202871 ***