Bug 199430 - Sliding desktops slide in the wrong direction for 4x2 virtual desktop arrangements
Summary: Sliding desktops slide in the wrong direction for 4x2 virtual desktop arrange...
Status: RESOLVED DUPLICATE of bug 185710
Alias: None
Product: kwin
Classification: Unclassified
Component: compatibility (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-08 15:40 UTC by Roey Katz
Modified: 2010-06-12 12:39 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roey Katz 2009-07-08 15:40:58 UTC
Version:            (using KDE 4.2.90)
Compiler:          gcc 4.x 
OS:                Linux
Installed from:    Unspecified

To replicate: 

1.  Set Pager to display two rows of four desktops.
2.  Set desktop switching effect to Sliding Windows.
3.  Open some new windows on the upper-leftmost (1,1) and upper-rightmost (1,4) virtual desktops.
4.  Starting with desktop (1,1) at the upper-left corner, navigate to desktop (4,1) in the upper-right corner.  
5.  Focus on desktop (1,1).  Switch to desktop (4,1).  Windows will slide in the opposite direction than what is expected.  This is a bug which manifests for 4x2 arrangements but not for 2x2.
Comment 1 Beat Wolf 2009-07-08 16:20:37 UTC
this is a dupe, but i really can't remember where the other went. Probably a kwin bug?
Comment 2 Beat Wolf 2009-07-14 00:46:57 UTC
related?
https://bugs.kde.org/show_bug.cgi?id=198784
Comment 3 Andreas Pietzowski 2010-02-14 13:58:31 UTC
This bug is still there in KDE 4.4.0 and also happens with my setup of x=3 and y=2 desktops. It's not a grave bug but sure it is just a formula mistake in the source code and could be fixed easily. Please someone should grab that issue.
Comment 4 Marco Martin 2010-06-12 12:00:50 UTC
i think this is -really- a kwin issue?
Comment 5 Martin Flöser 2010-06-12 12:39:22 UTC

*** This bug has been marked as a duplicate of bug 185710 ***