Bug 197404 - crash on application shutdown
Summary: crash on application shutdown
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-21 18:48 UTC by Vincenzo Di Massa
Modified: 2009-06-21 22:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vincenzo Di Massa 2009-06-21 18:48:08 UTC
Application that crashed: konqueror
Version of the application: 4.2.90 (KDE 4.2.90 (KDE 4.3 Beta2))
KDE Version: 4.2.90 (KDE 4.2.90 (KDE 4.3 Beta2))
Qt Version: 4.5.1
Operating System: Linux 2.6.29-sabayon x86_64
Distribution: "Gentoo Base System release 2.0.0"

 -- Backtrace:
Application: Konqueror (kdeinit), signal: Aborted
[KCrash Handler]
#5  0x00007f66d85a8225 in raise () from /lib/libc.so.6
#6  0x00007f66d85a9743 in abort () from /lib/libc.so.6
#7  0x00007f66d85a10a9 in __assert_fail () from /lib/libc.so.6
#8  0x00007f66c480b4d2 in KHTMLGlobal::finalCheck () at /home/hawk/stanzino/kde/src/4/KDE/kdelibs/khtml/khtml_global.cpp:258
#9  0x00007f66c0b7c795 in ~KHTMLFactory (this=0xe65250) at /home/hawk/stanzino/kde/src/4/KDE/kdelibs/khtml/khtml_factory.cpp:35
#10 0x00007f66db973f31 in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0xaa7160}, end={i = 0xb659f0}) at /usr/local/kde4_trunk/qt/include/QtCore/qalgorithms.h:350
#11 0x00007f66db974159 in ~FactoryHash (this=0x2202) at /home/hawk/stanzino/kde/src/4/KDE/kdelibs/kdecore/util/klibrary.cpp:93
#12 0x00007f66db9732a2 in destroy () at /home/hawk/stanzino/kde/src/4/KDE/kdelibs/kdecore/util/klibrary.cpp:97
#13 0x00007f66d85aadcd in exit () from /lib/libc.so.6
#14 0x0000000000407059 in launch (argc=2, _name=0x6655d8 "/usr/local/kde4_trunk/kde4/bin/konqueror", args=0x665609 "", cwd=0x0, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x66561a "itshawk;1245597645;393570;7336_TIME1501809") at /home/hawk/stanzino/kde/src/4/KDE/kdelibs/kinit/kinit.cpp:672
#15 0x0000000000407961 in handle_launcher_request (sock=7, who=<value optimized out>) at /home/hawk/stanzino/kde/src/4/KDE/kdelibs/kinit/kinit.cpp:1164
#16 0x0000000000407fff in handle_requests (waitForPid=0) at /home/hawk/stanzino/kde/src/4/KDE/kdelibs/kinit/kinit.cpp:1357
#17 0x0000000000408799 in main (argc=2, argv=0x7fffe44d1a28, envp=0x7fffe44d1a40) at /home/hawk/stanzino/kde/src/4/KDE/kdelibs/kinit/kinit.cpp:1784

This bug may be a duplicate of or related to bug 195133

Reported using DrKonqi
Comment 1 Dario Andres 2009-06-21 22:00:04 UTC
Thanks

*** This bug has been marked as a duplicate of bug 151453 ***