Bug 195133 - Konqueror crashed when closing
Summary: Konqueror crashed when closing
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-03 20:06 UTC by Rosetzky Cedric
Modified: 2009-06-03 20:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rosetzky Cedric 2009-06-03 20:06:30 UTC
Application that crashed: konqueror
Version of the application: 4.2.88 (KDE 4.2.88 (KDE 4.3 >= 20090527))
KDE Version: 4.2.88 (KDE 4.2.88 (KDE 4.3 >= 20090527))
Qt Version: 4.5.1
Operating System: Linux 2.6.29-gentoo-r5 i686

What I was doing when the application crashed:
Konqueror crashed when I was closing it. It's not really annoying, but the backtrace could help (even if it is really close to the previous one).

 -- Backtrace:
Application: Konqueror (kdeinit), signal: Aborted
[KCrash Handler]
#6  0xffffe424 in __kernel_vsyscall ()
#7  0xb695a670 in raise () from /lib/libc.so.6
#8  0xb695beb8 in abort () from /lib/libc.so.6
#9  0xb695364e in __assert_fail () from /lib/libc.so.6
#10 0xb1cbc101 in KHTMLGlobal::finalCheck () at /home/loacoon/Documents/Downloads/SVN/KDE4/KDE/kdelibs/khtml/khtml_global.cpp:258
#11 0xafbde3a3 in ~KHTMLFactory (this=0x82cfc90) at /home/loacoon/Documents/Downloads/SVN/KDE4/KDE/kdelibs/khtml/khtml_factory.cpp:35
#12 0xb7e5de93 in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x85a15a0}, end={i = 0x860fc88}) at /usr/include/qt4/QtCore/qalgorithms.h:350
#13 0xb7e5def8 in qDeleteAll<FactoryHash> (c=@0x85fd998) at /usr/include/qt4/QtCore/qalgorithms.h:358
#14 0xb7e5e111 in ~FactoryHash (this=0x85fd998) at /home/loacoon/Documents/Downloads/SVN/KDE4/KDE/kdelibs/kdecore/util/klibrary.cpp:93
#15 0xb7e5cf99 in destroy () at /home/loacoon/Documents/Downloads/SVN/KDE4/KDE/kdelibs/kdecore/util/klibrary.cpp:97
#16 0xb7d21205 in ~KCleanUpGlobalStatic (this=0xb7eb9590) at /home/loacoon/Documents/Downloads/SVN/KDE4/KDE/kdelibs/kdecore/kernel/kglobal.h:62
#17 0xb695d561 in exit () from /lib/libc.so.6
#18 0x0804e934 in launch (argc=2, _name=0x80a8d54 "/home/loacoon/Program-Files/KDE4/bin/konqueror", args=0x80a8d8c "", cwd=0x0, envc=0, envs=0x80a8d90 "", reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x80a8d94 "PCLOACOON;1244051782;219425;24863_TIME18405200") at /home/loacoon/Documents/Downloads/SVN/KDE4/KDE/kdelibs/kinit/kinit.cpp:671
#19 0x0804f09b in handle_launcher_request (sock=7, who=0x80527c4 "launcher") at /home/loacoon/Documents/Downloads/SVN/KDE4/KDE/kdelibs/kinit/kinit.cpp:1163
#20 0x0804f9c4 in handle_requests (waitForPid=0) at /home/loacoon/Documents/Downloads/SVN/KDE4/KDE/kdelibs/kinit/kinit.cpp:1356
#21 0x08050393 in main (argc=2, argv=0xbfee3904, envp=0xbfee3910) at /home/loacoon/Documents/Downloads/SVN/KDE4/KDE/kdelibs/kinit/kinit.cpp:1783

This bug may be a duplicate of or related to bug 194244

Reported using DrKonqi
Comment 1 Dario Andres 2009-06-03 20:20:34 UTC
Marking as duplicate of bug 151453. Thanks

*** This bug has been marked as a duplicate of bug 151453 ***