Bug 196543 - crash while playing with window switching
Summary: crash while playing with window switching
Status: RESOLVED DUPLICATE of bug 179865
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-15 00:25 UTC by Wolfgang Rohdewald
Modified: 2009-06-15 01:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Rohdewald 2009-06-15 00:25:51 UTC
Application that crashed: kwin
Version of the application: 4.2.90 (KDE 4.2.90 (KDE 4.3 Beta2))
KDE Version: 4.2.90 (KDE 4.2.90 (KDE 4.3 Beta2))
Qt Version: 4.5.0
Operating System: Linux 2.6.28-11-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
After installing experimental Xorg packages for newer intel drivers, playing with window switching options. The box switch crashes, the others do not.

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#6  0x070000dd in ?? ()
#7  0xa9690c9e in KWin::BoxSwitchEffect::paintWindowThumbnail (this=0xa49b838, w=0xa47b0a0) at /build/buildd/kdebase-workspace-4.2.90/kwin/effects/boxswitch/boxswitch.cpp:747
#8  0xa9692afa in KWin::BoxSwitchEffect::paintScreen (this=0xa49b838, mask=0, region={d = 0xbffd06e8, static shared_empty = {ref = {_q_value = 406}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbffd0928) at /build/buildd/kdebase-workspace-4.2.90/kwin/effects/boxswitch/boxswitch.cpp:157
#9  0xb807c46f in KWin::EffectsHandlerImpl::paintScreen (this=0xa25bf98, mask=0, region={d = 0xbffd0728, static shared_empty = {ref = {_q_value = 406}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbffd0928) at /build/buildd/kdebase-workspace-4.2.90/kwin/effects.cpp:122
#10 0xb7fa0d26 in KWin::Effect::paintScreen (this=0xa469f00, mask=0, region={d = 0xbffd0768, static shared_empty = {ref = {_q_value = 406}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbffd0928) at /build/buildd/kdebase-workspace-4.2.90/kwin/lib/kwineffects.cpp:206
#11 0xb807c46f in KWin::EffectsHandlerImpl::paintScreen (this=0xa25bf98, mask=0, region={d = 0xbffd07a8, static shared_empty = {ref = {_q_value = 406}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbffd0928) at /build/buildd/kdebase-workspace-4.2.90/kwin/effects.cpp:122
#12 0xb7fa0d26 in KWin::Effect::paintScreen (this=0xa469a38, mask=0, region={d = 0xbffd07e8, static shared_empty = {ref = {_q_value = 406}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbffd0928) at /build/buildd/kdebase-workspace-4.2.90/kwin/lib/kwineffects.cpp:206
#13 0xb807c46f in KWin::EffectsHandlerImpl::paintScreen (this=0xa25bf98, mask=0, region={d = 0xbffd0828, static shared_empty = {ref = {_q_value = 406}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbffd0928) at /build/buildd/kdebase-workspace-4.2.90/kwin/effects.cpp:122
#14 0xb7fa0d26 in KWin::Effect::paintScreen (this=0xa4305b8, mask=0, region={d = 0xbffd0868, static shared_empty = {ref = {_q_value = 406}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbffd0928) at /build/buildd/kdebase-workspace-4.2.90/kwin/lib/kwineffects.cpp:206
#15 0xb807c46f in KWin::EffectsHandlerImpl::paintScreen (this=0xa25bf98, mask=0, region={d = 0xbffd08a8, static shared_empty = {ref = {_q_value = 406}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbffd0928) at /build/buildd/kdebase-workspace-4.2.90/kwin/effects.cpp:122
#16 0xb7fa0d26 in KWin::Effect::paintScreen (this=0xa49b0c0, mask=0, region={d = 0xbffd08e8, static shared_empty = {ref = {_q_value = 406}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbffd0928) at /build/buildd/kdebase-workspace-4.2.90/kwin/lib/kwineffects.cpp:206
#17 0xb807c46f in KWin::EffectsHandlerImpl::paintScreen (this=0xa25bf98, mask=0, region={d = 0xbffd0980, static shared_empty = {ref = {_q_value = 406}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbffd0928) at /build/buildd/kdebase-workspace-4.2.90/kwin/effects.cpp:122
#18 0xb8065c70 in KWin::Scene::paintScreen (this=0xa487630, mask=0xbffd0a04, region=0xbffd0ac4) at /build/buildd/kdebase-workspace-4.2.90/kwin/scene.cpp:134
#19 0xb80755ca in KWin::SceneOpenGL::paint (this=0xa487630, damage={d = 0xbffd0ac4, static shared_empty = {ref = {_q_value = 406}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, toplevels=
        {{p = {static shared_null = {ref = {_q_value = 9740}, alloc = 0, begin = 0, end = 0, sharable = 1, array = {0x0}}, d = 0xbffd0ac0}, d = 0xbffd0ac0}})
    at /build/buildd/kdebase-workspace-4.2.90/kwin/scene_opengl.cpp:746
#20 0xb8060c76 in KWin::Workspace::performCompositing (this=0xa0ddcb8) at /build/buildd/kdebase-workspace-4.2.90/kwin/composite.cpp:412
#21 0xb7ff27dd in KWin::Workspace::qt_metacall (this=0xa0ddcb8, _c=QMetaObject::InvokeMetaMethod, _id=149, _a=0xbffd0b98)
    at /build/buildd/kdebase-workspace-4.2.90/obj-i486-linux-gnu/kwin/workspace.moc:473
#22 0xb6c3aca8 in QMetaObject::activate (sender=0xa0ddf1c, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3069
#23 0xb6c3b932 in QMetaObject::activate (sender=0xa0ddf1c, m=0xb6d17904, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3143
#24 0xb6c76717 in QTimer::timeout (this=0xa0ddf1c) at .moc/release-shared/moc_qtimer.cpp:128
#25 0xb6c406fe in QTimer::timerEvent (this=0xa0ddf1c, e=0xbffd103c) at kernel/qtimer.cpp:261
#26 0xb6c3515f in QObject::event (this=0xa0ddf1c, e=0xbffd103c) at kernel/qobject.cpp:1082
#27 0xb6ed1e9c in QApplicationPrivate::notify_helper (this=0x9fdadc0, receiver=0xa0ddf1c, e=0xbffd103c) at kernel/qapplication.cpp:4084
#28 0xb6eda19e in QApplication::notify (this=0xbffd1314, receiver=0xa0ddf1c, e=0xbffd103c) at kernel/qapplication.cpp:3631
#29 0xb7bf1e8d in KApplication::notify (this=0xbffd1314, receiver=0xa0ddf1c, event=0xbffd103c) at /build/buildd/kde4libs-4.2.90/kdeui/kernel/kapplication.cpp:302
#30 0xb800a1bd in KWin::Application::notify (this=0xbffd1314, o=0xa0ddf1c, e=0xbffd103c) at /build/buildd/kdebase-workspace-4.2.90/kwin/main.cpp:370
#31 0xb6c24a3b in QCoreApplication::notifyInternal (this=0xbffd1314, receiver=0xa0ddf1c, event=0xbffd103c) at kernel/qcoreapplication.cpp:602
#32 0xb6c53d71 in QTimerInfoList::activateTimers (this=0x9fddbc4) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#33 0xb6c504e0 in timerSourceDispatch (source=0x9fddb90) at kernel/qeventdispatcher_glib.cpp:164
#34 0xb503fb88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#35 0xb50430eb in ?? () from /usr/lib/libglib-2.0.so.0
#36 0xb5043268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#37 0xb6c50438 in QEventDispatcherGlib::processEvents (this=0x9fdada0, flags={i = -1073933896}) at kernel/qeventdispatcher_glib.cpp:323
#38 0xb6f73365 in QGuiEventDispatcherGlib::processEvents (this=0x9fdada0, flags={i = -1073933848}) at kernel/qguieventdispatcher_glib.cpp:202
#39 0xb6c2306a in QEventLoop::processEvents (this=0xbffd1260, flags={i = -1073933784}) at kernel/qeventloop.cpp:149
#40 0xb6c234aa in QEventLoop::exec (this=0xbffd1260, flags={i = -1073933720}) at kernel/qeventloop.cpp:200
#41 0xb6c25959 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:880
#42 0xb6ed1d17 in QApplication::exec () at kernel/qapplication.cpp:3553
#43 0xb800c943 in kdemain (argc=3, argv=0xbffd14f4) at /build/buildd/kdebase-workspace-4.2.90/kwin/main.cpp:525
#44 0x08048742 in main (argc=-1452236440, argv=0xb67ea201) at /build/buildd/kdebase-workspace-4.2.90/obj-i486-linux-gnu/kwin/kwin_dummy.cpp:3

This bug may be a duplicate of or related to bug 182341

Reported using DrKonqi
Comment 1 Wolfgang Rohdewald 2009-06-15 00:28:27 UTC
In the crash report dialog I checked more than one other bug report as possible duplicate, but the above text only shows one of them. Seems like a bug in DrKonqi to me.
Comment 2 Dario Andres 2009-06-15 01:37:39 UTC
The same as bug 196000 and bug 179865. Marking as duplicate.
BTW: about the DrKonqi issue, it is a known limitation as this is the first release of the reporting assistant, we will be working on it.
Thanks

*** This bug has been marked as a duplicate of bug 179865 ***