Bug 182341 - 'Box switch' crashes when active while window is closing
Summary: 'Box switch' crashes when active while window is closing
Status: RESOLVED DUPLICATE of bug 179865
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Unspecified
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-29 20:54 UTC by Jos van den Oever
Modified: 2009-02-09 11:28 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jos van den Oever 2009-01-29 20:54:36 UTC
Version:            (using KDE 4.2.0)
Installed from:    Ubuntu Packages

 - enable 'Box switch' under 'alt-tab'
 - close a window which takes some time to close, e.g. firefox with many open tabs
 - hold 'alt' and press tab

The result:

Application: KWin (kwin), signal SIGSEGV

Thread 1 (Thread 0xb650d6c0 (LWP 5830)):
[KCrash Handler]
#6  0xb6bbd91d in vtable for __cxxabiv1::__si_class_type_info () from /usr/lib/libstdc++.so.6
#7  0xb7f65062 in WindowPaintData (this=0xbfd80160, w=0x84c1148) at /build/buildd/kdebase-workspace-4.2.0/kwin/lib/kwineffects.cpp:74
#8  0xb4cad53c in KWin::BoxSwitchEffect::paintWindowThumbnail (this=0x837fe08, w=0x84c1148) at /build/buildd/kdebase-workspace-4.2.0/kwin/effects/boxswitch.cpp:761
#9  0xb4cb0822 in KWin::BoxSwitchEffect::paintScreen (this=0x837fe08, mask=0, region={d = 0xbfd803d8, static shared_empty = {ref = {_q_value = 117}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbfd80498) at /build/buildd/kdebase-workspace-4.2.0/kwin/effects/boxswitch.cpp:147
#10 0xb8033066 in KWin::EffectsHandlerImpl::paintScreen (this=0x83620e8, mask=0, region={d = 0xbfd80418, static shared_empty = {ref = {_q_value = 117}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbfd80498) at /build/buildd/kdebase-workspace-4.2.0/kwin/effects.cpp:121
#11 0xb7f631e6 in KWin::Effect::paintScreen (this=0x83998c0, mask=0, region={d = 0xbfd80458, static shared_empty = {ref = {_q_value = 117}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbfd80498) at /build/buildd/kdebase-workspace-4.2.0/kwin/lib/kwineffects.cpp:199
#12 0xb8033066 in KWin::EffectsHandlerImpl::paintScreen (this=0x83620e8, mask=0, region={d = 0xbfd804f0, static shared_empty = {ref = {_q_value = 117}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    data=@0xbfd80498) at /build/buildd/kdebase-workspace-4.2.0/kwin/effects.cpp:121
#13 0xb801da00 in KWin::Scene::paintScreen (this=0x83390d8, mask=0xbfd80574, region=0xbfd80634) at /build/buildd/kdebase-workspace-4.2.0/kwin/scene.cpp:133
#14 0xb8029b1a in KWin::SceneOpenGL::paint (this=0x83390d8, damage={d = 0xbfd80634, static shared_empty = {ref = {_q_value = 117}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, toplevels=
        {{p = {static shared_null = {ref = {_q_value = 2923}, alloc = 0, begin = 0, end = 0, sharable = 1, array = {0x0}}, d = 0xbfd80630}, d = 0xbfd80630}})
    at /build/buildd/kdebase-workspace-4.2.0/kwin/scene_opengl.cpp:724
#15 0xb8018c56 in KWin::Workspace::performCompositing (this=0x8335378) at /build/buildd/kdebase-workspace-4.2.0/kwin/composite.cpp:386
#16 0xb7faff3d in KWin::Workspace::qt_metacall (this=0x8335378, _c=QMetaObject::InvokeMetaMethod, _id=140, _a=0xbfd80708)
    at /build/buildd/kdebase-workspace-4.2.0/obj-i486-linux-gnu/kwin/workspace.moc:443
#17 0xb6ee2a60 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#18 0xb6ee37e2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#19 0xb6f1d7a7 in QTimer::timeout () from /usr/lib/libQtCore.so.4
#20 0xb6ee940e in QTimer::timerEvent () from /usr/lib/libQtCore.so.4
#21 0xb6edd53f in QObject::event () from /usr/lib/libQtCore.so.4
#22 0xb715e8ec in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#23 0xb716672e in QApplication::notify () from /usr/lib/libQtGui.so.4
#24 0xb7d9b06d in KApplication::notify (this=0xbfd80e98, receiver=0x83355cc, event=0xbfd80bbc) at /build/buildd/kde4libs-4.2.0/kdeui/kernel/kapplication.cpp:307
#25 0xb7fc7d0d in KWin::Application::notify (this=0xbfd80e98, o=0x83355cc, e=0xbfd80bbc) at /build/buildd/kdebase-workspace-4.2.0/kwin/main.cpp:368
#26 0xb6ecde61 in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#27 0xb6efbd81 in ?? () from /usr/lib/libQtCore.so.4
#28 0xb6ef8520 in ?? () from /usr/lib/libQtCore.so.4
#29 0xb66f66f8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#30 0xb66f9da3 in ?? () from /usr/lib/libglib-2.0.so.0
#31 0xb66f9f61 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#32 0xb6ef8478 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#33 0xb71f8ea5 in ?? () from /usr/lib/libQtGui.so.4
#34 0xb6ecc52a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#35 0xb6ecc6ea in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#36 0xb6eceda5 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#37 0xb715e767 in QApplication::exec () from /usr/lib/libQtGui.so.4
#38 0xb7fcbce2 in kdemain (argc=3, argv=0xbfd81074) at /build/buildd/kdebase-workspace-4.2.0/kwin/main.cpp:519
#39 0x08048732 in main (argc=) at /build/buildd/kdebase-workspace-4.2.0/obj-i486-linux-gnu/kwin/kwin_dummy.cpp:3
Comment 1 Martin Flöser 2009-02-09 11:28:24 UTC

*** This bug has been marked as a duplicate of bug 179865 ***