Bug 194244 - konqueror crashed for no obvious reason
Summary: konqueror crashed for no obvious reason
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-27 01:59 UTC by simon
Modified: 2009-05-27 02:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description simon 2009-05-27 01:59:38 UTC
Application that crashed: konqueror
Version of the application: 4.2.86 (KDE 4.2.86 (KDE 4.3 >= 20090514))
KDE Version: 4.2.87 (KDE 4.2.87 (KDE 4.3 >= 20090519))
Qt Version: 4.5.1
Operating System: Linux 2.6.30-rc6-git3 x86_64

What I was doing when the application crashed:

hi,

actually i have no real idea what triggered this, but you guys will find out ;)

 -- Backtrace:
Application: Konqueror (kdeinit), signal: Aborted
[KCrash Handler]
#5  0x00007fc97e6d4165 in raise () from /lib/libc.so.6
#6  0x00007fc97e6d54de in abort () from /lib/libc.so.6
#7  0x00007fc97e6cd49f in __assert_fail () from /lib/libc.so.6
#8  0x00007fc96f6c4689 in KHTMLGlobal::finalCheck () at /var/tmp/portage/kde-base/kdelibs-9999-r1/work/kdelibs-9999/khtml/khtml_global.cpp:258
#9  0x00007fc96feb583e in ~KHTMLFactory (this=0x9f51f0) at /var/tmp/portage/kde-base/kdelibs-9999-r1/work/kdelibs-9999/khtml/khtml_factory.cpp:35
#10 0x00007fc9818a0651 in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x9f9e00}, end={i = 0x9f4510}) at /usr/include/qt4/QtCore/qalgorithms.h:350
#11 0x00007fc9818a09d9 in ~FactoryHash (this=0x3e40) at /var/tmp/portage/kde-base/kdelibs-9999-r1/work/kdelibs-9999/kdecore/util/klibrary.cpp:93
#12 0x00007fc98189f8d2 in destroy () at /var/tmp/portage/kde-base/kdelibs-9999-r1/work/kdelibs-9999/kdecore/util/klibrary.cpp:97
#13 0x00007fc97e6d6aa9 in exit () from /lib/libc.so.6
#14 0x00000000004074f7 in launch (argc=2, _name=0x659578 "konqueror", args=0x65959d "", cwd=0x65959e "/home/user", envc=73, envs=<value optimized out>, reset_env=true, tty=0x0, avoid_loops=false, 
    startup_id_str=0x65a40d "0") at /var/tmp/portage/kde-base/kdelibs-9999-r1/work/kdelibs-9999/kinit/kinit.cpp:667
#15 0x0000000000407925 in handle_launcher_request (sock=10, who=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-9999-r1/work/kdelibs-9999/kinit/kinit.cpp:1159
#16 0x0000000000408271 in handle_requests (waitForPid=0) at /var/tmp/portage/kde-base/kdelibs-9999-r1/work/kdelibs-9999/kinit/kinit.cpp:1343
#17 0x0000000000408706 in main (argc=2, argv=0x7fff7558cee8, envp=0x7fff7558cf00) at /var/tmp/portage/kde-base/kdelibs-9999-r1/work/kdelibs-9999/kinit/kinit.cpp:1779
Comment 1 A. Spehr 2009-05-27 02:16:13 UTC
Thanks!

*** This bug has been marked as a duplicate of bug 192393 ***
Comment 2 A. Spehr 2009-05-27 02:26:07 UTC
...better report to mark to

*** This bug has been marked as a duplicate of bug 151453 ***