Bug 194478 - Konqueror crashes on close leaving nsviewer.bin open
Summary: Konqueror crashes on close leaving nsviewer.bin open
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-28 22:41 UTC by Sascha Peilicke
Modified: 2009-05-29 04:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sascha Peilicke 2009-05-28 22:41:14 UTC
Application that crashed: konqueror
Version of the application: 4.2.88 (KDE 4.2.88 (KDE 4.3 >= 20090527))
KDE Version: 4.2.88 (KDE 4.2.88 (KDE 4.3 >= 20090527))
Qt Version: 4.5.1
Operating System: Linux 2.6.27.21-0.1-default x86_64
Distribution: "openSUSE 11.1 (x86_64)"

What I was doing when the application crashed:
nsviewer.bin still open, thus could somehow be related to the flash player plugin still open from another session. this session (which crashed) was actually empty, just one open google page.

 -- Backtrace:
Application: Konqueror (kdeinit), signal: Aborted
[KCrash Handler]
#5  0x00007f1028808645 in raise () from /lib64/libc.so.6
#6  0x00007f1028809c33 in abort () from /lib64/libc.so.6
#7  0x00007f1028801329 in __assert_fail () from /lib64/libc.so.6
#8  0x00007f101a4cc2c2 in KHTMLGlobal::finalCheck () at /home/saschpe/projects/kde/src/trunk/KDE/kdelibs/khtml/khtml_global.cpp:258
#9  0x00007f1014b7a795 in ~KHTMLFactory (this=0xf6b5c0) at /home/saschpe/projects/kde/src/trunk/KDE/kdelibs/khtml/khtml_factory.cpp:35
#10 0x00007f102bac6cc1 in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x116ba20}, end={i = 0xe716d0}) at /usr/include/QtCore/qalgorithms.h:350
#11 0x00007f102bac6ee9 in ~FactoryHash (this=0x18cd) at /home/saschpe/projects/kde/src/trunk/KDE/kdelibs/kdecore/util/klibrary.cpp:93
#12 0x00007f102bac6032 in destroy () at /home/saschpe/projects/kde/src/trunk/KDE/kdelibs/kdecore/util/klibrary.cpp:97
#13 0x00007f102880b2ed in exit () from /lib64/libc.so.6
#14 0x0000000000407039 in launch (argc=2, _name=0x660228 "/home/saschpe/projects/kde/dist/bin/konqueror", args=0x66025e "", cwd=0x0, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x66026f "festor;1243525287;496956;6238_TIME554387") at /home/saschpe/projects/kde/src/trunk/KDE/kdelibs/kinit/kinit.cpp:671
#15 0x0000000000407941 in handle_launcher_request (sock=7, who=<value optimized out>) at /home/saschpe/projects/kde/src/trunk/KDE/kdelibs/kinit/kinit.cpp:1163
#16 0x0000000000407fdf in handle_requests (waitForPid=0) at /home/saschpe/projects/kde/src/trunk/KDE/kdelibs/kinit/kinit.cpp:1356
#17 0x0000000000408779 in main (argc=2, argv=0x7fff345ed558, envp=0x7fff345ed570) at /home/saschpe/projects/kde/src/trunk/KDE/kdelibs/kinit/kinit.cpp:1783

This bug may be a duplicate of or related to bug 194244

Reported using DrKonqi
Comment 1 A. Spehr 2009-05-29 04:56:11 UTC
Yep. Thanks!

*** This bug has been marked as a duplicate of bug 151453 ***