Bug 192393 - konqueror crash closing window
Summary: konqueror crash closing window
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: khtml (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-12 06:30 UTC by Andrey Borzenkov
Modified: 2011-07-25 12:35 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Borzenkov 2009-05-12 06:30:40 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

KDE 4.2.85/Qt 4.5.1 (why Bugzilla won't let me select this version?) as shipped by Mandriva.

I cicked on URL in KMail message (KDE bugzila :) ), looked at a bug and closed window using Close button in upper right. Konqueror aborted.

Application: Konqueror (konqueror), signal: Aborted
[KCrash Handler]
#5  0x00007fba63b9ea15 in raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#6  0x00007fba63ba0243 in abort () at abort.c:88
#7  0x00007fba63b97849 in __assert_fail (assertion=0x7fba530253b9 "!s_refcnt", file=0x7fba53025328 "/home/mandrake/rpm/BUILD/kdelibs-4.2.85/khtml/khtml_global.cpp", line=258, 
    function=0x7fba53025540 "static void KHTMLGlobal::finalCheck()") at assert.c:78
#8  0x00007fba52ceedf2 in KHTMLGlobal::finalCheck () at /usr/src/debug/kdelibs-4.2.85/khtml/khtml_global.cpp:258
#9  0x00007fba534e4535 in ~KHTMLFactory (this=0x11cfda0) at /usr/src/debug/kdelibs-4.2.85/khtml/khtml_factory.cpp:35
#10 0x00007fba61f45591 in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x11cfcc0}, end={i = 0x11c5f30}) at /usr/lib/qt4/include/QtCore/qalgorithms.h:350
#11 0x00007fba61f457b9 in ~FactoryHash (this=0x3a1b) at /usr/src/debug/kdelibs-4.2.85/kdecore/util/klibrary.cpp:93
#12 0x00007fba61f44902 in destroy () at /usr/src/debug/kdelibs-4.2.85/kdecore/util/klibrary.cpp:97
#13 0x00007fba63ba18fd in exit (status=0) at exit.c:75
#14 0x00007fba63b8b44d in __libc_start_main (main=0x4006d0 <main>, argc=4, ubp_av=0x7fff6c3ea058, init=0x400700 <__libc_csu_init>, fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7fff6c3ea048) at libc-start.c:252
#15 0x0000000000400609 in _start () at ../sysdeps/x86_64/elf/start.S:113
Comment 1 Dario Andres 2009-05-12 14:29:57 UTC
Looks like a variation of the common bug 151453
Thanks
Comment 2 A. Spehr 2009-05-27 02:16:13 UTC
*** Bug 194244 has been marked as a duplicate of this bug. ***
Comment 3 Martin Koller 2011-07-25 12:35:14 UTC

*** This bug has been marked as a duplicate of bug 151453 ***