Bug 193336 - Fill Light tool request
Summary: Fill Light tool request
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Editor-LocalContrast (show other bugs)
Version: 0.10.0
Platform: Ubuntu Packages Unspecified
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-20 11:29 UTC by Dotan Cohen
Modified: 2022-01-12 21:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 6.2.0


Attachments
Unmodified image, with dark area. The image needs fixing. (42.17 KB, image/png)
2009-05-20 11:37 UTC, Dotan Cohen
Details
This is the image after Colour -> Auto Correction -> Equalize (54.82 KB, image/png)
2009-05-20 11:43 UTC, Dotan Cohen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2009-05-20 11:29:21 UTC
Version:            (using KDE 4.2.3)
Installed from:    Ubuntu Packages

The no-longer available application BrilliantPhoto had a terrific Fill Flash enhancement. This enhancement worked as the current Colour -> Auto Correction -> Equalize worked, however, it modified the image in an uneven fashion. The darker areas would get full treatment, and the lighter areas would get less  effect, thereby preventing the overexposed appearance.
Comment 1 Dotan Cohen 2009-05-20 11:37:18 UTC
Created attachment 33850 [details]
Unmodified image, with dark area. The image needs fixing.
Comment 2 Dotan Cohen 2009-05-20 11:43:23 UTC
Created attachment 33851 [details]
This is the image after Colour -> Auto Correction -> Equalize 

In this image, the darker areas now look acceptable, but the lighter areas are completely ruined. Had the processing been applied in a scale relative to the darkness of the particular pixel in question, the entire image would look acceptable.
Comment 3 caulier.gilles 2009-05-20 12:55:35 UTC
Do you ask for a tool make high-key image ?

http://en.wikipedia.org/wiki/High-key_lighting

Gilles Caulier
Comment 4 Mikolaj Machowski 2009-05-20 13:59:19 UTC
I think this is more like "Fill Light" option of Lightroom/Photoshop. Short description:

Not quite sure what the Fill Light slider is doing? Well, think of it this way - when you adjust your Exposure setting, Lightroom will tend to make the entire photo brighter. This may be fine most of the time but it may eventually push some of your highlight areas to the point where they're clipped and become all white. If you reach that point and you'd still like to make the photo brighter, you can resort to the Fill Light slider. This will adjust the midtone areas of the photo and will, for the most part, leave your extreme highlights alone. It's a good way to brighten the overall photo without blowing out your highlight areas.

From: http://www.lightroomkillertips.com/2007/fill-light/

On Linux you can see implementation eg. in Raw Therapee.

This is related to:
Bug 181736
Bug 160012
Bug 150533
Bug 148538
Bug 145442
Comment 5 Dotan Cohen 2009-05-20 14:21:04 UTC
That could be, Gilles. In fact, I do want to decrease the lighting ratio as I want to brighten only the darker areas. I am not looking for any special effects, the end result should be a photo that looks normal.

It is too bad that the BrilliantPhoto application is no longer available, I would have loved to post before and after pics from it.
Comment 6 Dotan Cohen 2009-05-20 14:22:52 UTC
> I think this is more like "Fill Light" option
> of Lightroom/Photoshop.

Yes, that seems similar. I will go through the related bugs and comment where necessary, and I will possibly mark this one as a dupe.
Comment 7 Mikolaj Machowski 2009-05-20 16:04:44 UTC
#6 Dotan

All six of them probably could be merged into one wish for Highlight/Shadows plugin.
Comment 8 Dotan Cohen 2009-05-20 21:27:00 UTC
@Mikolaj: I do not think that the actually bugs should be merged, as they are requesting (slightly) different features. But I do agree that such a plugin could be a solution to all of them.
Comment 9 Dotan Cohen 2009-05-20 21:27:14 UTC

*** This bug has been marked as a duplicate of bug 145442 ***
Comment 10 caulier.gilles 2019-07-28 16:59:53 UTC
Fixed with bug #145442