Bug 192060 - KDE window manager doesn't remember window sizes
Summary: KDE window manager doesn't remember window sizes
Status: RESOLVED DUPLICATE of bug 15329
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-08 19:19 UTC by Praedor Tempus
Modified: 2012-03-14 22:38 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Praedor Tempus 2009-05-08 19:19:05 UTC
Version:            (using KDE 4.2.2)
OS:                Linux
Installed from:    Mandriva RPMs

Every time I start up kontact, quassel, or start them anew, I have to resize the windows because kwin insists on drawing them too small.  Kwin should remember window sizes upon application closing or minimization or system shutdown and repaint them at the same size henceforth - until the user resizes to a different size.
Comment 1 Thomas Lübking 2009-05-08 19:32:42 UTC
geometries are stored by apps (in their rcs), at least for kontakt this works here

you may have setup a kwin rule overriding this

otherwise these apps fail to write their geometries because:
- you don't have write permissions on the config file (e.g. ~/.kde[4]/share/config/kontactrc)
- the app doesn't quit but segfaults

afaics kwin does not even restrict "stupid" size requests ( i once had a Height=0xfffffff entry for konqueror... :-\ )
Comment 2 Thomas Lübking 2012-03-14 22:38:57 UTC

*** This bug has been marked as a duplicate of bug 15329 ***