Bug 191375 - Windows position and size is not saved
Summary: Windows position and size is not saved
Status: RESOLVED DUPLICATE of bug 15329
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-02 20:51 UTC by XData
Modified: 2009-05-03 04:48 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description XData 2009-05-02 20:51:30 UTC
Version:            (using KDE 4.2.2)
OS:                Linux
Installed from:    I Don't Know

When i lauch for example:
- My home directory with dolphin
- Open office
- Kwrite
- etc.

The position and the size of the window is not stored and in the next lauch, the
window start not in the same position and the size is not the same compared to the previous position.

I think it is very good if the position and the size of each folders and application where
stored for the next launches.

Thanks.
Comment 1 lucas 2009-05-03 04:48:56 UTC
As the window manager cannot 100% accurately determine which window is which over multiple application sessions this is mostly impossible to implement. The only way for it to be accurate is to have the applications themselves remember the window position. Applications that use KMainWindow do this (Almost all KDE applications) but I don't think any other toolkit tries.

*** This bug has been marked as a duplicate of bug 15329 ***