Bug 190838 - Folder list columns visibility does not restored
Summary: Folder list columns visibility does not restored
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Unclassified
Component: new message list (show other bugs)
Version: 1.11.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 192781 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-04-27 16:57 UTC by Andrey Cherepanov
Modified: 2009-05-15 16:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Cherepanov 2009-04-27 16:57:23 UTC
Version:           1.11.2 (using 4.2.2 (KDE 4.2.2), ALT Linux i586)
Compiler:          gcc
OS:                Linux (i686) release 2.6.27-std-def-alt7

Step to reproduce:
1. Select Show columns - Total in folder list context menu.
(Total column now visible)
2. Exit KMail
3. Run KMail 
(Only folder name column is visible).
Comment 1 Jaime Torres 2009-04-27 17:25:24 UTC
It's a duplicate of bug #183515 or one of its other bugs.
I think I mixed them incorrectly.
Comment 2 Olivier Trichet 2009-05-12 23:17:33 UTC
SVN commit 967209 by otrichet:

Fix the restoring of the state of the columns (visibility and width)

- Do not dump binary data into KConfig

BUG: 190230
BUG: 190838

 M  +2 -1      treewidget.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=967209
Comment 3 Thomas McGuire 2009-05-13 15:15:37 UTC
SVN commit 967442 by tmcguire:

Backport r967209 by otrichet from trunk to the 4.2 branch:

Fix the restoring of the state of the columns (visibility and width)

- Do not dump binary data into KConfig

CCBUG: 190230
CCBUG: 190838


 M  +2 -1      treewidget.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=967442
Comment 4 Dario Andres 2009-05-15 16:57:46 UTC
*** Bug 192781 has been marked as a duplicate of this bug. ***