Bug 190059 - Changing feed URL "removes" old articles
Summary: Changing feed URL "removes" old articles
Status: RESOLVED FIXED
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Unspecified
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 167501 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-04-19 13:13 UTC by Mark Purcell
Modified: 2022-04-17 21:45 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Purcell 2009-04-19 13:13:55 UTC
Version:            (using KDE 3.5.10)
Installed from:    Debian testing/unstable Packages

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=402082
402082@bugs.debian.org

From: Shai Berger <shai@platonix.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: akregator: Changing feed URL "removes" old articles
Date: Fri, 08 Dec 2006 00:07:54 +0200

[Message part 1 (text/plain, inline)]
Package: akregator
Version: 4:3.5.5.dfsg.1-3
Severity: normal


This week, Slashdot changed the URL for their feed (while the old
feed is still, AFAICT, available, they've asked everyone to change
the URL). I edited the feed, and changed the URL. At first, all
seemed to be OK; the last bunch of articles showed up as new,
even though I've read most of them, which seemed logical.

But then, in order to check another bug, I upgraded (from 4:3.5.5.dfsg.1-2)
and restarted Kontact. The first thing I noticed was that the count of
unread slashdot articles was out of sync with the real number; I seemed
to have much more unread articles, all relatively new, then the tree
view indicated. I finished reading them, and indeed, while I never got
the tree to display a negative or integer-overflowed number, I did get
a lower number of new items in the folder than in a contained, sibling
feed (I'll try to attach the image).

Then, I realized all my old articles were nowhere to be seen. Of these,
about 10 were still marked "unread" (that is, I intended to read them
later), so I was a little bummed.

Checking ~/.kde/share/apps/akregator/Archive, I did find my missing items.
They were in a separate file now, because of the different URL.

So, I want them back where I can see them. Preferably in the same feed
as the new ones. Or, at the very least, the "edit feed properties" should
warn about the dangers of changing the URL.

Thanks,

        Shai.


-- System Information:
Debian Release: 4.0
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-3-686
Locale: LANG=en_US.utf-8, LC_CTYPE=en_US.utf-8 (charmap=UTF-8)

Versions of packages akregator depends on:
ii  kdelibs4c2a            4:3.5.5a.dfsg.1-5 core libraries and binaries for al
ii  libc6                  2.3.6.ds1-8       GNU C Library: Shared libraries
ii  libgcc1                1:4.1.1-20        GCC support library
ii  libkdepim1a            4:3.5.5.dfsg.1-3  KDE PIM library
ii  libqt3-mt              3:3.3.7-1         Qt GUI Library (Threaded runtime v
ii  libstdc++6             4.1.1-20          The GNU Standard C++ Library v3

akregator recommends no packages.

-- no debconf information

[akregator-counting-bug.png (image/png, attachment)]
Comment 1 Ricardo J. Barberis 2014-01-07 01:53:22 UTC
Confirmed on KDE SC 4.8.5. still haven't tried on 4.11.4.
Comment 2 Maarten De Meyer 2014-01-16 14:24:08 UTC
*** Bug 167501 has been marked as a duplicate of this bug. ***
Comment 3 Justin Zobel 2021-03-09 04:12:03 UTC
Thank you for the bug report.

As this report hasn't seen any changes in 5 years or more, we ask if you can please confirm that the issue still persists.

If this bug is no longer persisting or relevant please change the status to resolved.
Comment 4 Ricardo J. Barberis 2021-03-10 14:04:17 UTC
Yes, this bug seems to be fixed.

I just changed one of my rss feeds (https://blog.almalinux.org/feed/ -> https://almalinux.org/feed/) and the old articles are stil there.

You may close this issue.

Thanks!
Comment 5 Ricardo J. Barberis 2021-04-04 18:05:27 UTC
Well, I changed another feed's URL and lost that feed's articles :/

But this time I made a backup first so I could recover them.

The old URL is https://nagstamon.ifw-dresden.de/feed/ and the new one is https://nagstamon.de/feed

This time the domain part is different, maybe that's a clue?
Comment 6 auxsvr 2022-04-17 21:45:59 UTC
I've just been bitten by this with akregator-21.12.3.